summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-05-16 10:09:29 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-05-16 10:12:50 +0200
commit8811a0455941390aa7774b9d47b425ceae6edeef (patch)
tree4bcecc6774b87a8f4393ee55948d614155ac1e23 /sys-auth/ykpers
parentx11-themes/kvantum: remove 0.10.8 and 0.11.0-r0 (diff)
downloadgentoo-8811a0455941390aa7774b9d47b425ceae6edeef.tar.gz
gentoo-8811a0455941390aa7774b9d47b425ceae6edeef.tar.bz2
gentoo-8811a0455941390aa7774b9d47b425ceae6edeef.zip
sys-auth/ykpers: Version bump to 1.19.3
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'sys-auth/ykpers')
-rw-r--r--sys-auth/ykpers/Manifest1
-rw-r--r--sys-auth/ykpers/ykpers-1.19.3.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/sys-auth/ykpers/Manifest b/sys-auth/ykpers/Manifest
index c2587c06748e..5d485cb92028 100644
--- a/sys-auth/ykpers/Manifest
+++ b/sys-auth/ykpers/Manifest
@@ -1,3 +1,4 @@
DIST ykpers-1.18.0.tar.gz 124932 BLAKE2B 48e7045429081c1e577ca560b3a10a4cc380820add40526dbb2a8e0fe347eae79c1dff8335c5363148da55cb374e193230ecb6273b08566ef94959848ceb848e SHA512 d636fcabf94a3fb48841572b7b0f03a12a3b3243b11ed7377654d01c33c7282dc321ee13b13c1ee3f2a49fc5015e326a96ef5bc1594b8592d07c1e5aa0521d20
DIST ykpers-1.18.1.tar.gz 125397 BLAKE2B 7393373414f9f2f9474408c86b8abba0f2034f5908ab8c14fd1dbf9acab40994b43b19031a58f5e889acaf289869b82bd429199237da173e3fa19154b4424374 SHA512 faf9c98fc41a64ae17e2002cd22e89fa2f51de9941aa6eb10c49aa78fd2e2867a5d47fc91fd91ab8e916117cba08629f3f1b076d91698ac2fee6e43366d948a8
DIST ykpers-1.19.0.tar.gz 125960 BLAKE2B 8b0ce106ec0c6e390f13e960f26d64bf17e4f481f8bf4cdfb29f050bdbcc9f73750993caa00c46f6bc0c59a8cef0891d2d4fa97cea96084b0c9a762adfc3f81a SHA512 413f81325782f0d71501d3dbf5aaaf646bd5dc02d87308a7f650044dfe860dc13b7cef11afa8794df3049c729e10da33ffad86e3f148ac429ee64685bf0fe56e
+DIST ykpers-1.19.3.tar.gz 127789 BLAKE2B 8dfc2751be92e69fcf98f5dc75d87eb170a4f70ff13faa321a85d4a04e27818823acbf02284ba23cb78ea758111513457ced4cdaa6961621a91f68b059eff378 SHA512 436c9807e488f7b324b892da7bfc7ea93e2b746cc3ae075822e9e8bfe478ef8e61c194127e5d4f50f6c1d9512292640d033464cceb6b8a18069411ff7993cc52
diff --git a/sys-auth/ykpers/ykpers-1.19.3.ebuild b/sys-auth/ykpers/ykpers-1.19.3.ebuild
new file mode 100644
index 000000000000..1996fb57cb46
--- /dev/null
+++ b/sys-auth/ykpers/ykpers-1.19.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools udev
+
+DESCRIPTION="Library and tool for personalization of Yubico's YubiKey"
+SRC_URI="https://github.com/Yubico/yubikey-personalization/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/Yubico/yubikey-personalization"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="BSD-2"
+IUSE="static-libs consolekit"
+
+RDEPEND="
+ dev-libs/json-c:=
+ >=sys-auth/libyubikey-1.6
+ virtual/libusb:1"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ consolekit? ( sys-auth/consolekit[acl] )"
+
+S="${WORKDIR}/yubikey-personalization-${PV}"
+
+DOCS=( doc/. AUTHORS NEWS README )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --localstatedir=/var \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use consolekit && udev_dorules *.rules
+
+ find "${D}" -name '*.la' -delete || die
+}