summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-05-13 20:06:29 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-05-13 20:06:42 -0500
commit9df2787b4fc6afa7fd2f11f2ca103f0cf98e59e5 (patch)
tree0affbad7bebec09f0c78119e899c3e96329814a8 /sys-block/targetcli-fb
parentx11-libs/xcb-util-xrm: amd64 stable wrt bug #649316 (diff)
downloadgentoo-9df2787b4fc6afa7fd2f11f2ca103f0cf98e59e5.tar.gz
gentoo-9df2787b4fc6afa7fd2f11f2ca103f0cf98e59e5.tar.bz2
gentoo-9df2787b4fc6afa7fd2f11f2ca103f0cf98e59e5.zip
sys-block/targetcli-fb: revbup for bug 655542
Closes: https://bugs.gentoo.org/655542 Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'sys-block/targetcli-fb')
-rw-r--r--sys-block/targetcli-fb/targetcli-fb-2.1.48-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-block/targetcli-fb/targetcli-fb-2.1.48-r1.ebuild b/sys-block/targetcli-fb/targetcli-fb-2.1.48-r1.ebuild
new file mode 100644
index 000000000000..c1dfd9ed51b1
--- /dev/null
+++ b/sys-block/targetcli-fb/targetcli-fb-2.1.48-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 versionator
+
+MY_PV=$(replace_version_separator 2 '.fb' ${PV})
+
+DESCRIPTION="Command shell for managing Linux LIO kernel target"
+HOMEPAGE="https://github.com/open-iscsi/targetcli-fb"
+SRC_URI="https://github.com/open-iscsi/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/configshell-fb[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=dev-python/rtslib-fb-2.1.62[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ !sys-block/targetcli"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_install() {
+ distutils-r1_src_install
+
+ keepdir /etc/target /etc/target/backup
+ doman targetcli.8
+}