summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-08-02 16:10:42 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2023-08-02 16:10:42 -0500
commit2be4c6ec9645a481e832e7ece7f0730fd46b850f (patch)
treea639ef24a081537fa7ceb721aeae6678336a7876 /sys-block/tgt
parentsys-devel/boost-m4: Stabilize 0.4_p20221019 ALLARCHES, #911632 (diff)
downloadgentoo-2be4c6ec9645a481e832e7ece7f0730fd46b850f.tar.gz
gentoo-2be4c6ec9645a481e832e7ece7f0730fd46b850f.tar.bz2
gentoo-2be4c6ec9645a481e832e7ece7f0730fd46b850f.zip
sys-block/tgt: add 1.0.87
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'sys-block/tgt')
-rw-r--r--sys-block/tgt/Manifest1
-rw-r--r--sys-block/tgt/tgt-1.0.87.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sys-block/tgt/Manifest b/sys-block/tgt/Manifest
index bae6815c6b7d..4acb98a49afa 100644
--- a/sys-block/tgt/Manifest
+++ b/sys-block/tgt/Manifest
@@ -1 +1,2 @@
DIST tgt-1.0.86.tar.gz 304697 BLAKE2B 60233019e9f09dd4288ca70f398992452dc00f7a2f46d82e333a9e1bfa4fe5dcc8583da3d4ce4382b32c60b1b009dd03d36faa9770faa11222b9ec4592bd6d96 SHA512 f4e8e87691be2793c5eee9d7dc744ae3a7b47f710f559141f0533de345f727fb68223a3090282f5c51f70ea55fbf5936d81e3b08ce953b7ac48013295c32bef7
+DIST tgt-1.0.87.tar.gz 304798 BLAKE2B e8772a02078204373dd43276cc5534dd9e8996841bdfef613f34a9c59ef2886f866ff6fb56e6bdaea653b4081b477e1ab15cb3ed3d125b7c08b45ab11a63a7cb SHA512 362adfc92f9fc6528b3de0aa9f202e39f6035b92fe3078236a3f75c0aef540a82cb4594077fdc7de2e524acc75601f5696111cc9aebc6de6265c53cd1d073db2
diff --git a/sys-block/tgt/tgt-1.0.87.ebuild b/sys-block/tgt/tgt-1.0.87.ebuild
new file mode 100644
index 000000000000..fae52eca55dc
--- /dev/null
+++ b/sys-block/tgt/tgt-1.0.87.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs systemd
+
+DESCRIPTION="Linux SCSI target framework (tgt)"
+HOMEPAGE="https://github.com/fujita/tgt"
+SRC_URI="https://github.com/fujita/tgt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="fcoe fcp ibmvio infiniband rbd selinux"
+
+DEPEND="
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ dev-perl/Config-General
+ rbd? ( sys-cluster/ceph )
+ infiniband? ( sys-cluster/rdma-core )
+"
+RDEPEND="
+ ${DEPEND}
+ dev-libs/libaio
+ sys-apps/sg3_utils
+ selinux? ( sec-policy/selinux-tgtd )
+"
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ default
+ sed -i -e 's:\($(CC)\) $^:\1 $(LDFLAGS) $^:' usr/Makefile || die
+ # make sure xml docs are generated before trying to install them
+ sed -i -e "s@install: @& all @g" doc/Makefile || die
+ sed -i -e 's|-Werror||g' usr/Makefile || die
+}
+
+src_compile() {
+ local myconf
+ use ibmvio && myconf="${myconf} IBMVIO=1"
+ use infiniband && myconf="${myconf} ISCSI_RDMA=1"
+ use fcp && myconf="${myconf} FCP=1"
+ use fcoe && myconf="${myconf} FCOE=1"
+ use rbd && myconf="${myconf} CEPH_RBD=1"
+
+ emake -C usr/ KERNELSRC="${KERNEL_DIR}" ISCSI=1 ${myconf}
+ emake -C doc
+}
+
+src_install() {
+ emake install-programs install-scripts install-doc DESTDIR="${D}" docdir=/usr/share/doc/${PF}
+ newinitd "${FILESDIR}"/tgtd.initd tgtd
+ newconfd "${FILESDIR}"/tgtd.confd tgtd
+ systemd_dounit "${S}"/scripts/tgtd.service
+ dodir /etc/tgt
+ keepdir /etc/tgt
+}