summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Strypsteen <mathieu@strypsteen.me>2022-07-12 16:59:23 +0000
committerRick Farina <zerochaos@gentoo.org>2022-07-12 14:27:29 -0400
commit4ab4aacf953585804ca6fb7e8a94cf74fc5cc1c9 (patch)
tree53bb7ff952b49c01135bb7b420de8a9342f5bed4 /sys-boot
parentx11-terms/alacritty: fix installation failure (diff)
downloadgentoo-4ab4aacf953585804ca6fb7e8a94cf74fc5cc1c9.tar.gz
gentoo-4ab4aacf953585804ca6fb7e8a94cf74fc5cc1c9.tar.bz2
gentoo-4ab4aacf953585804ca6fb7e8a94cf74fc5cc1c9.zip
sys-boot/shim: add 15.6
Signed-off-by: Mathieu Strypsteen <mathieu@strypsteen.me> Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/shim/Manifest3
-rw-r--r--sys-boot/shim/shim-15.6.ebuild26
2 files changed, 29 insertions, 0 deletions
diff --git a/sys-boot/shim/Manifest b/sys-boot/shim/Manifest
index 1271dd5a569d..a622652fa023 100644
--- a/sys-boot/shim/Manifest
+++ b/sys-boot/shim/Manifest
@@ -1,3 +1,6 @@
DIST shim-aa64-15-5.aarch64.rpm 397028 BLAKE2B 4e89dd2029238e9b455c469b2857610bfa0d686c43a6f93b7daa70625317c68552967e6761e2c4912b098880c2ccf04278736ca51b7c2e95bcfc700a716bf69d SHA512 1d27ec70bf8b18777bb38cec6769172bd56aa72e9f910e9fa21039dc1c133ebf789fe46fbfe079df6167c3982f6c47bdcad26d3175d6cf9494f89dc9a8a0c823
+DIST shim-aa64-15.6-2.aarch64.rpm 466804 BLAKE2B 706f31835be24fee7202b8f8eb49204741d7726f106fad993ff524f475434ab3f23bebcd427f8a2aa4cd9a9c2494fdec9c2a49c29025364f0ebe989786f74c2f SHA512 72c2a62f380e76c3ea0fe5b13ef4e4bcd5e62e1b26b0b277c6ed8dd5d5e76f0f92770497da09e8ce12e6c60ee57d679d134f960a10639644dd751811563f1f29
DIST shim-ia32-15-5.x86_64.rpm 1026312 BLAKE2B 42f018888463b0da1edbb2ae7379e63b79cea84208ef7ce069c3753bad2f232cb156d73e16864da279c31e8f8f25daa01d6ccc16a6fd13daa286d88460232f9b SHA512 a5d297265480b6a77f05050ecb31b31d2275df0b2f9bfa5ef1a4851163501f295fb81c142aa9fd30826b9e001f876c3d864b3d7b2f89575e6839f3939bca4755
+DIST shim-ia32-15.6-2.x86_64.rpm 419081 BLAKE2B f7160dd1330bfd7ad2d64cfe370750f576f1e3291aa8bc8313d52869f3dd23228db8514e7578c2609428479e430a1d39c1992450f4f42197216c00c420a0a150 SHA512 045325802474f53c6e86eff1166f1a966268c9ad706fac4c08966f211dbc32fba21ed3a07c46445ec579ac1e2819a1313ff54d6169737806954962945c61bdc2
DIST shim-x64-15-5.x86_64.rpm 669944 BLAKE2B 25d7fb6a4869212610158313f9b8d55f102d6d4e8fc562a43b4654e29fcdb6cef4ba4421d56afb1ad98b7df1c7fe121558a757f06db86cc391ea0ad3e2f9982e SHA512 4888e9422d71f4f8f05343e8dc161f8e48a31ba28469fe3671ce20283e5f7fced656f2d0583d76532dddecc49c2a8504a504b5da951a1e2c6302bf38fac5048e
+DIST shim-x64-15.6-2.x86_64.rpm 479835 BLAKE2B 7d12b97275c25659f94a8dd4c8678eb7df9e11fd3258966cb65c762467f28744b9403e13d5b5c98d6d6a5244ce4d81ef31b9d802040be99da03c1bb56be21275 SHA512 971978bddee95a6a134ef05c4d88cf5df41926e631de863b74ef772307f3e106c82c8f6889c18280d47187986abd774d8671c5be4b85b1b0bb3d1858b65d02cf
diff --git a/sys-boot/shim/shim-15.6.ebuild b/sys-boot/shim/shim-15.6.ebuild
new file mode 100644
index 000000000000..30c5747e54d4
--- /dev/null
+++ b/sys-boot/shim/shim-15.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm
+
+DESCRIPTION="Fedora's signed UEFI shim"
+HOMEPAGE="https://src.fedoraproject.org/rpms/shim"
+SRC_URI="amd64? ( https://kojipkgs.fedoraproject.org/packages/shim/${PV}/2/x86_64/shim-x64-${PV}-2.x86_64.rpm
+ https://kojipkgs.fedoraproject.org/packages/shim/${PV}/2/x86_64/shim-ia32-${PV}-2.x86_64.rpm )
+ x86? ( https://kojipkgs.fedoraproject.org/packages/shim/${PV}/2/x86_64/shim-x64-${PV}-2.x86_64.rpm
+ https://kojipkgs.fedoraproject.org/packages/shim/${PV}/2/x86_64/shim-ia32-${PV}-2.x86_64.rpm )
+ arm64? ( https://kojipkgs.fedoraproject.org/packages/shim/${PV}/2/aarch64/shim-aa64-${PV}-2.aarch64.rpm )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+S="${WORKDIR}/boot/efi/EFI"
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins BOOT/BOOT*.EFI
+ doins fedora/mm*.efi
+}