summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-09-12 17:02:21 -0700
committerZac Medico <zmedico@gentoo.org>2018-09-12 17:53:56 -0700
commit39cc2487681b0d3aaaa1d06569d563e29c27f131 (patch)
tree4ff8451646aca430daecea8eba0a5842c47f22d9 /sys-fabric/mstflint
parentsys-kernel/rt-sources: remove old (diff)
downloadgentoo-39cc2487681b0d3aaaa1d06569d563e29c27f131.tar.gz
gentoo-39cc2487681b0d3aaaa1d06569d563e29c27f131.tar.bz2
gentoo-39cc2487681b0d3aaaa1d06569d563e29c27f131.zip
sys-fabric/mstflint: new package
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'sys-fabric/mstflint')
-rw-r--r--sys-fabric/mstflint/Manifest1
-rw-r--r--sys-fabric/mstflint/metadata.xml14
-rw-r--r--sys-fabric/mstflint/mstflint-4.10.0_p3.ebuild33
3 files changed, 48 insertions, 0 deletions
diff --git a/sys-fabric/mstflint/Manifest b/sys-fabric/mstflint/Manifest
new file mode 100644
index 000000000000..a1ba5d287b9c
--- /dev/null
+++ b/sys-fabric/mstflint/Manifest
@@ -0,0 +1 @@
+DIST mstflint-4.10.0_p3.tar.gz 3208065 BLAKE2B 9d27bc41f3af4af2d430814a892bc26b302f4a57b2287cca4d5a64a37d7dd1b47e3f167b671be9ef1fadaf5dc51dff6094db811951ef1b5c6ad3ce746eb78546 SHA512 72077557f032bfa9c2c0b94f485b58c2d9efa955281997fed605e6351b1cfe73c46d8e4f293f93b58ebc4315d47b3dc3a4e8d72c8938647d34d291a2db89198f
diff --git a/sys-fabric/mstflint/metadata.xml b/sys-fabric/mstflint/metadata.xml
new file mode 100644
index 000000000000..3a04694a94c0
--- /dev/null
+++ b/sys-fabric/mstflint/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">Mellanox/mstflint</remote-id>
+ </upstream>
+ <use>
+ <flag name="inband">Enable firmware updates for Mellanox SwitchX and ConnectIB devices</flag>
+ </use>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-fabric/mstflint/mstflint-4.10.0_p3.ebuild b/sys-fabric/mstflint/mstflint-4.10.0_p3.ebuild
new file mode 100644
index 000000000000..ed5c82cd271e
--- /dev/null
+++ b/sys-fabric/mstflint/mstflint-4.10.0_p3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Mstflint - an open source version of MFT (Mellanox Firmware Tools)"
+HOMEPAGE="https://github.com/Mellanox/mstflint"
+LICENSE="|| ( GPL-2 BSD-2 )"
+KEYWORDS="~amd64 ~x86"
+EGIT_COMMIT="941bf389b87686ca2be8d6a8fcf0b2ee22955ecc"
+MY_PV=${PV/_p/-}
+MY_P=""
+SRC_URI="${HOMEPAGE}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+IUSE="inband"
+SLOT="0"
+RDEPEND="inband? ( sys-fabric/libibmad )
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ default
+ echo '#define TOOLS_GIT_SHA "'${EGIT_COMMIT}'"' > ./common/gitversion.h || die
+}
+
+src_configure() {
+ eautoreconf
+ econf $(use_enable inband)
+ # /usr/bin/install: cannot create regular file '/var/tmp/portage/.../dev_mgt.py': File exists
+ sed -e 's:^dev_mgt_pylib_DATA = c_dev_mgt.so dev_mgt.py:dev_mgt_pylib_DATA = c_dev_mgt.so:' -i dev_mgt/Makefile || die
+}