summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-03-07 16:01:53 +0100
committerPacho Ramos <pacho@gentoo.org>2024-03-07 16:01:53 +0100
commit48c19d3872ddc2752da6396858f50522eca40287 (patch)
treee2f77544e32e27d2d848c11c268dea51ea9b47f7 /sys-firmware
parentapp-office/impressive: add 0.13.2 (diff)
downloadgentoo-48c19d3872ddc2752da6396858f50522eca40287.tar.gz
gentoo-48c19d3872ddc2752da6396858f50522eca40287.tar.bz2
gentoo-48c19d3872ddc2752da6396858f50522eca40287.zip
sys-firmware/sof-firmware: add 2023.12.1
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/sof-firmware/Manifest1
-rw-r--r--sys-firmware/sof-firmware/sof-firmware-2023.12.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-firmware/sof-firmware/Manifest b/sys-firmware/sof-firmware/Manifest
index 422eab2179c4..97b0e4a2536e 100644
--- a/sys-firmware/sof-firmware/Manifest
+++ b/sys-firmware/sof-firmware/Manifest
@@ -1,2 +1,3 @@
DIST sof-firmware-2023.09.2.tar.gz 5454975 BLAKE2B c5ac62245abbf2354d109070125c9e25c80d9a66c341a9e34e53b716c1cb4b15f9cc0ff18d005aba673621a5421824f9a8ce3655aaeb12e182b96ac2f1d91c54 SHA512 dbf9385c1900f0b0bda7b8b6a9d1a3b4e5556f0570a1b1b794104179a2e1a12f1e896e36062c4179d7ad1a55078cbbfb348eb10667d736ad99b6cd23c4af0832
+DIST sof-firmware-2023.12.1.tar.gz 5446189 BLAKE2B a901637ba25df51152f04c7db5330b70a18c92363b102c061568a4c3a8a7e2fc506ac9783abe715f680a27be8a040d63b7dd5b62682979ccf1e4eaeb30789d83 SHA512 e0175f3af5336f23548efcf8fa302bafbb6122fd173273203f687c05ee17fab4e7bd457b27cc7a62fd25ea77708ffdbf9e1fe3880d3df1cf2196d7073c6f7677
DIST sof-firmware-2023.12.tar.gz 5427762 BLAKE2B 48169378609119555f9b655599cef55e5722be71fdfc8fb71b699188fcb3f62a68e217fc3fec8859cd3e1c252f046208d5123c961dd824bd9b6559bd1fb72325 SHA512 ed43e7597c93140b15499ba17bae1866dcf1e2959d910e81b3831e4db2224a1dcff790ef21afcd610d7cc9309251a08351bae1c959ded18e5e28a6b24ae99506
diff --git a/sys-firmware/sof-firmware/sof-firmware-2023.12.1.ebuild b/sys-firmware/sof-firmware/sof-firmware-2023.12.1.ebuild
new file mode 100644
index 000000000000..6775a219fd4f
--- /dev/null
+++ b/sys-firmware/sof-firmware/sof-firmware-2023.12.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Sound Open Firmware (SOF) binary files"
+HOMEPAGE="https://www.sofproject.org https://github.com/thesofproject/sof https://github.com/thesofproject/sof-bin"
+SRC_URI="https://github.com/thesofproject/sof-bin/releases/download/v${PV}/sof-bin-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/sof-bin-${PV}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Needed for sof-ctl
+RDEPEND="media-libs/alsa-lib"
+
+QA_PREBUILT="usr/bin/sof-ctl
+ usr/bin/sof-logger
+ usr/bin/sof-probes"
+
+src_install() {
+ dodir /lib/firmware/intel
+ dodir /usr/bin
+ FW_DEST="${D}/lib/firmware/intel" TOOLS_DEST="${D}/usr/bin" "${S}/install.sh" || die
+}
+
+pkg_preinst() {
+ local sofpath="${EROOT}/lib/firmware/intel/sof"
+ if [[ ! -L "${sofpath}" && -d "${sofpath}" ]] ; then
+ rm -r "${sofpath}" || die
+ fi
+}