summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-01 16:10:01 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-01 16:10:59 +0100
commit05bbec84cc85a2ef5e761b104440b83ac5d32046 (patch)
tree0446ce36c28095417124543ce5ffbd5288c8d896 /sys-fs/vhba
parentsci-misc/vitables: bump to debian 3.0.2_p4, migrate nose to pytest. (diff)
downloadgentoo-05bbec84cc85a2ef5e761b104440b83ac5d32046.tar.gz
gentoo-05bbec84cc85a2ef5e761b104440b83ac5d32046.tar.bz2
gentoo-05bbec84cc85a2ef5e761b104440b83ac5d32046.zip
sys-fs/vhba: Call udev_reload
Closes: https://bugs.gentoo.org/852275 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-fs/vhba')
-rw-r--r--sys-fs/vhba/vhba-20211218.ebuild22
1 files changed, 16 insertions, 6 deletions
diff --git a/sys-fs/vhba/vhba-20211218.ebuild b/sys-fs/vhba/vhba-20211218.ebuild
index 3261cbfecf35..6b51dc2b402e 100644
--- a/sys-fs/vhba/vhba-20211218.ebuild
+++ b/sys-fs/vhba/vhba-20211218.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,11 +14,14 @@ S=${WORKDIR}/${MY_P}
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-RDEPEND="virtual/udev"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+RDEPEND="
+ virtual/udev
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
MODULE_NAMES="vhba(block:${S})"
BUILD_TARGETS=modules
@@ -33,7 +36,6 @@ pkg_setup() {
src_prepare() {
# Avoid -Werror problems
sed -i -e '/ccflags/s/-Werror/-Wall/' Makefile || die "sed failed"
-
eapply_user
}
@@ -48,3 +50,11 @@ src_install() {
KERNEL=="vhba_ctl", SUBSYSTEM=="misc", TAG+="uaccess"
EOF
}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}