summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_access_dnsbl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_access_dnsbl')
-rw-r--r--www-apache/mod_access_dnsbl/Manifest1
-rw-r--r--www-apache/mod_access_dnsbl/files/10_mod_access_dnsbl.conf11
-rw-r--r--www-apache/mod_access_dnsbl/metadata.xml5
-rw-r--r--www-apache/mod_access_dnsbl/mod_access_dnsbl-0.02.ebuild24
4 files changed, 41 insertions, 0 deletions
diff --git a/www-apache/mod_access_dnsbl/Manifest b/www-apache/mod_access_dnsbl/Manifest
new file mode 100644
index 000000000000..2e4616a4e91e
--- /dev/null
+++ b/www-apache/mod_access_dnsbl/Manifest
@@ -0,0 +1 @@
+DIST mod_access_dnsbl-0.02.tar.gz 3648 SHA256 9f2aba05c8a026866529f7e51d2035e288eb184a46cfc7ecacb6548a2b279bce SHA512 5d4217798f2fdced4e6bac55187edfb8534ce4db85a0ca7d3e5a832b962ea12df8ad47284e4f29f9ce5029bd26ffafc403cf3b8cb566d1a108168162a68682f6 WHIRLPOOL 97900fb78d851bab84635a5bb955e586e5b0f6390b49ff7d2a9bab5f05dd865c50c4332e81aa68ed73bf9ae0b071a236bb0a0edcabf7f61a75cf4d43cf87a718
diff --git a/www-apache/mod_access_dnsbl/files/10_mod_access_dnsbl.conf b/www-apache/mod_access_dnsbl/files/10_mod_access_dnsbl.conf
new file mode 100644
index 000000000000..7e9419e97fd1
--- /dev/null
+++ b/www-apache/mod_access_dnsbl/files/10_mod_access_dnsbl.conf
@@ -0,0 +1,11 @@
+<IfDefine DNSBL>
+LoadModule access_dnsbl_module modules/mod_access_dnsbl.so
+
+# example configuration:
+#<Directory /var/www/localhost/htdocs/protected>
+# DNSBLOrder allow,deny
+# DNSBLDeny from spammers
+#</Directory>
+</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_access_dnsbl/metadata.xml b/www-apache/mod_access_dnsbl/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/www-apache/mod_access_dnsbl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/www-apache/mod_access_dnsbl/mod_access_dnsbl-0.02.ebuild b/www-apache/mod_access_dnsbl/mod_access_dnsbl-0.02.ebuild
new file mode 100644
index 000000000000..664232c06083
--- /dev/null
+++ b/www-apache/mod_access_dnsbl/mod_access_dnsbl-0.02.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit apache-module
+
+DESCRIPTION="Specify access controls based on DNSBL zones"
+HOMEPAGE="http://www.apacheconsultancy.com/modules/${PN}/"
+SRC_URI="http://www.apacheconsultancy.com/modules/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="www-apache/mod_dnsbl_lookup"
+RDEPEND="${DEPEND}"
+
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="DNSBL"
+
+need_apache2