summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-09-23 20:59:03 +0200
committerMichał Górny <mgorny@gentoo.org>2018-09-23 21:07:58 +0200
commit0e32ffdb0178f395581a64f678c8e29fad1ef9ca (patch)
treee31fbee9603ec8139a6d466638159a79d66d7e34 /www-plugins
parentnet-irc/irssi: Add myself as maintainer (diff)
downloadgentoo-0e32ffdb0178f395581a64f678c8e29fad1ef9ca.tar.gz
gentoo-0e32ffdb0178f395581a64f678c8e29fad1ef9ca.tar.bz2
gentoo-0e32ffdb0178f395581a64f678c8e29fad1ef9ca.zip
www-plugins/lightspark: 0.8.1 requires LLVM < 7
Closes: https://bugs.gentoo.org/666834 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/lightspark/lightspark-0.8.1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/www-plugins/lightspark/lightspark-0.8.1.ebuild b/www-plugins/lightspark/lightspark-0.8.1.ebuild
index 6106645e3222..02f432a55440 100644
--- a/www-plugins/lightspark/lightspark-0.8.1.ebuild
+++ b/www-plugins/lightspark/lightspark-0.8.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit cmake-utils gnome2-utils nsplugins toolchain-funcs xdg-utils
+inherit cmake-utils gnome2-utils llvm nsplugins toolchain-funcs xdg-utils
EGIT_COMMIT="f6ed8284810ad91c277ed5d0835b215e7329450e"
DESCRIPTION="High performance flash player"
@@ -24,7 +24,7 @@ RDEPEND="app-arch/xz-utils:0=
media-libs/libpng:0=
media-libs/libsdl2:0=
media-libs/sdl2-mixer:0=
- >=sys-devel/llvm-3.4:=
+ <sys-devel/llvm-7:=
sys-libs/zlib:0=
x11-libs/cairo:0=
x11-libs/libX11:0=
@@ -48,6 +48,8 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P/_rc*/}
+LLVM_MAX_SLOT=6
+
src_configure() {
local mycmakeargs=(
-DENABLE_CURL=$(usex curl)