summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-01-27 21:52:51 -0800
committerMatt Turner <mattst88@gentoo.org>2017-01-27 22:08:58 -0800
commitbcea2037cba680360c03f63bd3041e3c5eda6d9c (patch)
tree0a306679a5b71001439d7d2ed9c39656d0e85f5e /x11-drivers
parentx11-drivers/xf86-input-evdev: Add missing virtual/libudev:= dependency. (diff)
downloadgentoo-bcea2037cba680360c03f63bd3041e3c5eda6d9c.tar.gz
gentoo-bcea2037cba680360c03f63bd3041e3c5eda6d9c.tar.bz2
gentoo-bcea2037cba680360c03f63bd3041e3c5eda6d9c.zip
x11-drivers/xf86-input-wacom: Kconfig directions.
Upstream commit 471d17148c8b4174ac5f5283a73316d12c4379bc changed it to HID_USB_WACOM, and then commit 7403a6a448c3ed96221bb46c9da75254fd87b520 merged HID_USB_WACOM into HID_WACOM. Both commits appeared first in the v3.17 release. Bug: https://bugs.gentoo.org/544712
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.34.0.ebuild36
1 files changed, 25 insertions, 11 deletions
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.34.0.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.34.0.ebuild
index 5a0aed8aaae2..2e82a9171037 100644
--- a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.34.0.ebuild
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.34.0.ebuild
@@ -45,16 +45,30 @@ src_install() {
pkg_pretend() {
linux-info_pkg_setup
- if ! linux_config_exists \
- || ! linux_chkconfig_present TABLET_USB_WACOM \
- || ! linux_chkconfig_present INPUT_EVDEV; then
- echo
- ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
- ewarn " Device Drivers --->"
- ewarn " Input device support --->"
- ewarn " <*> Event interface"
- ewarn " [*] Tablets --->"
- ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
- echo
+ if kernel_is lt 3 17; then
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present TABLET_USB_WACOM \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn " [*] Tablets --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+ else
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present HID_WACOM; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " HID support --->"
+ ewarn " Special HID drivers --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
fi
+
}