summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-05-07 23:26:23 -0400
committerSam James <sam@gentoo.org>2024-05-08 20:19:30 +0100
commit0518bf825c5834935484f672dabd5afcb08cc530 (patch)
treea4fbe9e72f8f7ac869017ad17ecf7ef49602e98e /x11-libs
parentpackage.mask: Last rite net-irc/ninja (diff)
downloadgentoo-0518bf825c5834935484f672dabd5afcb08cc530.tar.gz
gentoo-0518bf825c5834935484f672dabd5afcb08cc530.tar.bz2
gentoo-0518bf825c5834935484f672dabd5afcb08cc530.zip
x11-libs/cmrt: mark as LTO-unsafe, strict-aliasing unsafe
The software is dead upstream. In August 2022 (almost immediately after the package was added to the tree), the README.md was updated to say: > Intel has ceased development and contributions including, but not > limited to, maintenance, bug fixes, new releases, or updates, to this > project. > > Intel no longer accepts patches to this project. and the github repository was marked as archived. No point in reporting anything, because you can't even if you want to. Just mark it as unsafe and move on. Closes: https://bugs.gentoo.org/864409 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/cmrt/cmrt-1.0.6-r3.ebuild20
1 files changed, 18 insertions, 2 deletions
diff --git a/x11-libs/cmrt/cmrt-1.0.6-r3.ebuild b/x11-libs/cmrt/cmrt-1.0.6-r3.ebuild
index 7ed6d16eae5e..4973586aa1ac 100644
--- a/x11-libs/cmrt/cmrt-1.0.6-r3.ebuild
+++ b/x11-libs/cmrt/cmrt-1.0.6-r3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="Intel C for Media RunTime GPU kernel manager"
HOMEPAGE="https://github.com/intel/cmrt"
@@ -29,6 +29,22 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/864409
+ #
+ # > Intel has ceased development and contributions including, but not
+ # > limited to, maintenance, bug fixes, new releases, or updates, to this
+ # > project. Intel no longer accepts patches to this project.
+ # No point in submitting a bug report or trying to get this into good shape.
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ default
+}
+
src_install() {
default
find "${ED}" -type f -name '*.la' -delete || die