summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/devilspie2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/devilspie2')
-rw-r--r--x11-misc/devilspie2/Manifest2
-rw-r--r--x11-misc/devilspie2/devilspie2-0.36.ebuild47
-rw-r--r--x11-misc/devilspie2/devilspie2-0.37.ebuild47
-rw-r--r--x11-misc/devilspie2/metadata.xml6
4 files changed, 102 insertions, 0 deletions
diff --git a/x11-misc/devilspie2/Manifest b/x11-misc/devilspie2/Manifest
new file mode 100644
index 000000000000..8e47f635d466
--- /dev/null
+++ b/x11-misc/devilspie2/Manifest
@@ -0,0 +1,2 @@
+DIST devilspie2_0.36-src.tar.gz 44818 SHA256 7d0c2982d65f4dfc9d64f29f72252cce3354231938bc79da8034edfb3394ae11 SHA512 5ab755e7b2f12c0d6304a7ce4a25c95f1cb5d11eec42da0902239e37e2f637663706a21b2d69643f423b8fd597761283fc7a0efc8c201e1f07e503a2057fefd6 WHIRLPOOL 2a6aac66c8fe9e5a0eb8099eca835bc1a7382627e662fdbd70f598a4ead478ca9d8a8510a6ce353f2a186ac94f71a5df67375dd91a3dbd4c9cc001854d1cc6fa
+DIST devilspie2_0.37-src.tar.gz 44722 SHA256 463db05b85723f571e16034b3c9281bdcc3a2cffcaa2cf056580575ee8a421b6 SHA512 1eaf7d6a5074179d1a3b356ed25e0243bb177e8d408797a8efe230ae1b737d18f52442a69f92a3f47cece2d91c70b4c7d9cb378183eb353f0e163ac772f9478e WHIRLPOOL a58c6137415108c10e603e4c095309038801b2a82dfa0ea1befd8a03b62d341fdf3015314df0ebb0f81f43b481c3661b6904ef28a1899bd52aeb98922dcd509a
diff --git a/x11-misc/devilspie2/devilspie2-0.36.ebuild b/x11-misc/devilspie2/devilspie2-0.36.ebuild
new file mode 100644
index 000000000000..10c913be0070
--- /dev/null
+++ b/x11-misc/devilspie2/devilspie2-0.36.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# check locales on version bump!
+PLOCALES="fi fr ja nl pt_BR ru sv"
+inherit flag-o-matic toolchain-funcs l10n
+
+DESCRIPTION="Devilspie like window matching utility, using LUA for scripting"
+HOMEPAGE="http://devilspie2.gusnan.se"
+SRC_URI="http://devilspie2.gusnan.se/download/${PN}_${PV}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.32.4:2
+ >=dev-lang/lua-5.1.5
+ >=x11-libs/gtk+-3.4.4:3
+ >=x11-libs/libwnck-3.4.4:3
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-proto/xproto"
+
+src_prepare() {
+ use debug && append-cflags -D_DEBUG
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) PREFIX="/usr" LANGUAGES="$(l10n_get_locales)"
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" LANGUAGES="$(l10n_get_locales)" install
+
+ dodoc AUTHORS ChangeLog README README.translators TODO VERSION
+ doman devilspie2.1
+}
+
+pkg_postinst() {
+ elog "Default directory for scripts is ~/.config/devilspie2/"
+}
diff --git a/x11-misc/devilspie2/devilspie2-0.37.ebuild b/x11-misc/devilspie2/devilspie2-0.37.ebuild
new file mode 100644
index 000000000000..815fe9329187
--- /dev/null
+++ b/x11-misc/devilspie2/devilspie2-0.37.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# check locales on version bump!
+PLOCALES="fi fr ja nl pt_BR ru sv"
+inherit flag-o-matic toolchain-funcs l10n
+
+DESCRIPTION="Devilspie like window matching utility, using LUA for scripting"
+HOMEPAGE="http://devilspie2.gusnan.se"
+SRC_URI="http://devilspie2.gusnan.se/download/${PN}_${PV}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.32.4:2
+ >=dev-lang/lua-5.1.5
+ >=x11-libs/gtk+-3.4.4:3
+ >=x11-libs/libwnck-3.4.4:3
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-proto/xproto"
+
+src_prepare() {
+ use debug && append-cflags -D_DEBUG
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) PREFIX="/usr" LANGUAGES="$(l10n_get_locales)"
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" LANGUAGES="$(l10n_get_locales)" install
+
+ dodoc AUTHORS ChangeLog README README.translators TODO VERSION
+ doman devilspie2.1
+}
+
+pkg_postinst() {
+ elog "Default directory for scripts is ~/.config/devilspie2/"
+}
diff --git a/x11-misc/devilspie2/metadata.xml b/x11-misc/devilspie2/metadata.xml
new file mode 100644
index 000000000000..9360f354d02a
--- /dev/null
+++ b/x11-misc/devilspie2/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+</pkgmetadata>
+