summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/gtkdialog
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/gtkdialog')
-rw-r--r--x11-misc/gtkdialog/Manifest2
-rw-r--r--x11-misc/gtkdialog/gtkdialog-0.8.2.ebuild28
-rw-r--r--x11-misc/gtkdialog/gtkdialog-0.8.3.ebuild28
-rw-r--r--x11-misc/gtkdialog/metadata.xml15
4 files changed, 73 insertions, 0 deletions
diff --git a/x11-misc/gtkdialog/Manifest b/x11-misc/gtkdialog/Manifest
new file mode 100644
index 000000000000..9b6476ec9d98
--- /dev/null
+++ b/x11-misc/gtkdialog/Manifest
@@ -0,0 +1,2 @@
+DIST gtkdialog-0.8.2.tar.gz 494083 SHA256 02a75a331d712b0756abb3f1715b7016398f1831917a1798ce747d7131a30fb5 SHA512 15eb99a2a0b3983fc99658afe6e0a97fbeaf2e533a93974d5961da052e87c0aa3a7b6ac4445deff0e54e22a260568b125fd563784352af058328c4a3dbace6fe WHIRLPOOL 04de9c2434ff87b2b7c26f5447db765e3c02ad60b07a15e946853d41db2b981f3a6c1a123bb91472317414eeb3416e52db02faa869f0d5c02f8917877518f562
+DIST gtkdialog-0.8.3.tar.gz 571974 SHA256 ff89d2d7f1e6488e5df5f895716ac1d4198c2467a2a5dc1f51ab408a2faec38e SHA512 fd8a93d576917efd650e38e31f261065c0a0c3f9213338ed4bd457d310993d8efbe8deabb2c1451f491d14c8d38cbcd5d4cb0c9f289c6fd462f7a06754b89da7 WHIRLPOOL 51ca225b8c47de8f5fdaf1937d44450670d77cb913c677fa48dafce9e1365fb8a45f353b9ab9f86a3da96155a3d27f1dd011e98ae74eac506069bd72ae484867
diff --git a/x11-misc/gtkdialog/gtkdialog-0.8.2.ebuild b/x11-misc/gtkdialog/gtkdialog-0.8.2.ebuild
new file mode 100644
index 000000000000..a3979b6397cb
--- /dev/null
+++ b/x11-misc/gtkdialog/gtkdialog-0.8.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="A small utility for fast and easy GUI building"
+HOMEPAGE="http://code.google.com/p/gtkdialog/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ gnome-base/libglade"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/flex
+ virtual/yacc"
+
+DOCS=( AUTHORS ChangeLog TODO )
+
+src_install() {
+ # Stop make install from running gtk-update-icon-cache
+ emake DESTDIR="${D}" UPDATE_ICON_CACHE=true install
+}
diff --git a/x11-misc/gtkdialog/gtkdialog-0.8.3.ebuild b/x11-misc/gtkdialog/gtkdialog-0.8.3.ebuild
new file mode 100644
index 000000000000..afdadf3ffba2
--- /dev/null
+++ b/x11-misc/gtkdialog/gtkdialog-0.8.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="A small utility for fast and easy GUI building"
+HOMEPAGE="http://code.google.com/p/gtkdialog/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ gnome-base/libglade"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/flex
+ virtual/yacc"
+
+DOCS=( AUTHORS ChangeLog TODO )
+
+src_install() {
+ # Stop make install from running gtk-update-icon-cache
+ emake DESTDIR="${D}" UPDATE_ICON_CACHE=true install
+}
diff --git a/x11-misc/gtkdialog/metadata.xml b/x11-misc/gtkdialog/metadata.xml
new file mode 100644
index 000000000000..f66a06401dd0
--- /dev/null
+++ b/x11-misc/gtkdialog/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <longdescription>gtkdialog is a GUI-creation utility that can be used with an arbitrary
+ interpreter. It enables the programmer to describe a graphical user
+ interface in a simple XML-like language, and use it with any
+ interpreter that supports either files, standard I/O, or environment
+ variables. It can be called as an external program from the
+ interpreter, but can be used as a stand-alone framework for the
+ application as well. Stand-alone, bash, and awk examples are provided.</longdescription>
+ <upstream>
+ <remote-id type="google-code">gtkdialog</remote-id>
+ </upstream>
+</pkgmetadata>