summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/kdocker
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/kdocker')
-rw-r--r--x11-misc/kdocker/Manifest1
-rw-r--r--x11-misc/kdocker/files/kdocker-4.8-unbundle-qtsingleapplication.patch17
-rw-r--r--x11-misc/kdocker/kdocker-4.8-r2.ebuild46
-rw-r--r--x11-misc/kdocker/metadata.xml9
4 files changed, 73 insertions, 0 deletions
diff --git a/x11-misc/kdocker/Manifest b/x11-misc/kdocker/Manifest
new file mode 100644
index 000000000000..dcfb732e06e6
--- /dev/null
+++ b/x11-misc/kdocker/Manifest
@@ -0,0 +1 @@
+DIST kdocker-4.8.tar.gz 379186 SHA256 16e5d6dab6957139343b29d2bab7d1f7154d74bb4a60dace897b23cf6f8921a9 SHA512 4e7d716dba1ec7d45cb1134e4d28b4d4461a837d2f88f1460d54297594f617c414ba231515e1ca5c284e75099ac5db9762712085aba6c374991c8c642d903a91 WHIRLPOOL 059c018059e29f5259adfeb23f3bf1d6b1967aa06a1cf991bcfa050324c3459ea08c304c869a77c4f6ac16e508546051d6484cc6806217fb39afd8fdd01f9970
diff --git a/x11-misc/kdocker/files/kdocker-4.8-unbundle-qtsingleapplication.patch b/x11-misc/kdocker/files/kdocker-4.8-unbundle-qtsingleapplication.patch
new file mode 100644
index 000000000000..798769e6907c
--- /dev/null
+++ b/x11-misc/kdocker/files/kdocker-4.8-unbundle-qtsingleapplication.patch
@@ -0,0 +1,17 @@
+=== modified file 'kdocker.pro'
+--- kdocker.pro 2011-05-31 00:46:31 +0000
++++ kdocker.pro 2013-10-27 14:41:36 +0000
+@@ -2,7 +2,11 @@
+ CONFIG += qt
+ TARGET = kdocker
+
+-include(solutions/qtsingleapplication/qtsingleapplication.pri)
++isEmpty(SYSTEMQTSA) {
++ include(3rdparty/qtsingleapplication/qtsingleapplication.pri)
++} else {
++ CONFIG += qtsingleapplication
++}
+
+ DEPENDPATH += src
+ INCLUDEPATH += . src /usr/include/X11
+
diff --git a/x11-misc/kdocker/kdocker-4.8-r2.ebuild b/x11-misc/kdocker/kdocker-4.8-r2.ebuild
new file mode 100644
index 000000000000..812d28d88832
--- /dev/null
+++ b/x11-misc/kdocker/kdocker-4.8-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+LANGS="it"
+inherit bash-completion-r1 qt4-r2
+
+DESCRIPTION="Helper to dock any application into the system tray"
+HOMEPAGE="https://launchpad.net/kdocker/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV:0:3}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtsingleapplication[qt4(+),X]
+ x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXpm
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS BUGS ChangeLog CREDITS README TODO )
+
+PATCHES=( "${FILESDIR}/${P}-unbundle-qtsingleapplication.patch" )
+
+src_prepare() {
+ qt4-r2_src_prepare
+
+ if ! use linguas_it ; then
+ sed -e '/^INSTALLS +=/s/translations//' -i kdocker.pro || die "sed failed"
+ fi
+
+ sed -i -e "/completion.path/s%/etc/bash_completion.d%$(get_bashcompdir)%" \
+ kdocker.pro || die "sed failed"
+}
+
+src_configure() {
+ eqmake4 PREFIX="${EPREFIX}/usr" SYSTEMQTSA=1
+}
diff --git a/x11-misc/kdocker/metadata.xml b/x11-misc/kdocker/metadata.xml
new file mode 100644
index 000000000000..106f35298550
--- /dev/null
+++ b/x11-misc/kdocker/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <upstream>
+ <remote-id type="launchpad">kdocker</remote-id>
+ <bugs-to>http://bugs.launchpad.net/kdocker</bugs-to>
+ </upstream>
+</pkgmetadata>