summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-firmware/seabios/Manifest3
-rw-r--r--sys-firmware/seabios/seabios-1.12.0-r1.ebuild171
-rw-r--r--sys-firmware/seabios/seabios-1.12.0.ebuild145
-rw-r--r--sys-firmware/seabios/seabios-1.14.0-r1.ebuild172
-rw-r--r--sys-firmware/seabios/seabios-1.14.0.ebuild166
5 files changed, 0 insertions, 657 deletions
diff --git a/sys-firmware/seabios/Manifest b/sys-firmware/seabios/Manifest
index 53fef7c53118..8eda39382f89 100644
--- a/sys-firmware/seabios/Manifest
+++ b/sys-firmware/seabios/Manifest
@@ -1,6 +1,3 @@
-DIST seabios-1.12.0-bin.tar.xz 162492 BLAKE2B 9a5a349226ed7efbed328493dc057e232203b251677a23f1f09c133743ff0ca6b05270c9d27460be1d8897888fe23ff7bdfa122023fa8ddb23af03d5b9b6f8dd SHA512 f7a0395d621245093bb9a278d95ecc3d4e8d23f620058cd4fddaf885c8b86256f6258f3fd8173c1d24c03306f44d180e768bf8005ee123bc4b699b9f0ca371be
-DIST seabios-1.12.0.tar.gz 613542 BLAKE2B f145c2db716996bfa9e5c014086ccfaa8ae96ebc158f34303b122b7bf209408c567665d8691364df8d8e886f63e0e72a3f3cd319dfa86ef581023201b5d94e53 SHA512 e52c5363e5bb37b5286e55545aa06bd126218f9d0e3a06ac2e189de68fe3de3256c11ca1bb13357a9c384d7e3af6284083ff3aa587688b5de04ef11b97bdfa27
-DIST seabios-1.14.0-bin.tar.xz 170160 BLAKE2B 1ab471ce0c6e27633ec42a66e3069496be84de713baab5de4f297821bd0da26404f7f70abc82e223ec5aa317a878889ae92b019988c72d24f77e7dcc5865f916 SHA512 7964e9bb7dff4fd6593f5d6d64efc4b1460750461b86635dbe5255d2086d619f51711d7a35e4dc20e556f705091c0950afabeddcd2e8876f05ce14f9ca73ed71
DIST seabios-1.14.0-r2-bin.tar.xz 132256 BLAKE2B 7d38949de254d6e3699d463a66c363156aa36bfe16c18bea48c55a61bdc423184175fd5427d3246a78d9c6335e61e5baa982f67e7406c5525e405b4383530d41 SHA512 5ce0e407b97e878842fbd7ad2f9e8a65f2565a5aa43d08e01cff024352780f55f8669958c58d20770db7f90e87cc52c860af831cefe3846227e7b45cd9dc33ee
DIST seabios-1.14.0.tar.gz 628985 BLAKE2B cc1126925dab1551a655680d20d06ebf28c12c386500d1ee4df9e1a99403b4c5bc6a66c2cc5ef58b4c3d6d7226f35007506a6a1855c2cf2742469dcb7aba05bb SHA512 215c42f59425f8abd062be7b11fc0e39c977cee5001a2381551b0f851ac337d0dd53c065267e6dee0e710ffd700fa635f9007b89da8dfce0f47122c984ee8146
DIST seabios-1.16.0.tar.gz 635419 BLAKE2B b645f20bae341d56ce4fc4a7044446050d8490c6c136377f6dccf02c88100b0644bc13d210b4a517a8be6002d5671b0fba77120a2aca3a9bafbad5e88d037e40 SHA512 9daefcfb1c9edda4462a4b080c9bac552154d577ae19703a914928e43005e7a52edd86869c6507e94a7f0c61ce8b3e6f5dea38cd5146628cb138a130947c522f
diff --git a/sys-firmware/seabios/seabios-1.12.0-r1.ebuild b/sys-firmware/seabios/seabios-1.12.0-r1.ebuild
deleted file mode 100644
index 03b9cd8cd76c..000000000000
--- a/sys-firmware/seabios/seabios-1.12.0-r1.ebuild
+++ /dev/null
@@ -1,171 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit toolchain-funcs python-any-r1
-
-# SeaBIOS maintainers sometimes don't release stable tarballs or stable
-# binaries to generate the stable tarball the following is necessary:
-# git clone git://git.seabios.org/seabios.git && cd seabios
-# git archive --output seabios-${PV}.tar.gz --prefix seabios-${PV}/ rel-${PV}
-
-if [[ ${PV} == *9999* || -n "${EGIT_COMMIT}" ]] ; then
- EGIT_REPO_URI="git://git.seabios.org/seabios.git"
- inherit git-r3
-else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-
- # Binary versions taken from fedora:
- # http://download.fedoraproject.org/pub/fedora/linux/development/rawhide/Everything/x86_64/os/Packages/s/
- # seabios-bin-1.12.1-2.fc31.noarch.rpm
- # seavgabios-bin-1.12.1-2.fc31.noarch.rpm
- SRC_URI="
- !binary? ( https://code.coreboot.org/p/seabios/downloads/get/${P}.tar.gz )
- binary? ( https://dev.gentoo.org/~tamiko/distfiles/${P}-bin.tar.xz )"
-fi
-
-DESCRIPTION="Open Source implementation of a 16-bit x86 BIOS"
-HOMEPAGE="https://www.seabios.org/"
-
-LICENSE="LGPL-3 GPL-3"
-SLOT="0"
-IUSE="+binary debug +seavgabios"
-
-REQUIRED_USE="debug? ( !binary )"
-
-SOURCE_DEPEND="
- >=sys-power/iasl-20060912
- ${PYTHON_DEPS}"
-DEPEND="
- !binary? (
- ${SOURCE_DEPEND}
- )"
-RDEPEND=""
-
-choose_target_chost() {
- if [[ -n "${CC}" ]]; then
- ${CC} -dumpmachine
- return
- fi
-
- if use amd64 || use x86; then
- # Use the native compiler
- echo "${CHOST}"
- return
- fi
-
- local i
- for i in x86_64 i686 i586 i486 i386 ; do
- i=${i}-pc-linux-gnu
- type -P ${i}-gcc > /dev/null && echo ${i} && return
- done
-}
-
-pkg_pretend() {
- if ! use binary; then
- ewarn "You have decided to compile your own SeaBIOS. This is not"
- ewarn "supported by upstream unless you use their recommended"
- ewarn "toolchain (which you are not)."
- elog
- ewarn "If you are intending to use this build with QEMU, realize"
- ewarn "you will not receive any support if you have compiled your"
- ewarn "own SeaBIOS. Virtual machines subtly fail based on changes"
- ewarn "in SeaBIOS."
- if [[ -z "$(choose_target_chost)" ]]; then
- elog
- eerror "Before you can compile ${PN}[-binary], you need to install a x86 cross-compiler"
- eerror "Run the following commands:"
- eerror " emerge crossdev"
- eerror " crossdev --stable -t x86_64-pc-linux-gnu"
- die "cross-compiler is needed"
- fi
- fi
-}
-
-pkg_setup() {
- use binary || python-any-r1_pkg_setup
-}
-
-src_unpack() {
- default
-
- # This simplifies the logic between binary & source builds.
- mkdir -p "${S}"
-}
-
-src_prepare() {
- default
-
- # Ensure precompiled iasl files are never used
- find "${WORKDIR}" -name '*.hex' -delete || die
-}
-
-src_configure() {
- use binary && return
-
- tc-ld-disable-gold #438058
-
- if use debug ; then
- echo "CONFIG_DEBUG_LEVEL=8" >.config
- fi
- _emake config
-}
-
-_emake() {
- LANG=C \
- emake V=1 \
- CC="$(tc-getCC)" \
- LD="$(tc-getLD)" \
- AR="$(tc-getAR)" \
- AS="$(tc-getAS)" \
- OBJCOPY="$(tc-getOBJCOPY)" \
- RANLIB="$(tc-getRANLIB)" \
- OBJDUMP="$(tc-getOBJDUMP)" \
- HOST_CC="$(tc-getBUILD_CC)" \
- VERSION="Gentoo/${EGIT_COMMIT:-${PVR}}" \
- "$@"
-}
-
-src_compile() {
- use binary && return
-
- local TARGET_CHOST=$(choose_target_chost)
-
- cp "${FILESDIR}/seabios/config.seabios-256k" .config || die
- _emake oldnoconfig
- CHOST="${TARGET_CHOST}" _emake iasl
- CHOST="${TARGET_CHOST}" _emake out/bios.bin
- mv out/bios.bin ../bios-256k.bin || die
-
- if use seavgabios ; then
- local config t targets=(
- cirrus
- isavga
- qxl
- stdvga
- virtio
- vmware
- )
- for t in "${targets[@]}" ; do
- emake clean distclean
- cp "${FILESDIR}/seavgabios/config.vga-${t}" .config || die
- _emake oldnoconfig
- CHOST="${TARGET_CHOST}" _emake out/vgabios.bin
- cp out/vgabios.bin ../vgabios-${t}.bin || die
- done
- fi
-}
-
-src_install() {
- insinto /usr/share/seabios
- use binary && doins ../bios.bin
- doins ../bios-256k.bin
-
- if use seavgabios ; then
- insinto /usr/share/seavgabios
- doins ../vgabios*.bin
- fi
-}
diff --git a/sys-firmware/seabios/seabios-1.12.0.ebuild b/sys-firmware/seabios/seabios-1.12.0.ebuild
deleted file mode 100644
index 375070e32da8..000000000000
--- a/sys-firmware/seabios/seabios-1.12.0.ebuild
+++ /dev/null
@@ -1,145 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit toolchain-funcs python-any-r1
-
-# SeaBIOS maintainers sometimes don't release stable tarballs or stable
-# binaries to generate the stable tarball the following is necessary:
-# git clone git://git.seabios.org/seabios.git && cd seabios
-# git archive --output seabios-${PV}.tar.gz --prefix seabios-${PV}/ rel-${PV}
-
-if [[ ${PV} == *9999* || -n "${EGIT_COMMIT}" ]] ; then
- EGIT_REPO_URI="git://git.seabios.org/seabios.git"
- inherit git-r3
-else
- KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 ~sparc x86"
-
- # Binary versions taken from fedora:
- # http://download.fedoraproject.org/pub/fedora/linux/development/rawhide/Everything/x86_64/os/Packages/s/
- # seabios-bin-1.12.1-2.fc31.noarch.rpm
- # seavgabios-bin-1.12.1-2.fc31.noarch.rpm
- SRC_URI="
- !binary? ( https://code.coreboot.org/p/seabios/downloads/get/${P}.tar.gz )
- binary? ( https://dev.gentoo.org/~tamiko/distfiles/${P}-bin.tar.xz )"
-fi
-
-DESCRIPTION="Open Source implementation of a 16-bit x86 BIOS"
-HOMEPAGE="https://www.seabios.org/"
-
-LICENSE="LGPL-3 GPL-3"
-SLOT="0"
-IUSE="+binary debug +seavgabios"
-
-REQUIRED_USE="debug? ( !binary )
- !amd64? ( !x86? ( binary ) )"
-
-# The amd64/x86 check is needed to workaround #570892.
-SOURCE_DEPEND="
- >=sys-power/iasl-20060912
- ${PYTHON_DEPS}"
-DEPEND="
- !binary? (
- amd64? ( ${SOURCE_DEPEND} )
- x86? ( ${SOURCE_DEPEND} )
- )"
-RDEPEND=""
-
-pkg_pretend() {
- if ! use binary; then
- ewarn "You have decided to compile your own SeaBIOS. This is not"
- ewarn "supported by upstream unless you use their recommended"
- ewarn "toolchain (which you are not)."
- elog
- ewarn "If you are intending to use this build with QEMU, realize"
- ewarn "you will not receive any support if you have compiled your"
- ewarn "own SeaBIOS. Virtual machines subtly fail based on changes"
- ewarn "in SeaBIOS."
- fi
-}
-
-pkg_setup() {
- use binary || python-any-r1_pkg_setup
-}
-
-src_unpack() {
- default
-
- # This simplifies the logic between binary & source builds.
- mkdir -p "${S}"
-}
-
-src_prepare() {
- default
-
- # Ensure precompiled iasl files are never used
- find "${WORKDIR}" -name '*.hex' -delete || die
-}
-
-src_configure() {
- use binary && return
-
- tc-ld-disable-gold #438058
-
- if use debug ; then
- echo "CONFIG_DEBUG_LEVEL=8" >.config
- fi
- _emake config
-}
-
-_emake() {
- LANG=C \
- emake V=1 \
- CC="$(tc-getCC)" \
- LD="$(tc-getLD)" \
- AR="$(tc-getAR)" \
- AS="$(tc-getAS)" \
- OBJCOPY="$(tc-getOBJCOPY)" \
- RANLIB="$(tc-getRANLIB)" \
- OBJDUMP="$(tc-getOBJDUMP)" \
- HOST_CC="$(tc-getBUILD_CC)" \
- VERSION="Gentoo/${EGIT_COMMIT:-${PVR}}" \
- "$@"
-}
-
-src_compile() {
- use binary && return
-
- cp "${FILESDIR}/seabios/config.seabios-256k" .config || die
- _emake oldnoconfig
- _emake iasl
- _emake out/bios.bin
- mv out/bios.bin ../bios-256k.bin || die
-
- if use seavgabios ; then
- local config t targets=(
- cirrus
- isavga
- qxl
- stdvga
- virtio
- vmware
- )
- for t in "${targets[@]}" ; do
- emake clean distclean
- cp "${FILESDIR}/seavgabios/config.vga-${t}" .config || die
- _emake oldnoconfig
- _emake out/vgabios.bin
- cp out/vgabios.bin ../vgabios-${t}.bin || die
- done
- fi
-}
-
-src_install() {
- insinto /usr/share/seabios
- use binary && doins ../bios.bin
- doins ../bios-256k.bin
-
- if use seavgabios ; then
- insinto /usr/share/seavgabios
- doins ../vgabios*.bin
- fi
-}
diff --git a/sys-firmware/seabios/seabios-1.14.0-r1.ebuild b/sys-firmware/seabios/seabios-1.14.0-r1.ebuild
deleted file mode 100644
index 92b326728a8d..000000000000
--- a/sys-firmware/seabios/seabios-1.14.0-r1.ebuild
+++ /dev/null
@@ -1,172 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit toolchain-funcs python-any-r1
-
-# SeaBIOS maintainers sometimes don't release stable tarballs or stable
-# binaries to generate the stable tarball the following is necessary:
-# git clone git://git.seabios.org/seabios.git && cd seabios
-# git archive --output seabios-${PV}.tar.gz --prefix seabios-${PV}/ rel-${PV}
-
-if [[ ${PV} == *9999* || -n "${EGIT_COMMIT}" ]] ; then
- EGIT_REPO_URI="git://git.seabios.org/seabios.git"
- inherit git-r3
-else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-
- SRC_URI="
- !binary? ( https://www.seabios.org/downloads/${P}.tar.gz )
- binary? ( https://dev.gentoo.org/~tamiko/distfiles/${P}-bin.tar.xz )"
-fi
-
-DESCRIPTION="Open Source implementation of a 16-bit x86 BIOS"
-HOMEPAGE="https://www.seabios.org/"
-
-LICENSE="LGPL-3 GPL-3"
-SLOT="0"
-IUSE="+binary debug +seavgabios"
-
-REQUIRED_USE="debug? ( !binary )"
-
-SOURCE_DEPEND="
- >=sys-power/iasl-20060912
- ${PYTHON_DEPS}"
-DEPEND="
- !binary? (
- ${SOURCE_DEPEND}
- )"
-RDEPEND=""
-
-choose_target_chost() {
- if [[ -n "${CC}" ]]; then
- ${CC} -dumpmachine
- return
- fi
-
- if use amd64 || use x86; then
- # Use the native compiler
- echo "${CHOST}"
- return
- fi
-
- local i
- for i in x86_64 i686 i586 i486 i386 ; do
- i=${i}-pc-linux-gnu
- type -P ${i}-gcc > /dev/null && echo ${i} && return
- done
-}
-
-pkg_pretend() {
- if ! use binary; then
- ewarn "You have decided to compile your own SeaBIOS. This is not"
- ewarn "supported by upstream unless you use their recommended"
- ewarn "toolchain (which you are not)."
- elog
- ewarn "If you are intending to use this build with QEMU, realize"
- ewarn "you will not receive any support if you have compiled your"
- ewarn "own SeaBIOS. Virtual machines subtly fail based on changes"
- ewarn "in SeaBIOS."
- if [[ -z "$(choose_target_chost)" ]]; then
- elog
- eerror "Before you can compile ${PN}[-binary], you need to install a x86 cross-compiler"
- eerror "Run the following commands:"
- eerror " emerge crossdev"
- eerror " crossdev --stable -t x86_64-pc-linux-gnu"
- die "cross-compiler is needed"
- fi
- fi
-}
-
-pkg_setup() {
- use binary || python-any-r1_pkg_setup
-}
-
-src_unpack() {
- default
-
- # This simplifies the logic between binary & source builds.
- mkdir -p "${S}"
-}
-
-src_prepare() {
- default
-
- if ! use binary; then
- eapply "${FILESDIR}"/${PN}-1.14.0-binutils-2.36.patch
- fi
-
- # Ensure precompiled iasl files are never used
- find "${WORKDIR}" -name '*.hex' -delete || die
-}
-
-src_configure() {
- use binary && return
-
- tc-ld-disable-gold #438058
-
- if use debug ; then
- echo "CONFIG_DEBUG_LEVEL=8" >.config
- fi
- _emake config
-}
-
-_emake() {
- LANG=C \
- emake V=1 \
- CPP="$(tc-getPROG CPP cpp)" \
- CC="$(tc-getCC)" \
- LD="$(tc-getLD)" \
- AR="$(tc-getAR)" \
- AS="$(tc-getAS)" \
- OBJCOPY="$(tc-getOBJCOPY)" \
- RANLIB="$(tc-getRANLIB)" \
- OBJDUMP="$(tc-getOBJDUMP)" \
- STRIP="$(tc-getSTRIP)" \
- HOST_CC="$(tc-getBUILD_CC)" \
- VERSION="Gentoo/${EGIT_COMMIT:-${PVR}}" \
- "$@"
-}
-
-src_compile() {
- use binary && return
-
- local TARGET_CHOST=$(choose_target_chost)
-
- cp "${FILESDIR}/seabios/config.seabios-256k" .config || die
- _emake oldnoconfig
- CHOST="${TARGET_CHOST}" _emake iasl
- CHOST="${TARGET_CHOST}" _emake out/bios.bin
- mv out/bios.bin ../bios-256k.bin || die
-
- if use seavgabios ; then
- local config t targets=(
- cirrus
- isavga
- qxl
- stdvga
- virtio
- vmware
- )
- for t in "${targets[@]}" ; do
- _emake clean distclean
- cp "${FILESDIR}/seavgabios/config.vga-${t}" .config || die
- _emake oldnoconfig
- CHOST="${TARGET_CHOST}" _emake out/vgabios.bin
- cp out/vgabios.bin ../vgabios-${t}.bin || die
- done
- fi
-}
-
-src_install() {
- insinto /usr/share/seabios
- doins ../bios-256k.bin
-
- if use seavgabios ; then
- insinto /usr/share/seavgabios
- doins ../vgabios*.bin
- fi
-}
diff --git a/sys-firmware/seabios/seabios-1.14.0.ebuild b/sys-firmware/seabios/seabios-1.14.0.ebuild
deleted file mode 100644
index 67cefdec6735..000000000000
--- a/sys-firmware/seabios/seabios-1.14.0.ebuild
+++ /dev/null
@@ -1,166 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit toolchain-funcs python-any-r1
-
-# SeaBIOS maintainers sometimes don't release stable tarballs or stable
-# binaries to generate the stable tarball the following is necessary:
-# git clone git://git.seabios.org/seabios.git && cd seabios
-# git archive --output seabios-${PV}.tar.gz --prefix seabios-${PV}/ rel-${PV}
-
-if [[ ${PV} == *9999* || -n "${EGIT_COMMIT}" ]] ; then
- EGIT_REPO_URI="git://git.seabios.org/seabios.git"
- inherit git-r3
-else
- KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 ~sparc x86"
-
- SRC_URI="
- !binary? ( https://www.seabios.org/downloads/${P}.tar.gz )
- binary? ( https://dev.gentoo.org/~tamiko/distfiles/${P}-bin.tar.xz )"
-fi
-
-DESCRIPTION="Open Source implementation of a 16-bit x86 BIOS"
-HOMEPAGE="https://www.seabios.org/"
-
-LICENSE="LGPL-3 GPL-3"
-SLOT="0"
-IUSE="+binary debug +seavgabios"
-
-REQUIRED_USE="debug? ( !binary )"
-
-SOURCE_DEPEND="
- >=sys-power/iasl-20060912
- ${PYTHON_DEPS}"
-DEPEND="
- !binary? (
- ${SOURCE_DEPEND}
- )"
-RDEPEND=""
-
-choose_target_chost() {
- if [[ -n "${CC}" ]]; then
- ${CC} -dumpmachine
- return
- fi
-
- if use amd64 || use x86; then
- # Use the native compiler
- echo "${CHOST}"
- return
- fi
-
- local i
- for i in x86_64 i686 i586 i486 i386 ; do
- i=${i}-pc-linux-gnu
- type -P ${i}-gcc > /dev/null && echo ${i} && return
- done
-}
-
-pkg_pretend() {
- if ! use binary; then
- ewarn "You have decided to compile your own SeaBIOS. This is not"
- ewarn "supported by upstream unless you use their recommended"
- ewarn "toolchain (which you are not)."
- elog
- ewarn "If you are intending to use this build with QEMU, realize"
- ewarn "you will not receive any support if you have compiled your"
- ewarn "own SeaBIOS. Virtual machines subtly fail based on changes"
- ewarn "in SeaBIOS."
- if [[ -z "$(choose_target_chost)" ]]; then
- elog
- eerror "Before you can compile ${PN}[-binary], you need to install a x86 cross-compiler"
- eerror "Run the following commands:"
- eerror " emerge crossdev"
- eerror " crossdev --stable -t x86_64-pc-linux-gnu"
- die "cross-compiler is needed"
- fi
- fi
-}
-
-pkg_setup() {
- use binary || python-any-r1_pkg_setup
-}
-
-src_unpack() {
- default
-
- # This simplifies the logic between binary & source builds.
- mkdir -p "${S}"
-}
-
-src_prepare() {
- default
-
- # Ensure precompiled iasl files are never used
- find "${WORKDIR}" -name '*.hex' -delete || die
-}
-
-src_configure() {
- use binary && return
-
- tc-ld-disable-gold #438058
-
- if use debug ; then
- echo "CONFIG_DEBUG_LEVEL=8" >.config
- fi
- _emake config
-}
-
-_emake() {
- LANG=C \
- emake V=1 \
- CC="$(tc-getCC)" \
- LD="$(tc-getLD)" \
- AR="$(tc-getAR)" \
- AS="$(tc-getAS)" \
- OBJCOPY="$(tc-getOBJCOPY)" \
- RANLIB="$(tc-getRANLIB)" \
- OBJDUMP="$(tc-getOBJDUMP)" \
- HOST_CC="$(tc-getBUILD_CC)" \
- VERSION="Gentoo/${EGIT_COMMIT:-${PVR}}" \
- "$@"
-}
-
-src_compile() {
- use binary && return
-
- local TARGET_CHOST=$(choose_target_chost)
-
- cp "${FILESDIR}/seabios/config.seabios-256k" .config || die
- _emake oldnoconfig
- CHOST="${TARGET_CHOST}" _emake iasl
- CHOST="${TARGET_CHOST}" _emake out/bios.bin
- mv out/bios.bin ../bios-256k.bin || die
-
- if use seavgabios ; then
- local config t targets=(
- cirrus
- isavga
- qxl
- stdvga
- virtio
- vmware
- )
- for t in "${targets[@]}" ; do
- emake clean distclean
- cp "${FILESDIR}/seavgabios/config.vga-${t}" .config || die
- _emake oldnoconfig
- CHOST="${TARGET_CHOST}" _emake out/vgabios.bin
- cp out/vgabios.bin ../vgabios-${t}.bin || die
- done
- fi
-}
-
-src_install() {
- insinto /usr/share/seabios
- doins ../bios-256k.bin
-
- if use seavgabios ; then
- insinto /usr/share/seavgabios
- doins ../vgabios*.bin
- fi
-}