summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/physlock/physlock-0.4.4.ebuild')
-rw-r--r--app-misc/physlock/physlock-0.4.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-misc/physlock/physlock-0.4.4.ebuild b/app-misc/physlock/physlock-0.4.4.ebuild
new file mode 100644
index 000000000000..750977a1c0e5
--- /dev/null
+++ b/app-misc/physlock/physlock-0.4.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="lightweight Linux console locking tool"
+HOMEPAGE="https://github.com/muennich/physlock"
+SRC_URI="https://github.com/muennich/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+}