summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/smtm/smtm-1.6.10-r1.ebuild')
-rw-r--r--app-misc/smtm/smtm-1.6.10-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/smtm/smtm-1.6.10-r1.ebuild b/app-misc/smtm/smtm-1.6.10-r1.ebuild
new file mode 100644
index 000000000000..14a034469bf8
--- /dev/null
+++ b/app-misc/smtm/smtm-1.6.10-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="Stock ticker, profit/loss calculator and chart tool"
+HOMEPAGE="http://eddelbuettel.com/dirk/code/smtm.html"
+SRC_URI="http://eddelbuettel.com/dirk/code/smtm/smtm_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+# This warrants USE examples
+IUSE=""
+
+DEPEND="dev-perl/perl-tk
+ dev-perl/DateManip
+ dev-perl/HTML-Parser
+ dev-perl/Finance-YahooQuote
+ dev-perl/libwww-perl"
+
+SRC_TEST="do parallel"
+
+src_install() {
+ perl-module_src_install
+ # install examples into own folder for now
+ docompress -x usr/share/doc/${PF}/examples
+ insinto usr/share/doc/${PF}/examples
+ doins examples/*
+}