summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/tmux/files/tmux-1.9a-flags.patch')
-rw-r--r--app-misc/tmux/files/tmux-1.9a-flags.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/tmux/files/tmux-1.9a-flags.patch b/app-misc/tmux/files/tmux-1.9a-flags.patch
new file mode 100644
index 000000000000..8bf21d86ed6c
--- /dev/null
+++ b/app-misc/tmux/files/tmux-1.9a-flags.patch
@@ -0,0 +1,28 @@
+--- tmux-1.9a/Makefile.am
++++ tmux-1.9a/Makefile.am
+@@ -27,23 +27,20 @@
+ if IS_GCC
+ CFLAGS += -std=gnu99
+ if IS_DEBUG
+-CFLAGS += -O0 -g
+ CFLAGS += -Wno-long-long -Wall -W -Wnested-externs -Wformat=2
+ CFLAGS += -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations
+ CFLAGS += -Wwrite-strings -Wshadow -Wpointer-arith -Wsign-compare
+ CFLAGS += -Wundef -Wbad-function-cast -Winline -Wcast-align
+ CFLAGS += -Wdeclaration-after-statement
+ CPPFLAGS += -DDEBUG
+-else
+-CFLAGS += -O2
+ endif
+ if IS_GCC4
+-CPPFLAGS += -iquote. -I/usr/local/include
++CPPFLAGS += -iquote.
+ if IS_DEBUG
+ CFLAGS += -Wno-pointer-sign
+ endif
+ else
+-CPPFLAGS += -I. -I- -I/usr/local/include
++CPPFLAGS += -I. -I-
+ endif
+ endif
+