summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.8.2-r1.ebuild')
-rw-r--r--dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.8.2-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.8.2-r1.ebuild b/dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.8.2-r1.ebuild
new file mode 100644
index 000000000000..ca01de330e4b
--- /dev/null
+++ b/dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.8.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.5.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="The Wadler/Leijen Pretty Printer for colored ANSI terminal output"
+HOMEPAGE="https://github.com/ekmett/ansi-wl-pprint"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="example"
+
+RDEPEND=">=dev-haskell/ansi-terminal-0.4.0:=[profile?]
+ >=dev-haskell/semigroups-0.1:=[profile?] <dev-haskell/semigroups-0.19:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag example example)
+}
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'ansi-terminal >= 0.4.0 && < 0.9' 'ansi-terminal >= 0.4.0'
+}