summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/lua')
-rw-r--r--dev-lang/lua/lua-5.1.5-r200.ebuild5
-rw-r--r--dev-lang/lua/lua-5.3.6-r102.ebuild5
-rw-r--r--dev-lang/lua/lua-5.4.6.ebuild5
3 files changed, 9 insertions, 6 deletions
diff --git a/dev-lang/lua/lua-5.1.5-r200.ebuild b/dev-lang/lua/lua-5.1.5-r200.ebuild
index 56b7cc7dbb99..7041b3869d45 100644
--- a/dev-lang/lua/lua-5.1.5-r200.ebuild
+++ b/dev-lang/lua/lua-5.1.5-r200.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit optfeature
+inherit libtool optfeature
DESCRIPTION="A powerful light-weight programming language designed for extending applications"
HOMEPAGE="https://www.lua.org/"
@@ -29,6 +29,7 @@ src_prepare() {
"${FILESDIR}"/${PN}-5.1.4-test.patch
)
default
+ elibtoolize
}
src_configure() {
diff --git a/dev-lang/lua/lua-5.3.6-r102.ebuild b/dev-lang/lua/lua-5.3.6-r102.ebuild
index 723277fb487a..db6f23a4a9ac 100644
--- a/dev-lang/lua/lua-5.3.6-r102.ebuild
+++ b/dev-lang/lua/lua-5.3.6-r102.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit flag-o-matic optfeature
+inherit flag-o-matic libtool optfeature
DESCRIPTION="A powerful light-weight programming language designed for extending applications"
HOMEPAGE="https://www.lua.org/"
@@ -24,6 +24,7 @@ BDEPEND="virtual/pkgconfig"
src_prepare() {
default
+ elibtoolize
if use elibc_musl; then
# locales on musl are non-functional (#834153)
diff --git a/dev-lang/lua/lua-5.4.6.ebuild b/dev-lang/lua/lua-5.4.6.ebuild
index b880a4d62f6b..9ec3e85313e3 100644
--- a/dev-lang/lua/lua-5.4.6.ebuild
+++ b/dev-lang/lua/lua-5.4.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit flag-o-matic optfeature
+inherit flag-o-matic libtool optfeature
DESCRIPTION="A powerful light-weight programming language designed for extending applications"
HOMEPAGE="https://www.lua.org/"
@@ -29,6 +29,7 @@ PATCHES=(
src_prepare() {
default
+ elibtoolize
if use elibc_musl; then
# locales on musl are non-functional (#834153)