summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/nim')
-rw-r--r--dev-lang/nim/nim-1.6.14-r1.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/dev-lang/nim/nim-1.6.14-r1.ebuild b/dev-lang/nim/nim-1.6.14-r1.ebuild
index bf22ccb6ecfe..85bb540e41e0 100644
--- a/dev-lang/nim/nim-1.6.14-r1.ebuild
+++ b/dev-lang/nim/nim-1.6.14-r1.ebuild
@@ -152,28 +152,35 @@ src_test() {
# AdditionalCategories from "testament/categories.nim".
categories+=( debugger examples lib )
- local tcat checkpoint
+ local test_return=0
+
+ local tcat
+ local checkpoint
for tcat in "${categories[@]}"; do
# Use checkpoints for less painful testing.
checkpoint="${T}/.testament-${tcat}"
+
[[ -f "${checkpoint}" ]] && continue
case ${tcat} in
testdata )
:
- ;;
+ ;;
arc | ic | valgrind )
einfo "Skipped category '${tcat}'"
;;
* )
einfo "Running tests in category '${tcat}'"
- edo ./bin/testament "${testament_args[@]}" \
- category "${tcat}" "${nimflags[@]}"
+ nonfatal edo ./bin/testament "${testament_args[@]}" \
+ category "${tcat}" "${nimflags[@]}" || test_return=1
;;
esac
touch "${checkpoint}" || die
done
+
+ [[ "${test_return}" -eq 1 ]] &&
+ die "tests failed, please inspect the failed test categories above"
}
src_install() {