summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pokerth/Manifest1
-rw-r--r--games-board/pokerth/files/pokerth-1.1.1-boost-1.60.patch150
-rw-r--r--games-board/pokerth/files/pokerth-1.1.1-boost-noexcept.patch80
-rw-r--r--games-board/pokerth/files/pokerth-1.1.1-qmake-gcc-6.patch86
-rw-r--r--games-board/pokerth/files/pokerth-1.1.1-qt5.patch19
-rw-r--r--games-board/pokerth/pokerth-1.1.1-r2.ebuild76
6 files changed, 0 insertions, 412 deletions
diff --git a/games-board/pokerth/Manifest b/games-board/pokerth/Manifest
index 75c22499163e..1e96e868f0e6 100644
--- a/games-board/pokerth/Manifest
+++ b/games-board/pokerth/Manifest
@@ -1,2 +1 @@
-DIST PokerTH-1.1.1-src.tar.bz2 19326922 BLAKE2B 43c94c1330ca11eaa52e4729e52fed3ee4022b8486b626168933a20658bf0c79028adb39b68433e5ccb7c8618b610366f193720f821039adc0e9a84eff0488b7 SHA512 bd822d15747d94b67657ea2fd0b9c8c1bdad0031a6eae30380217387a702e5f648d6f612b1bff0355c3c301ecaf47ca9d635a526e575f1bc1c5f88e38a7f73c1
DIST pokerth-1.1.2.tar.gz 21354306 BLAKE2B d8e1ecc46e61d9c16ae3949099f6e72271a5ab2def9799652b0c612980e0c5e96cb2ccf4d659c1a90b9ac6433af95587fa5d44af80c16fb6a34a272751c9fc4a SHA512 d54c84f199636eb5a53580213e5e4ccc828cf565bf4b055797daa82e2ad54d8c52c7a16a781b82c8cc89d184a2b3c4105922394d08c7d2e06383b96963c36b5a
diff --git a/games-board/pokerth/files/pokerth-1.1.1-boost-1.60.patch b/games-board/pokerth/files/pokerth-1.1.1-boost-1.60.patch
deleted file mode 100644
index daaeca013b32..000000000000
--- a/games-board/pokerth/files/pokerth-1.1.1-boost-1.60.patch
+++ /dev/null
@@ -1,150 +0,0 @@
-From 69f820bb3d7c4dc8c838f115cb4c7ee5fd188721 Mon Sep 17 00:00:00 2001
-From: Jonathan Wakely <github@kayari.org>
-Date: Thu, 26 Nov 2015 16:27:52 +0000
-Subject: [PATCH] Qualify std::ifstream and std::ofstream
-
-Starting with Boost 1.60.0 <boost/filesystem.hpp> includes
-<boost/filesystem/fstream.hpp>, which declares ifstream and ofstream
-types that make the unqualified names ifstream and ofstream ambiguous.
-The names must be qualified to refer to the std versions.
----
- src/core/common/avatarmanager.cpp | 4 ++--
- src/core/common/loghelper_server.cpp | 6 +++---
- src/net/common/clientstate.cpp | 4 ++--
- src/net/common/clientthread.cpp | 4 ++--
- src/net/common/downloaderthread.cpp | 2 +-
- src/pokerth_server.cpp | 2 +-
- src/zlib_compress.cpp | 4 ++--
- 7 files changed, 13 insertions(+), 13 deletions(-)
-
-diff --git a/src/core/common/avatarmanager.cpp b/src/core/common/avatarmanager.cpp
-index a8a52e4..0246b72 100644
---- a/src/core/common/avatarmanager.cpp
-+++ b/src/core/common/avatarmanager.cpp
-@@ -61,7 +61,7 @@ using namespace std;
- using namespace boost::filesystem;
-
- struct AvatarFileState {
-- ifstream inputStream;
-+ std::ifstream inputStream;
- };
-
- AvatarManager::AvatarManager(bool useExternalServer, const std::string &externalServerAddress,
-@@ -371,7 +371,7 @@ AvatarManager::StoreAvatarInCache(const MD5Buf &md5buf, AvatarFileType avatarFil
- path tmpPath(cacheDir);
- tmpPath /= (md5buf.ToString() + ext);
- string fileName(tmpPath.file_string());
-- ofstream o(fileName.c_str(), ios_base::out | ios_base::binary | ios_base::trunc);
-+ std::ofstream o(fileName.c_str(), ios_base::out | ios_base::binary | ios_base::trunc);
- if (!o.fail()) {
- o.write((const char *)data, size);
- o.close();
-diff --git a/src/core/common/loghelper_server.cpp b/src/core/common/loghelper_server.cpp
-index f79e4ca..a0d0350 100644
---- a/src/core/common/loghelper_server.cpp
-+++ b/src/core/common/loghelper_server.cpp
-@@ -67,7 +67,7 @@ void
- internal_log_err(const string &msg)
- {
- if (!g_logFile.empty()) {
-- ofstream o(g_logFile.c_str(), ios_base::out | ios_base::app);
-+ std::ofstream o(g_logFile.c_str(), ios_base::out | ios_base::app);
- if (!o.fail()) {
- o << second_clock::local_time() << " ERR: " << msg;
- o.flush();
-@@ -80,7 +80,7 @@ internal_log_msg(const std::string &msg)
- {
- if (g_logLevel) {
- if (!g_logFile.empty()) {
-- ofstream o(g_logFile.c_str(), ios_base::out | ios_base::app);
-+ std::ofstream o(g_logFile.c_str(), ios_base::out | ios_base::app);
- if (!o.fail())
- o << second_clock::local_time() << " MSG: " << msg;
- }
-@@ -92,7 +92,7 @@ internal_log_level(const std::string &msg, int logLevel)
- {
- if (g_logLevel >= logLevel) {
- if (!g_logFile.empty()) {
-- ofstream o(g_logFile.c_str(), ios_base::out | ios_base::app);
-+ std::ofstream o(g_logFile.c_str(), ios_base::out | ios_base::app);
- if (!o.fail())
- o << second_clock::local_time() << " OUT: " << msg;
- }
-diff --git a/src/net/common/clientstate.cpp b/src/net/common/clientstate.cpp
-index 143773b..080da2d 100644
---- a/src/net/common/clientstate.cpp
-+++ b/src/net/common/clientstate.cpp
-@@ -308,8 +308,8 @@ ClientStateReadingServerList::Enter(boost::shared_ptr<ClientThread> client)
-
- // Unzip the file using zlib.
- try {
-- ifstream inFile(zippedServerListPath.directory_string().c_str(), ios_base::in | ios_base::binary);
-- ofstream outFile(xmlServerListPath.directory_string().c_str(), ios_base::out | ios_base::trunc);
-+ std::ifstream inFile(zippedServerListPath.directory_string().c_str(), ios_base::in | ios_base::binary);
-+ std::ofstream outFile(xmlServerListPath.directory_string().c_str(), ios_base::out | ios_base::trunc);
- boost::iostreams::filtering_streambuf<boost::iostreams::input> in;
- in.push(boost::iostreams::zlib_decompressor());
- in.push(inFile);
-diff --git a/src/net/common/clientthread.cpp b/src/net/common/clientthread.cpp
-index d60a535..1f3a619 100644
---- a/src/net/common/clientthread.cpp
-+++ b/src/net/common/clientthread.cpp
-@@ -1695,7 +1695,7 @@ void
- ClientThread::ReadSessionGuidFromFile()
- {
- string guidFileName(GetContext().GetCacheDir() + TEMP_GUID_FILENAME);
-- ifstream guidStream(guidFileName.c_str(), ios::in | ios::binary);
-+ std::ifstream guidStream(guidFileName.c_str(), ios::in | ios::binary);
- if (guidStream.good()) {
- std::vector<char> tmpGuid(CLIENT_GUID_SIZE);
- guidStream.read(&tmpGuid[0], CLIENT_GUID_SIZE);
-@@ -1707,7 +1707,7 @@ void
- ClientThread::WriteSessionGuidToFile() const
- {
- string guidFileName(GetContext().GetCacheDir() + TEMP_GUID_FILENAME);
-- ofstream guidStream(guidFileName.c_str(), ios::out | ios::trunc | ios::binary);
-+ std::ofstream guidStream(guidFileName.c_str(), ios::out | ios::trunc | ios::binary);
- if (guidStream.good()) {
- guidStream.write(GetContext().GetSessionGuid().c_str(), GetContext().GetSessionGuid().size());
- }
-diff --git a/src/net/common/downloaderthread.cpp b/src/net/common/downloaderthread.cpp
-index e58e3f8..56a9526 100644
---- a/src/net/common/downloaderthread.cpp
-+++ b/src/net/common/downloaderthread.cpp
-@@ -96,7 +96,7 @@ DownloaderThread::Main()
- // Previous download was finished.
- if (m_curDownloadData) {
- path filepath(m_curDownloadData->filename);
-- ifstream instream(filepath.file_string().c_str(), ios_base::in | ios_base::binary);
-+ std::ifstream instream(filepath.file_string().c_str(), ios_base::in | ios_base::binary);
- // Find out file size.
- // Not fully portable, but works on win/linux/mac.
- instream.seekg(0, ios_base::beg);
-diff --git a/src/pokerth_server.cpp b/src/pokerth_server.cpp
-index 3b93d46..450a47e 100644
---- a/src/pokerth_server.cpp
-+++ b/src/pokerth_server.cpp
-@@ -161,7 +161,7 @@ main(int argc, char *argv[])
- pidFile = tmpPidPath.directory_string();
- }
- {
-- ofstream pidStream(pidFile.c_str(), ios_base::out | ios_base::trunc);
-+ std::ofstream pidStream(pidFile.c_str(), ios_base::out | ios_base::trunc);
- if (!pidStream.fail())
- pidStream << getpid();
- else
-diff --git a/src/zlib_compress.cpp b/src/zlib_compress.cpp
-index e3fd72d..4b04817 100644
---- a/src/zlib_compress.cpp
-+++ b/src/zlib_compress.cpp
-@@ -59,8 +59,8 @@ main(int argc, char *argv[])
- return 2;
- }
- try {
-- ifstream inFile(inputFilePath.directory_string().c_str(), ios_base::in);
-- ofstream outFile(outputFilePath.directory_string().c_str(), ios_base::out | ios_base::binary);
-+ std::ifstream inFile(inputFilePath.directory_string().c_str(), ios_base::in);
-+ std::ofstream outFile(outputFilePath.directory_string().c_str(), ios_base::out | ios_base::binary);
- boost::iostreams::filtering_streambuf<boost::iostreams::output> out;
- out.push(boost::iostreams::zlib_compressor());
- out.push(outFile);
diff --git a/games-board/pokerth/files/pokerth-1.1.1-boost-noexcept.patch b/games-board/pokerth/files/pokerth-1.1.1-boost-noexcept.patch
deleted file mode 100644
index ab112e831a0c..000000000000
--- a/games-board/pokerth/files/pokerth-1.1.1-boost-noexcept.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-Keep dynamic exception specifications in sync with boost.
-See also: https://bugs.gentoo.org/show_bug.cgi?id=603354
-
---- a/src/third_party/websocketpp/websocketpp/error.hpp
-+++ b/src/third_party/websocketpp/websocketpp/error.hpp
-@@ -122,7 +122,7 @@
- public:
- category() {}
-
-- char const * name() const _WEBSOCKETPP_NOEXCEPT_TOKEN_ {
-+ char const * name() const BOOST_SYSTEM_NOEXCEPT {
- return "websocketpp";
- }
-
---- a/src/third_party/websocketpp/websocketpp/extensions/extension.hpp
-+++ b/src/third_party/websocketpp/websocketpp/extensions/extension.hpp
-@@ -62,7 +62,7 @@
- public:
- category() {}
-
-- const char *name() const _WEBSOCKETPP_NOEXCEPT_TOKEN_ {
-+ const char *name() const BOOST_SYSTEM_NOEXCEPT {
- return "websocketpp.extension";
- }
-
---- a/src/third_party/websocketpp/websocketpp/processors/base.hpp
-+++ b/src/third_party/websocketpp/websocketpp/processors/base.hpp
-@@ -159,7 +159,7 @@
- public:
- processor_category() {}
-
-- char const * name() const _WEBSOCKETPP_NOEXCEPT_TOKEN_ {
-+ char const * name() const BOOST_SYSTEM_NOEXCEPT {
- return "websocketpp.processor";
- }
-
---- a/src/third_party/websocketpp/websocketpp/transport/asio/base.hpp
-+++ b/src/third_party/websocketpp/websocketpp/transport/asio/base.hpp
-@@ -202,7 +202,7 @@
- /// Asio transport error category
- class category : public lib::error_category {
- public:
-- char const * name() const _WEBSOCKETPP_NOEXCEPT_TOKEN_ {
-+ char const * name() const BOOST_SYSTEM_NOEXCEPT {
- return "websocketpp.transport.asio";
- }
-
---- a/src/third_party/websocketpp/websocketpp/transport/asio/security/base.hpp
-+++ b/src/third_party/websocketpp/websocketpp/transport/asio/security/base.hpp
-@@ -102,7 +102,7 @@
- /// Error category related to asio transport socket policies
- class socket_category : public lib::error_category {
- public:
-- const char *name() const _WEBSOCKETPP_NOEXCEPT_TOKEN_ {
-+ const char *name() const BOOST_SYSTEM_NOEXCEPT {
- return "websocketpp.transport.asio.socket";
- }
-
---- a/src/third_party/websocketpp/websocketpp/transport/base/connection.hpp
-+++ b/src/third_party/websocketpp/websocketpp/transport/base/connection.hpp
-@@ -179,7 +179,7 @@
- public:
- category() {}
-
-- char const * name() const _WEBSOCKETPP_NOEXCEPT_TOKEN_ {
-+ char const * name() const BOOST_SYSTEM_NOEXCEPT {
- return "websocketpp.transport";
- }
-
---- a/src/third_party/websocketpp/websocketpp/transport/iostream/base.hpp
-+++ b/src/third_party/websocketpp/websocketpp/transport/iostream/base.hpp
-@@ -64,7 +64,7 @@
- public:
- category() {}
-
-- char const * name() const _WEBSOCKETPP_NOEXCEPT_TOKEN_ {
-+ char const * name() const BOOST_SYSTEM_NOEXCEPT {
- return "websocketpp.transport.iostream";
- }
-
diff --git a/games-board/pokerth/files/pokerth-1.1.1-qmake-gcc-6.patch b/games-board/pokerth/files/pokerth-1.1.1-qmake-gcc-6.patch
deleted file mode 100644
index aebf2b0ab946..000000000000
--- a/games-board/pokerth/files/pokerth-1.1.1-qmake-gcc-6.patch
+++ /dev/null
@@ -1,86 +0,0 @@
-From: Markus Koschany <apo@debian.org>
-Date: Tue, 23 Aug 2016 17:50:52 +0200
-Subject: qmake gcc-6
-
----
- chatcleaner.pro | 1 -
- pokerth_db.pro | 1 -
- pokerth_game.pro | 1 -
- pokerth_lib.pro | 2 +-
- pokerth_protocol.pro | 1 -
- pokerth_server.pro | 1 -
- 6 files changed, 1 insertion(+), 6 deletions(-)
-
-diff --git a/chatcleaner.pro b/chatcleaner.pro
-index 6d63b4a..56070d8 100644
---- a/chatcleaner.pro
-+++ b/chatcleaner.pro
-@@ -49,7 +49,6 @@ win32 {
- !win32{
- ##### My release static build options
- #QMAKE_CXXFLAGS += -ffunction-sections -fdata-sections
-- INCLUDEPATH += $${PREFIX}/include
- }
- mac {
- # make it x86_64 only
-diff --git a/pokerth_db.pro b/pokerth_db.pro
-index 7c2d142..c524ee3 100644
---- a/pokerth_db.pro
-+++ b/pokerth_db.pro
-@@ -49,7 +49,6 @@ win32{
- !win32{
- ##### My release static build options
- #QMAKE_CXXFLAGS += -ffunction-sections -fdata-sections
-- INCLUDEPATH += $${PREFIX}/include
- }
-
- mac{
-diff --git a/pokerth_game.pro b/pokerth_game.pro
-index e3ddb03..e0e8660 100644
---- a/pokerth_game.pro
-+++ b/pokerth_game.pro
-@@ -404,7 +404,6 @@ unix:!mac {
- # #### My release static build options
- # QMAKE_CXXFLAGS += -ffunction-sections -fdata-sections
- # QMAKE_LFLAGS += -Wl,--gc-sections
-- INCLUDEPATH += $${PREFIX}/include
- QMAKE_LIBDIR += lib
- !android{
- LIBPATH += $${PREFIX}/lib /opt/gsasl/lib
-diff --git a/pokerth_lib.pro b/pokerth_lib.pro
-index 6db489d..498d06e 100644
---- a/pokerth_lib.pro
-+++ b/pokerth_lib.pro
-@@ -243,7 +243,7 @@ win32{
- !win32{
- ##### My release static build options
- #QMAKE_CXXFLAGS += -ffunction-sections -fdata-sections
-- INCLUDEPATH += $${PREFIX}/include /opt/gsasl/include
-+ INCLUDEPATH += /opt/gsasl/include
- }
-
- mac{
-diff --git a/pokerth_protocol.pro b/pokerth_protocol.pro
-index 7a331df..2ead0ec 100644
---- a/pokerth_protocol.pro
-+++ b/pokerth_protocol.pro
-@@ -33,7 +33,6 @@ win32 {
- DEFINES += _WIN32_WINNT=0x0501
- }
- unix : !mac {
-- INCLUDEPATH += $${PREFIX}/include
- system(protoc pokerth.proto --cpp_out=src/third_party/protobuf)
- system(protoc chatcleaner.proto --cpp_out=src/third_party/protobuf)
- system(protoc pokerth.proto --java_out=tests/src)
-diff --git a/pokerth_server.pro b/pokerth_server.pro
-index 706475f..43b30f3 100644
---- a/pokerth_server.pro
-+++ b/pokerth_server.pro
-@@ -174,7 +174,6 @@ unix : !mac {
- #QMAKE_LFLAGS += -Wl,--gc-sections
-
- LIBPATH += lib $${PREFIX}/lib /opt/gsasl/lib
-- INCLUDEPATH += $${PREFIX}/include
- LIB_DIRS = $${PREFIX}/lib $${PREFIX}/lib64 $$system(qmake -query QT_INSTALL_LIBS)
- BOOST_FS = boost_filesystem boost_filesystem-mt
- BOOST_THREAD = boost_thread boost_thread-mt
diff --git a/games-board/pokerth/files/pokerth-1.1.1-qt5.patch b/games-board/pokerth/files/pokerth-1.1.1-qt5.patch
deleted file mode 100644
index 1d3dd63922fb..000000000000
--- a/games-board/pokerth/files/pokerth-1.1.1-qt5.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-From 731f5f05f54065a67fa7c9f9bc8fe992390cb979 Mon Sep 17 00:00:00 2001
-From: Felix Hammer <f.hammer@web.de>
-Date: Fri, 7 Aug 2015 00:57:51 +0200
-Subject: [PATCH] Qt 5.5.0 patch for qtsingleapplication
-
----
- src/third_party/qtsingleapplication/qtlocalpeer.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
---- a/src/third_party/qtsingleapplication/qtlocalpeer.cpp
-+++ b/src/third_party/qtsingleapplication/qtlocalpeer.cpp
-@@ -31,6 +31,7 @@
-
- #include <QCoreApplication>
- #include <QTime>
-+#include <QDataStream>
-
- #if defined(Q_OS_WIN)
- #include <QLibrary>
diff --git a/games-board/pokerth/pokerth-1.1.1-r2.ebuild b/games-board/pokerth/pokerth-1.1.1-r2.ebuild
deleted file mode 100644
index a7c17d198096..000000000000
--- a/games-board/pokerth/pokerth-1.1.1-r2.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils flag-o-matic qmake-utils
-
-MY_P="PokerTH-${PV}-src"
-DESCRIPTION="Texas Hold'em poker game"
-HOMEPAGE="https://www.pokerth.net/"
-SRC_URI="mirror://sourceforge/pokerth/${MY_P}.tar.bz2"
-
-LICENSE="AGPL-3 GPL-1 GPL-2 GPL-3 BitstreamVera public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="dedicated"
-
-RDEPEND="dev-db/sqlite:3
- dev-libs/boost:=[threads(+)]
- dev-libs/libgcrypt:0
- dev-libs/protobuf
- dev-libs/tinyxml[stl]
- dev-qt/qtcore:5
- dev-qt/qtnetwork:5
- >=net-libs/libircclient-1.6-r2
- >=net-misc/curl-7.16
- virtual/gsasl
- !dedicated? (
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- media-libs/libsdl:0
- media-libs/sdl-mixer[mod,vorbis]
- )"
-DEPEND="${RDEPEND}
- !dedicated? ( dev-qt/qtsql:5 )
- virtual/pkgconfig"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.1.1-qt5.patch
- "${FILESDIR}"/${PN}-1.1.1-boost-1.60.patch
- "${FILESDIR}"/${PN}-1.1.1-qmake-gcc-6.patch
- "${FILESDIR}"/${PN}-1.1.1-boost-noexcept.patch
- "${FILESDIR}"/${PN}-1.1.1-boost-1.65-ambiguous-advance.patch
-)
-
-src_prepare() {
- default
-
- if use dedicated; then
- sed -i -e 's/pokerth_game.pro//' pokerth.pro || die
- fi
-
- sed -i -e '/no_dead_strip_inits_and_terms/d' *pro || die
-}
-
-src_configure() {
- eqmake5 pokerth.pro
-}
-
-src_install() {
- dobin bin/pokerth_server
- if ! use dedicated; then
- dobin ${PN}
- insinto /usr/share/${PN}
- doins -r data
- domenu ${PN}.desktop
- doicon ${PN}.png
- fi
-
- einstalldocs
- dodoc docs/{gui_styling,server_setup}_howto.txt
-
- doman docs/pokerth.1
-}