summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/nestopia/nestopia-1.51.1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/games-emulation/nestopia/nestopia-1.51.1.ebuild b/games-emulation/nestopia/nestopia-1.51.1.ebuild
index c6bdbe0d6fb8..ebab0b9b149b 100644
--- a/games-emulation/nestopia/nestopia-1.51.1.ebuild
+++ b/games-emulation/nestopia/nestopia-1.51.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools xdg
+inherit autotools flag-o-matic xdg
DESCRIPTION="Portable Nintendo Entertainment System emulator written in C++"
HOMEPAGE="http://0ldsk00l.ca/nestopia/"
@@ -38,5 +38,8 @@ src_prepare() {
}
src_configure() {
+ # silence the narrowing warnings on clang (#830469)
+ append-cxxflags -Wno-narrowing
+
econf $(use_enable doc)
}