summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r4.ebuild9
-rw-r--r--sci-mathematics/gmp-ecm/gmp-ecm-7.0.5.ebuild6
2 files changed, 12 insertions, 3 deletions
diff --git a/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r4.ebuild b/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r4.ebuild
index 2a77bd33a96a..404d71631f44 100644
--- a/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r4.ebuild
+++ b/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools flag-o-matic toolchain-funcs
+inherit autotools toolchain-funcs
MY_PN="ecm"
MY_P="${MY_PN}-${PV}"
@@ -27,7 +27,11 @@ PATCHES=(
S="${WORKDIR}/${MY_P}"
pkg_pretend() {
- use openmp && tc-check-openmp
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_prepare(){
@@ -64,6 +68,7 @@ src_compile() {
emake ecm-params && emake clean && emake
fi
}
+
src_configure() {
econf \
--enable-shared \
diff --git a/sci-mathematics/gmp-ecm/gmp-ecm-7.0.5.ebuild b/sci-mathematics/gmp-ecm/gmp-ecm-7.0.5.ebuild
index bf4ba87d79a1..42feb39cf26a 100644
--- a/sci-mathematics/gmp-ecm/gmp-ecm-7.0.5.ebuild
+++ b/sci-mathematics/gmp-ecm/gmp-ecm-7.0.5.ebuild
@@ -30,7 +30,11 @@ BDEPEND="dev-libs/libxslt
S="${WORKDIR}/${MY_P}"
pkg_pretend() {
- use openmp && tc-check-openmp
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_compile() {