summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon the Sorcerer <neuron@mail.uni-paderborn.de>2017-12-24 11:11:22 +0100
committerSimon the Sorcerer <neuron@mail.uni-paderborn.de>2017-12-24 11:11:22 +0100
commit36e2b03d22d178784ab0ffa4e1127fdf24d4435a (patch)
tree07807b1a89a7195623a644a69c18452ca275ade5
parentadded media-sound/exaile. (diff)
downloaddarkelf-36e2b03d22d178784ab0ffa4e1127fdf24d4435a.tar.gz
darkelf-36e2b03d22d178784ab0ffa4e1127fdf24d4435a.tar.bz2
darkelf-36e2b03d22d178784ab0ffa4e1127fdf24d4435a.zip
added app-shells/zsh-syntax-highlighting.
-rw-r--r--app-shells/zsh-syntax-highlighting/Manifest4
-rw-r--r--app-shells/zsh-syntax-highlighting/metadata.xml13
-rw-r--r--app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.0.ebuild66
-rw-r--r--app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-9999.ebuild66
4 files changed, 149 insertions, 0 deletions
diff --git a/app-shells/zsh-syntax-highlighting/Manifest b/app-shells/zsh-syntax-highlighting/Manifest
new file mode 100644
index 0000000..0699e7f
--- /dev/null
+++ b/app-shells/zsh-syntax-highlighting/Manifest
@@ -0,0 +1,4 @@
+DIST zsh-syntax-highlighting-0.6.0.tar.gz 111534 SHA256 e69db483e20228b72ccfa401e9ad6cf80d6edb48c68acca9102b50b311821b84 SHA512 bb83f41336e9010aa78ee5adc9a216ee53f3b4347041d1b273083940d9db4d0e4acd960150b28c41f6e5e8d00b029f00fca6f9a46955892e4547a9f2345e3b85 WHIRLPOOL 32d0b069134ccfe79d7e516f8a952755dc4a7bdbe6f3505b2de0c6edcdfbb26155950971d0e9f414c0201d3a62e1f7d19daf72c1af365236e94ef23fe62bd522
+EBUILD zsh-syntax-highlighting-0.6.0.ebuild 1687 SHA256 1057c8e542b98d263c3764b9a1060d2640cab4efe9238ea6298913d985148640 SHA512 178d3227b65f3f8c9d7570daa06c7275655b8d5b03ba5d907ed312929c54ee4bbadea053ec52c24fd946e0bd59c7750b99fded3d120066eecdb62af4f58d604b WHIRLPOOL a7928dc7bf56c6280791f79fb35d68f7e7a8df0f119edddb921e85c08062caf04a5aa4be2d206d28c53d404f16f9d9bff8e0a7b7ac377e7c7f9f073306df31dc
+EBUILD zsh-syntax-highlighting-9999.ebuild 1687 SHA256 1057c8e542b98d263c3764b9a1060d2640cab4efe9238ea6298913d985148640 SHA512 178d3227b65f3f8c9d7570daa06c7275655b8d5b03ba5d907ed312929c54ee4bbadea053ec52c24fd946e0bd59c7750b99fded3d120066eecdb62af4f58d604b WHIRLPOOL a7928dc7bf56c6280791f79fb35d68f7e7a8df0f119edddb921e85c08062caf04a5aa4be2d206d28c53d404f16f9d9bff8e0a7b7ac377e7c7f9f073306df31dc
+MISC metadata.xml 739 SHA256 1b05a94f03e992c00a9f4e71116f9539f39d6f4fcfce1e6fe52d88be621c5575 SHA512 95a3f441c14792c8983aa608055171c5a4f6e2a018f7968c35505ac4909251f3936de4a40d310192d3d1363feee794904875af6101929a1b60e11c12fb260d09 WHIRLPOOL c7af244de136d3e2c5e4347133e44d42d2b825e422573720f0c28644e524998369bd4e9ab8116e85d69b9be273cc7d30fbf95615dbb0a0ed599a78ceef579865
diff --git a/app-shells/zsh-syntax-highlighting/metadata.xml b/app-shells/zsh-syntax-highlighting/metadata.xml
new file mode 100644
index 0000000..d074d80
--- /dev/null
+++ b/app-shells/zsh-syntax-highlighting/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>neuron@mail.uni-paderborn.de</email>
+ <description>Primary maintainer</description>
+</maintainer>
+<longdescription>This package provides syntax highlighing for the shell zsh. It enables highlighing of commands whilst they are typed at a zsh prompt into an interactive terminal. This helps in reviewing commands before running them, particularly in catching syntax errors.</longdescription>
+<upstream>
+ <bugs-to>https://github.com/zsh-users/zsh-syntax-highlighting/issues</bugs-to>
+ <remote-id type="github">zsh-users/zsh-syntax-highlighting</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.0.ebuild b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.0.ebuild
new file mode 100644
index 0000000..a4ee54e
--- /dev/null
+++ b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit readme.gentoo-r1
+
+case ${PV} in
+9999*)
+ EGIT_REPO_URI="https://github.com/zsh-users/${PN}.git"
+ inherit git-r3
+ PROPERTIES="live"
+ SRC_URI=""
+ KEYWORDS="";;
+*)
+ RESTRICT="mirror"
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV/_rc/-rc}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris";;
+esac
+
+DESCRIPTION="Fish shell like syntax highlighting for zsh."
+HOMEPAGE="https://github.com/zsh-users/zsh-syntax-highlighting"
+
+LICENSE="HPND"
+SLOT="0"
+IUSE=""
+
+RDEPEND="app-shells/zsh"
+DEPEND=""
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. /usr/share/zsh/site-contrib/${PN}/zsh-syntax-highlighting.zsh
+at the end of your ~/.zshrc
+For testing, you can also execute the above command in your zsh."
+
+MAKE_ARGS=(
+ "SHARE_DIR=${ED}/usr/share/zsh/site-contrib/${PN}"
+ "DOC_DIR=${ED}/usr/share/doc/${PF}"
+)
+
+src_prepare() {
+ grep -q 'local .*cdpath_dir' \
+ "${S}/highlighters/main/main-highlighter.zsh" >/dev/null 2>&1 || \
+ sed -i -e '/for cdpath_dir/ilocal cdpath_dir' \
+ -- "${S}/highlighters/main/main-highlighter.zsh" || die
+ eapply_user
+}
+
+src_compile() {
+ emake "${MAKE_ARGS[@]}"
+}
+
+src_install() {
+ emake "${MAKE_ARGS[@]}" install
+ readme.gentoo_create_doc
+}
+
+src_test() {
+ emake "${MAKE_ARGS[@]}" test
+ emake "${MAKE_ARGS[@]}" perf
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-9999.ebuild b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-9999.ebuild
new file mode 100644
index 0000000..a4ee54e
--- /dev/null
+++ b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-9999.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit readme.gentoo-r1
+
+case ${PV} in
+9999*)
+ EGIT_REPO_URI="https://github.com/zsh-users/${PN}.git"
+ inherit git-r3
+ PROPERTIES="live"
+ SRC_URI=""
+ KEYWORDS="";;
+*)
+ RESTRICT="mirror"
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV/_rc/-rc}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris";;
+esac
+
+DESCRIPTION="Fish shell like syntax highlighting for zsh."
+HOMEPAGE="https://github.com/zsh-users/zsh-syntax-highlighting"
+
+LICENSE="HPND"
+SLOT="0"
+IUSE=""
+
+RDEPEND="app-shells/zsh"
+DEPEND=""
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. /usr/share/zsh/site-contrib/${PN}/zsh-syntax-highlighting.zsh
+at the end of your ~/.zshrc
+For testing, you can also execute the above command in your zsh."
+
+MAKE_ARGS=(
+ "SHARE_DIR=${ED}/usr/share/zsh/site-contrib/${PN}"
+ "DOC_DIR=${ED}/usr/share/doc/${PF}"
+)
+
+src_prepare() {
+ grep -q 'local .*cdpath_dir' \
+ "${S}/highlighters/main/main-highlighter.zsh" >/dev/null 2>&1 || \
+ sed -i -e '/for cdpath_dir/ilocal cdpath_dir' \
+ -- "${S}/highlighters/main/main-highlighter.zsh" || die
+ eapply_user
+}
+
+src_compile() {
+ emake "${MAKE_ARGS[@]}"
+}
+
+src_install() {
+ emake "${MAKE_ARGS[@]}" install
+ readme.gentoo_create_doc
+}
+
+src_test() {
+ emake "${MAKE_ARGS[@]}" test
+ emake "${MAKE_ARGS[@]}" perf
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}