aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrei Horodniceanu <a.horodniceanu@proton.me>2024-05-30 20:00:53 +0300
committerAndrei Horodniceanu <a.horodniceanu@proton.me>2024-05-30 20:00:53 +0300
commite43ae4bf0767567abe5a86127359df271f2cb5a5 (patch)
tree7c7fb0de3f0858c3f0de8047f84589562aa564f0
parentdev-util/dfmt: drop 0.15.1-r1 (diff)
downloaddlang-e43ae4bf0767567abe5a86127359df271f2cb5a5.tar.gz
dlang-e43ae4bf0767567abe5a86127359df271f2cb5a5.tar.bz2
dlang-e43ae4bf0767567abe5a86127359df271f2cb5a5.zip
dev-util/dlang-tools: drop 2.107.0
Signed-off-by: Andrei Horodniceanu <a.horodniceanu@proton.me>
-rw-r--r--dev-util/dlang-tools/dlang-tools-2.107.0.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/dev-util/dlang-tools/dlang-tools-2.107.0.ebuild b/dev-util/dlang-tools/dlang-tools-2.107.0.ebuild
deleted file mode 100644
index ea02763..0000000
--- a/dev-util/dlang-tools/dlang-tools-2.107.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DESCRIPTION="Ancilliary tools for the D programming language compiler"
-HOMEPAGE="http://dlang.org/"
-LICENSE="Boost-1.0"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-TOOLS="ddemangle detab dustmite rdmd"
-IUSE="+ddemangle detab dustmite +rdmd"
-REQUIRED_USE="|| ( ${TOOLS} )"
-
-DLANG_SLOT="$(ver_cut 1-2)"
-RESTRICT="mirror"
-
-BETA="$(ver_cut 4)"
-VERSION="$(ver_cut 1-3)"
-
-if [[ -n "${BETA}" ]]; then
- # We want to convert a Gentoo version string into an upstream one: 2.097.0_rc1 -> 2.097.0-rc.1
- VERSION="$(ver_rs 3 "-" 4 ".")"
-fi
-SRC_URI="https://codeload.github.com/dlang/tools/tar.gz/v${VERSION} -> dlang-tools-${VERSION}.tar.gz"
-
-DLANG_VERSION_RANGE="2.100-2.107"
-DLANG_PACKAGE_TYPE="single"
-
-inherit desktop dlang xdg-utils
-
-S="${WORKDIR}/tools-${VERSION}"
-
-d_src_compile() {
- use ddemangle && dlang_compile_bin ddemangle ddemangle.d
- use detab && dlang_compile_bin detab detab.d
- use dustmite && dlang_compile_bin dustmite DustMite/dustmite.d DustMite/splitter.d DustMite/polyhash.d
- use rdmd && dlang_compile_bin rdmd rdmd.d
-}
-
-d_src_install() {
- for tool in ${TOOLS}; do
- if use "${tool}"; then
- dobin "${tool}"
- fi
- done
-
- # file icons
- for size in 16 22 24 32 48 256; do
- newicon --size "${size}" --context mimetypes "${FILESDIR}/icons/${size}/dmd-source.png" text-x-dsrc.png
- done
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}