aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuel Bernardo <samuelbernardo.mail@gmail.com>2021-01-17 18:05:11 +0000
committerSamuel Bernardo <samuelbernardo.mail@gmail.com>2021-01-17 18:05:11 +0000
commit7bfdff49c492ca882c53f6db90196d0940c2c2ff (patch)
tree0340eecedc471839f8dabdbe08416cdd44b32d16 /net-misc
parentUpdate openoffice-bin (diff)
downloadssnb-7bfdff49c492ca882c53f6db90196d0940c2c2ff.tar.gz
ssnb-7bfdff49c492ca882c53f6db90196d0940c2c2ff.tar.bz2
ssnb-7bfdff49c492ca882c53f6db90196d0940c2c2ff.zip
Update megasync
Signed-off-by: Samuel Bernardo <samuelbernardo.mail@gmail.com>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/megasync/megasync-4.3.1-r1.ebuild150
-rw-r--r--net-misc/megasync/megasync-4.3.7.0.ebuild (renamed from net-misc/megasync/megasync-4.3.3.ebuild)140
-rw-r--r--[l---------]net-misc/megasync/megasync-9999.ebuild120
3 files changed, 191 insertions, 219 deletions
diff --git a/net-misc/megasync/megasync-4.3.1-r1.ebuild b/net-misc/megasync/megasync-4.3.1-r1.ebuild
deleted file mode 100644
index d4a648f..0000000
--- a/net-misc/megasync/megasync-4.3.1-r1.ebuild
+++ /dev/null
@@ -1,150 +0,0 @@
-# Copyright 1999-2020 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=7
-
-inherit eutils multilib qmake-utils autotools git-r3 desktop cmake-multilib
-
-DESCRIPTION="A Qt-based program for syncing your MEGA account in your PC. This is the official app."
-HOMEPAGE="http://mega.co.nz"
-RTAG="_Linux"
-if [[ ${PV} == *9999* ]];then
- EGIT_REPO_URI="https://github.com/meganz/MEGAsync"
- KEYWORDS=""
- EGIT_SUBMODULES=( '*' )
-else
- EGIT_REPO_URI="https://github.com/meganz/MEGAsync"
- EGIT_COMMIT="v${PV}.0${RTAG}"
- EGIT_SUBMODULES=( '*' )
- KEYWORDS="~x86 ~amd64"
-fi
-
-LICENSE="MEGA"
-SLOT="0"
-IUSE="dolphin nautilus thunar +cryptopp +sqlite +zlib +curl freeimage readline examples threads qt5 java php python gnome"
-
-DEPEND="
- dev-lang/swig
- app-doc/doxygen
- media-libs/libmediainfo
- media-libs/libraw
- !qt5? (
- dev-qt/qtcore:4
- dev-qt/qtgui:4
- dev-qt/qtdbus:4
- dev-libs/sni-qt
- dev-qt/qtimageformats:5
- dev-qt/qtsvg:5
- )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/linguist-tools
- dev-qt/qtwidgets:5
- dev-qt/qtgui:5
- dev-qt/qtconcurrent:5
- dev-qt/qtnetwork:5
- dev-qt/qtdbus:5
- dev-qt/qtimageformats:5
- dev-qt/qtsvg:5
- )"
-RDEPEND="${DEPEND}
- x11-themes/hicolor-icon-theme
- dev-libs/openssl
- dev-libs/libgcrypt
- media-libs/libpng
- net-dns/c-ares
- cryptopp? ( dev-libs/crypto++ )
- app-arch/xz-utils
- dev-libs/libuv
- sqlite? ( dev-db/sqlite:3 )
- dev-libs/libsodium
- zlib? ( sys-libs/zlib )
- curl? ( net-misc/curl[ssl,curl_ssl_openssl] )
- freeimage? ( media-libs/freeimage )
- readline? ( sys-libs/readline:0 )
- dolphin? ( kde-apps/dolphin )
- nautilus? ( >=gnome-base/nautilus-3 )
- thunar? ( xfce-base/thunar )
- "
-
-PATCHES=( )
-
-if [[ ${PV} != *9999* ]];then
- src_prepare(){
- if [ -e "${FILESDIR}/MEGAsync-${PV}.0_Linux.patch" ]; then
- EPATCH_OPTS="-p0" epatch "${FILESDIR}/MEGAsync-${PV}.0_Linux.patch"
- fi
- if [ ! -z ${PATCHES} ]; then
- epatch ${PATCHES}
- fi
- if use gnome; then
- if [ -e "${FILESDIR}${P}-gnome.patch" ]; then
- epatch "${FILESDIR}/${P}-gnome.patch"
- fi
- fi
- eapply_user
- cd src/MEGASync/mega
- eautoreconf
- }
-fi
-
-src_configure(){
- cd "${S}"/src/MEGASync/mega
- econf \
- "--disable-silent-rules" \
- "--disable-curl-checks" \
- "--disable-megaapi" \
- $(use_with zlib) \
- $(use_with sqlite) \
- $(use_with cryptopp) \
- "--with-cares" \
- $(use_with curl) \
- "--without-termcap" \
- $(use_enable threads posix-threads) \
- "--with-sodium" \
- $(use_with freeimage) \
- $(use_with readline) \
- $(use_enable examples) \
- $(use_enable java) \
- $(use_enable php) \
- $(use_enable python) \
- "--enable-chat" \
- "--enable-gcc-hardening"
- cd ../..
- local myeqmakeargs=(
- MEGA.pro
- CONFIG+="release"
- )
- if use qt5; then
- eqmake5 ${myeqmakeargs[@]}
- use dolphin && cmake-utils_src_configure
- $(qt5_get_bindir)/lrelease MEGASync/MEGASync.pro
- else
- eqmake4 ${myeqmakeargs[@]}
- use dolphin && cmake-utils_src_configure
- $(qt4_get_bindir)/lrelease MEGASync/MEGASync.pro
- fi
-}
-
-src_compile(){
- emake -C src INSTALL_ROOT="${D}" || die
- use dolphin && cmake-utils_src_compile
-}
-
-src_install(){
- use dolphin && cmake-utils_src_install
- local DOCS=( CREDITS.md README.md )
- einstalldocs
- insinto usr/share/licenses/${PN}
- doins LICENCE.md installer/terms.txt
- cd src/MEGASync
- dobin ${PN}
- cd platform/linux/data
- insinto usr/share/applications
- doins ${PN}.desktop
- cd icons/hicolor
- for size in 16x16 32x32 48x48 128x128 256x256;do
- doicon -s $size $size/apps/mega.png
- done
-}
diff --git a/net-misc/megasync/megasync-4.3.3.ebuild b/net-misc/megasync/megasync-4.3.7.0.ebuild
index aa7d2f2..5890701 100644
--- a/net-misc/megasync/megasync-4.3.3.ebuild
+++ b/net-misc/megasync/megasync-4.3.7.0.ebuild
@@ -4,83 +4,86 @@
EAPI=7
-inherit eutils multilib qmake-utils autotools git-r3 desktop cmake-multilib
+inherit autotools desktop qmake-utils xdg cmake git-r3
-DESCRIPTION="A Qt-based program for syncing your MEGA account in your PC. This is the official app."
+DESCRIPTION="The official Qt-based program for syncing your MEGA account in your PC"
HOMEPAGE="http://mega.co.nz"
RTAG="_Linux"
-if [[ ${PV} == *9999* ]];then
- EGIT_REPO_URI="https://github.com/meganz/MEGAsync"
- KEYWORDS=""
- EGIT_SUBMODULES=( '*' )
-else
- EGIT_REPO_URI="https://github.com/meganz/MEGAsync"
- EGIT_COMMIT="v${PV}.0${RTAG}"
- EGIT_SUBMODULES=( '*' )
- KEYWORDS="~x86 ~amd64"
-fi
+EGIT_REPO_URI="https://github.com/meganz/MEGAsync"
+EGIT_COMMIT="v${PV}${RTAG}"
+EGIT_SUBMODULES=( '*' )
+KEYWORDS="~x86 ~amd64"
LICENSE="MEGA"
SLOT="0"
-IUSE="dolphin nautilus thunar +cryptopp +sqlite +zlib +curl freeimage readline examples threads java php python gnome"
+IUSE="+cryptopp +curl +sqlite +zlib dolphin examples freeimage java libressl nautilus php python readline threads thunar"
+RDEPEND="
+ app-arch/xz-utils
+ dev-libs/libgcrypt
+ dev-libs/libsodium
+ dev-libs/libuv
+ media-libs/libpng
+ net-dns/c-ares
+ x11-themes/hicolor-icon-theme
+ cryptopp? ( dev-libs/crypto++ )
+ curl? (
+ !libressl? ( net-misc/curl[ssl,curl_ssl_openssl] )
+ libressl? ( net-misc/curl[ssl,curl_ssl_libressl] )
+ )
+ dolphin? ( kde-apps/dolphin )
+ freeimage? ( media-libs/freeimage )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ nautilus? ( >=gnome-base/nautilus-3 )
+ readline? ( sys-libs/readline:0 )
+ sqlite? ( dev-db/sqlite:3 )
+ thunar? ( xfce-base/thunar )
+ zlib? ( sys-libs/zlib )
+"
DEPEND="
- dev-lang/swig
- app-doc/doxygen
+ ${RDEPEND}
media-libs/libmediainfo
media-libs/libraw
dev-qt/qtcore:5
- dev-qt/linguist-tools
dev-qt/qtwidgets:5
dev-qt/qtgui:5
dev-qt/qtconcurrent:5
dev-qt/qtnetwork:5
dev-qt/qtdbus:5
dev-qt/qtimageformats:5
- dev-qt/qtsvg:5"
-RDEPEND="${DEPEND}
- x11-themes/hicolor-icon-theme
- dev-libs/openssl
- dev-libs/libgcrypt
- media-libs/libpng
- net-dns/c-ares
- cryptopp? ( dev-libs/crypto++ )
- app-arch/xz-utils
- dev-libs/libuv
- sqlite? ( dev-db/sqlite:3 )
- dev-libs/libsodium
- zlib? ( sys-libs/zlib )
- curl? ( net-misc/curl[ssl,curl_ssl_openssl] )
- freeimage? ( media-libs/freeimage )
- readline? ( sys-libs/readline:0 )
- dolphin? ( kde-apps/dolphin )
- nautilus? ( >=gnome-base/nautilus-3 )
- thunar? ( xfce-base/thunar )
- "
+ dev-qt/qtsvg:5
+"
+BDEPEND="
+ dev-lang/swig
+ dev-qt/linguist-tools
+"
+
+DOCS=( CREDITS.md README.md )
PATCHES=( )
-if [[ ${PV} != *9999* ]];then
- src_prepare(){
- if [ -e "${FILESDIR}/MEGAsync-${PV}.0_Linux.patch" ]; then
- EPATCH_OPTS="-p0" epatch "${FILESDIR}/MEGAsync-${PV}.0_Linux.patch"
- fi
- if [ ! -z ${PATCHES} ]; then
- epatch ${PATCHES}
- fi
- if use gnome; then
- if [ -e "${FILESDIR}${P}-gnome.patch" ]; then
- epatch "${FILESDIR}/${P}-gnome.patch"
- fi
- fi
- eapply_user
- cd src/MEGASync/mega
- eautoreconf
- }
-fi
+CMAKE_USE_DIR="${S}/src/MEGAShellExtDolphin"
-src_configure(){
- cd "${S}"/src/MEGASync/mega
+src_prepare() {
+ if [ -e "${FILESDIR}/MEGAsync-${PV}.0_Linux.patch" ]; then
+ EPATCH_OPTS="-p0" epatch "${FILESDIR}/MEGAsync-${PV}.0_Linux.patch"
+ fi
+ if [ ! -z ${PATCHES} ]; then
+ epatch ${PATCHES}
+ fi
+ if use dolphin; then
+ # use the kde5 CMakeLists instead of the kde 4 version
+ mv src/MEGAShellExtDolphin/CMakeLists_kde5.txt src/MEGAShellExtDolphin/CMakeLists.txt || die
+ cmake_src_prepare
+ fi
+ eapply_user
+ cd src/MEGASync/mega
+ eautoreconf
+}
+
+src_configure() {
+ cd src/MEGASync/mega
econf \
"--disable-silent-rules" \
"--disable-curl-checks" \
@@ -100,35 +103,36 @@ src_configure(){
$(use_enable php) \
$(use_enable python) \
"--enable-chat" \
- "--enable-gcc-hardening"
+ "--enable-gcc-hardening"
cd ../..
+
local myeqmakeargs=(
MEGA.pro
CONFIG+="release"
)
+
eqmake5 ${myeqmakeargs[@]}
- use dolphin && cmake-utils_src_configure
+ use dolphin && cmake_src_configure
$(qt5_get_bindir)/lrelease MEGASync/MEGASync.pro
}
-src_compile(){
+src_compile() {
emake -C src INSTALL_ROOT="${D}" || die
- use dolphin && cmake-utils_src_compile
+ use dolphin && cmake_src_compile
}
-src_install(){
- use dolphin && cmake-utils_src_install
+src_install() {
local DOCS=( CREDITS.md README.md )
+ use dolphin && cmake_src_install
einstalldocs
+ dobin src/MEGASync/${PN}
insinto usr/share/licenses/${PN}
doins LICENCE.md installer/terms.txt
- cd src/MEGASync
- dobin ${PN}
- cd platform/linux/data
- insinto usr/share/applications
- doins ${PN}.desktop
- cd icons/hicolor
+ dobin src/MEGASync/${PN}
+ domenu src/MEGASync/platform/linux/data/${PN}.desktop
+ cd src/MEGASync/platform/linux/data/icons/hicolor
for size in 16x16 32x32 48x48 128x128 256x256;do
doicon -s $size $size/apps/mega.png
done
}
+
diff --git a/net-misc/megasync/megasync-9999.ebuild b/net-misc/megasync/megasync-9999.ebuild
index 464f33c..8029bd4 120000..100644
--- a/net-misc/megasync/megasync-9999.ebuild
+++ b/net-misc/megasync/megasync-9999.ebuild
@@ -1 +1,119 @@
-megasync-4.3.3.ebuild \ No newline at end of file
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop qmake-utils xdg cmake git-r3
+
+DESCRIPTION="The official Qt-based program for syncing your MEGA account in your PC"
+HOMEPAGE="http://mega.co.nz"
+
+EGIT_REPO_URI="https://github.com/meganz/MEGAsync"
+KEYWORDS=""
+EGIT_SUBMODULES=( '*' )
+
+LICENSE="MEGA"
+SLOT="0"
+IUSE="+cryptopp +curl +sqlite +zlib dolphin examples freeimage java libressl nautilus php python readline threads thunar"
+
+RDEPEND="
+ app-arch/xz-utils
+ dev-libs/libgcrypt
+ dev-libs/libsodium
+ dev-libs/libuv
+ media-libs/libpng
+ net-dns/c-ares
+ x11-themes/hicolor-icon-theme
+ cryptopp? ( dev-libs/crypto++ )
+ curl? (
+ !libressl? ( net-misc/curl[ssl,curl_ssl_openssl] )
+ libressl? ( net-misc/curl[ssl,curl_ssl_libressl] )
+ )
+ dolphin? ( kde-apps/dolphin )
+ freeimage? ( media-libs/freeimage )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ nautilus? ( >=gnome-base/nautilus-3 )
+ readline? ( sys-libs/readline:0 )
+ sqlite? ( dev-db/sqlite:3 )
+ thunar? ( xfce-base/thunar )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="
+ ${RDEPEND}
+ media-libs/libmediainfo
+ media-libs/libraw
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtgui:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtdbus:5
+ dev-qt/qtimageformats:5
+ dev-qt/qtsvg:5
+"
+BDEPEND="
+ app-doc/doxygen
+ dev-lang/swig
+ dev-qt/linguist-tools
+"
+
+DOCS=( CREDITS.md README.md )
+
+src_prepare() {
+ default
+ cd src/MEGASync/mega
+ eautoreconf
+}
+
+src_configure() {
+ cd src/MEGASync/mega
+ econf \
+ "--disable-silent-rules" \
+ "--disable-curl-checks" \
+ "--disable-megaapi" \
+ $(use_with zlib) \
+ $(use_with sqlite) \
+ $(use_with cryptopp) \
+ "--with-cares" \
+ $(use_with curl) \
+ "--without-termcap" \
+ $(use_enable threads posix-threads) \
+ "--with-sodium" \
+ $(use_with freeimage) \
+ $(use_with readline) \
+ $(use_enable examples) \
+ $(use_enable java) \
+ $(use_enable php) \
+ $(use_enable python) \
+ "--enable-chat" \
+ "--enable-gcc-hardening"
+ cd ../..
+
+ local myeqmakeargs=(
+ MEGA.pro
+ CONFIG+="release"
+ )
+
+ eqmake5 ${myeqmakeargs[@]}
+ use dolphin && cmake_src_configure
+ $(qt5_get_bindir)/lrelease MEGASync/MEGASync.pro
+}
+
+src_compile() {
+ emake -C src INSTALL_ROOT="${D}" || die
+ use dolphin && cmake_src_compile
+}
+
+src_install() {
+ use dolphin && cmake_src_install
+ einstalldocs
+ dobin src/MEGASync/${PN}
+ insinto usr/share/licenses/${PN}
+ doins LICENCE.md installer/terms.txt
+ domenu src/MEGASync/platform/linux/data/${PN}.desktop
+ cd src/MEGASync/platform/linux/data/icons/hicolor
+ for size in 16x16 32x32 48x48 128x128 256x256;do
+ doicon -s $size $size/apps/mega.png
+ done
+}