summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Miess <Philip_Miess@yahoo.com>2020-04-11 23:52:03 -0400
committerPhilip Miess <Philip_Miess@yahoo.com>2020-04-11 23:52:03 -0400
commitbfacd72d64a83bcad0607d65eafc1265bf142a47 (patch)
treec94dca839b7016702c85fcdaca2daf85028a58f5 /sys-apps
parent0install 2.3.9 (diff)
downloadsuperposition-bfacd72d64a83bcad0607d65eafc1265bf142a47.tar.gz
superposition-bfacd72d64a83bcad0607d65eafc1265bf142a47.tar.bz2
superposition-bfacd72d64a83bcad0607d65eafc1265bf142a47.zip
0install 2.3.9 on python 3.7
Signed-off-by: Philip Miess <Philip_Miess@yahoo.com>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/0install/0install-2.3.9.ebuild7
-rw-r--r--sys-apps/0install/Manifest2
2 files changed, 7 insertions, 2 deletions
diff --git a/sys-apps/0install/0install-2.3.9.ebuild b/sys-apps/0install/0install-2.3.9.ebuild
index 0155ffe..3cdfe4b 100644
--- a/sys-apps/0install/0install-2.3.9.ebuild
+++ b/sys-apps/0install/0install-2.3.9.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7} )
PYTHON_REQ_USE="xml(+)"
inherit xdg-utils distutils-r1
@@ -29,6 +29,11 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
+python_prepare(){
+[[ ${EPYTHON} == python3_6 ]] && continue
+ sed -i 's:def async:def aasync:' zeroinstall/support/async_compat.py || die 'async name sed failed.'
+}
+
python_install_all() {
distutils-r1_python_install_all
diff --git a/sys-apps/0install/Manifest b/sys-apps/0install/Manifest
index 55a5b7f..ed52bf8 100644
--- a/sys-apps/0install/Manifest
+++ b/sys-apps/0install/Manifest
@@ -13,5 +13,5 @@ EBUILD 0install-2.13.ebuild 1221 BLAKE2B 6c5774b05b554c0248f106b4afa620693390eff
EBUILD 0install-2.3.5.ebuild 1222 BLAKE2B 24983c13fa184c252f76e21f3255ccc56b8a4ab7b08b4c768976f711583bc800357be8ede1dd683594e0ab2f6adf85f3544be3b0214a60c424f949b4b22b1dbd SHA512 f9b5e8e99608689bb58485cd22f9ac0b7f81e51af8b8d06dc7b78fe55350df3fa3cb12d3c16090a5d45a3c18df4aea15b47a07854c36170c9941bad448e9c6f2
EBUILD 0install-2.3.6.ebuild 1313 BLAKE2B 7b9baf86d3e3a8e8e9623b2959262b4a99df29db3daf0762f3f709c3618a97321b6f6825e12b2faa03cf45126119f432ba844ee0414804dead24c3e2b1368429 SHA512 5561db02c40584260d5181bf50f397baba5be95f53d6a56fec8182b1b6bbf34bb56c276eb26741cce272a96cafdbb39e10b022df75e064f90c5c0fd4fe531793
EBUILD 0install-2.3.7.ebuild 1342 BLAKE2B 771c636be15b63bbfa387b055aac94072ed678e44bb7c224914c608713b48b4755abaa26a37792dce92678a20fde73df8580e2cb9fe9489fc8d9a2cbaed013f5 SHA512 e57aa4ff45ea0ac150547238a583c49ec326382e8ab2d969edfbe8249b52ecee8b61c27428a6400dbb3f94ded0ffabc5fff97e94c69cf6454ba929f18ad18fc9
-EBUILD 0install-2.3.9.ebuild 1196 BLAKE2B 157216fcbdd28d614abf07d7699823640b3a039a576834f5cadc57cf302fa4624001c04f42a249978fa3d55430afa0974ada4c0e33db84d809e6eee67bcaa815 SHA512 9bcf5dab3afc7e680bfbce9ba5411458e0cd5e3827c1736c7172774f1ae2330d38a621e5f0d03856a5a2789dc81b4c095f8fe894e5a86c74d851c0ddb9b0c303
+EBUILD 0install-2.3.9.ebuild 1365 BLAKE2B c39938fb5c514f507f10415ccdc0d718a9e8b743a18c23b983eb2e9e7a0aab25cac69046aedeaae8ce824aa1fe347363752e635547f7164e20a1b29c349dc95c SHA512 09b081fc8c5b73975605d3244f214932507e6b6127ab58088c9185ef9ba282d7061e8f03448e7043573b5902f9084b274fac20c4e86a2f40d47bf81f3c8cc685
MISC metadata.xml 285 BLAKE2B 7665ca7b22bf0c8b2e486a5633130588ea83952d863912d0e8299707ed6d26dd66e40e1faa53173eb24079d4607cb783c9e0f6dce8f298607e5baf1ec5f1e587 SHA512 a8207edb781bc25e9bdc7f074ae3164ea9037077c6f6e0284474d033d57ceb188c3e1e9a77a0bbc9c7cac538a75ba23c42993340bd6555b0a71085d43c3f905d