summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2012-06-29 16:29:35 -0400
committerElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2012-06-29 16:29:35 -0400
commitdc12b93d45e8fad1957742722e1ab3b7a0b9ba97 (patch)
tree4b68bc0f4880001b2fa88c32041c84d40d50893e
parentFixed shebangs for flowblade binary... (diff)
downloadArmageddon-dc12b93d45e8fad1957742722e1ab3b7a0b9ba97.tar.gz
Armageddon-dc12b93d45e8fad1957742722e1ab3b7a0b9ba97.tar.bz2
Armageddon-dc12b93d45e8fad1957742722e1ab3b7a0b9ba97.zip
udevil version bump for the new release 0.2.9
-rw-r--r--sys-apps/udevil/Manifest2
-rw-r--r--sys-apps/udevil/files/udevil-0.2.9-flags.patch61
-rw-r--r--sys-apps/udevil/udevil-0.2.9.ebuild68
3 files changed, 130 insertions, 1 deletions
diff --git a/sys-apps/udevil/Manifest b/sys-apps/udevil/Manifest
index 8b57228..87a667b 100644
--- a/sys-apps/udevil/Manifest
+++ b/sys-apps/udevil/Manifest
@@ -1,2 +1,2 @@
-DIST udevil-0.2.7.tar.xz 278428 RMD160 0add9a60f4838a14105cb89804342b97b79bd716 SHA1 748943d70b471fb360e31e98cba716e221e81655 SHA256 bb0044b0cba4e89f5b61e2bb09ef0bac82a5e03bcd77b23545b30d8a1713cb59
DIST udevil-0.2.8.tar.xz 278748 RMD160 9eb83f04b8aea2d21572520b5194cd4a52f1bf58 SHA1 ebefd08fb000756c9b56408396891f52b7d828e2 SHA256 3ffdd11283772f4a66c8ac928cf5e03072a1497ae70c9a131ec06d1dae9297cb
+DIST udevil-0.2.9.tar.xz 278988 RMD160 9eb1c155dad34dae4ef2d5f9a02599f128f58fd9 SHA1 f02d6dc98e60b632fe221dc048e2b3d11dca79a5 SHA256 224f10b20726fd544cade37284533fba2daa268073bdfaccbf53632f44b2ffdd
diff --git a/sys-apps/udevil/files/udevil-0.2.9-flags.patch b/sys-apps/udevil/files/udevil-0.2.9-flags.patch
new file mode 100644
index 0000000..dc7d09c
--- /dev/null
+++ b/sys-apps/udevil/files/udevil-0.2.9-flags.patch
@@ -0,0 +1,61 @@
+From: Elijah El Lazkani <ThyArmageddon+Gentoo@Gmail.com>
+Date: Wed Jun 13 22:45:09 UTC 2012
+Subject: Removing explicit LDFLAGS and CPPFLAGS
+
+--- configure.ac
++++ configure.ac
+@@ -16,42 +16,6 @@
+ AC_DEFINE_UNQUOTED(UDEVIL_VERSION, "$VERSION", [udevil version])
+
+
+-dnl linker optimizations
+-AC_MSG_CHECKING([whether $LD accepts --as-needed])
+-case `$LD --as-needed -v 2>&1 </dev/null` in
+-*GNU* | *'with BFD'*)
+- LDFLAGS="$LDFLAGS -Wl,--as-needed"
+- AC_MSG_RESULT([yes])
+- ;;
+-*)
+- AC_MSG_RESULT([no])
+- ;;
+-esac
+-AC_MSG_CHECKING([whether $LD accepts -O1])
+-case `$LD -O1 -v 2>&1 </dev/null` in
+-*GNU* | *'with BFD'*)
+- LDFLAGS="$LDFLAGS -Wl,-O1"
+- AC_MSG_RESULT([yes])
+- ;;
+-*)
+- AC_MSG_RESULT([no])
+- ;;
+-esac
+-AC_MSG_CHECKING([whether $LD accepts -Bsymbolic-functions])
+-case `$LD -Bsymbolic-functions -v 2>&1 </dev/null` in
+-*GNU* | *'with BFD'*)
+- LDFLAGS="$LDFLAGS -Wl,-Bsymbolic-functions"
+- AC_MSG_RESULT([yes])
+- ;;
+-*)
+- AC_MSG_RESULT([no])
+- ;;
+-esac
+-
+-dnl advanced compiler tweaking
+-CPPFLAGS="$CPPFLAGS -fstrict-aliasing -fmessage-length=0"
+-
+-
+ # program paths
+ AC_ARG_WITH(mount-prog,
+ AC_HELP_STRING([--with-mount-prog=PATH], [Path to mount program (default: /bin/mount)]),
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -16,8 +16,7 @@
+
+ udevil_CFLAGS = \
+ @GLIB_CFLAGS@ \
+- @LIBUDEV_CFLAGS@ \
+- -Werror-implicit-function-declaration
++ @LIBUDEV_CFLAGS@
+
+ udevil_LDADD = \
+ $(INTLLIBS) \
diff --git a/sys-apps/udevil/udevil-0.2.9.ebuild b/sys-apps/udevil/udevil-0.2.9.ebuild
new file mode 100644
index 0000000..cfb6277
--- /dev/null
+++ b/sys-apps/udevil/udevil-0.2.9.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/udevil/udevil-0.2.8.ebuild,v 1.2 2012/06/17 17:16:26 hasufell Exp $
+
+EAPI=4
+
+inherit eutils autotools user
+
+DESCRIPTION="mount and unmount removable devices without a password"
+HOMEPAGE="http://ignorantguru.github.com/udevil/"
+SRC_URI="https://github.com/IgnorantGuru/${PN}/raw/master/packages/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-shells/bash-4.0
+ sys-apps/util-linux
+ >=sys-fs/udev-143
+ virtual/acl"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup(){
+ enewgroup plugdev
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-flags.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-setfacl-prog="$(type -P setfacl)"
+}
+
+src_install() {
+ default
+ fowners root:plugdev /usr/bin/udevil
+ fperms 4754 /usr/bin/udevil
+}
+
+pkg_postinst() {
+ einfo
+ elog "Please add your user to the plugdev group"
+ elog "to be able to use ${PN} as a user"
+ elog
+ elog "Optional dependencies:"
+ elog " gnome-extra/zenity (devmon popups)"
+ elog " net-fs/cifs-utils (mounting samba shares)"
+ elog " net-fs/curlftpfs (mounting ftp shares)"
+ elog " net-fs/nfs-utils (mounting nfs shares)"
+ elog " sys-fs/sshfs-fuse (mounting sftp shares)"
+ elog " virtual/eject (eject via devmon)"
+ if ! has_version 'sys-fs/udisks' ; then
+ elog
+ elog "When using ${PN} without udisks, and without the udisks-daemon running,"
+ elog "you may need to enable kernel polling for device media changes to be detected."
+ elog "See http://ignorantguru.github.com/${PN}/#polling"
+ has_version '<sys-fs/udev-173' && ewarn "You need at least udev-173"
+ kernel_is lt 2 6 38 && ewarn "You need at least kernel 2.6.38"
+ einfo
+ fi
+}