summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/tiled/tiled-1.9.2.ebuild')
-rw-r--r--dev-games/tiled/tiled-1.9.2.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/dev-games/tiled/tiled-1.9.2.ebuild b/dev-games/tiled/tiled-1.9.2.ebuild
new file mode 100644
index 0000000..4c2cfd5
--- /dev/null
+++ b/dev-games/tiled/tiled-1.9.2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit python-single-r1 qmake-utils xdg-utils
+
+DESCRIPTION="A general purpose tile map editor"
+HOMEPAGE="https://www.mapeditor.org/"
+SRC_URI="https://github.com/bjorn/tiled/archive/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ app-arch/zstd:=
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtdbus-5.15:5
+ >=dev-qt/qtdeclarative-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtnetwork-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ sys-libs/zlib
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+ dev-util/qbs
+"
+
+DOCS=( AUTHORS COPYING NEWS.md README.md )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+ # Create a Qt5 profile for Qbs
+ qbs setup-qt "$(qt5_get_bindir)/qmake" qt5
+}
+
+src_configure() {
+ # Setup toolchains
+ qbs setup-toolchains --detect
+ # The installdir is appended to installPrefix
+ qbs build profile:qt5 \
+ qbs.installPrefix:"/usr" \
+ qbs.installDir:"$(get_libdir)" \
+ qbs.install:true
+ #SYSTEM_ZSTD="yes" \
+ #DISABLE_PYTHON_PLUGIN="$(usex !python)" \
+ #USE_FHS_PLUGIN_PATH="true"
+}
+
+src_install() {
+ #emake INSTALL_ROOT="${D}" install
+ qbs install --install-root="${D}" profile:qt5
+
+ einstalldocs
+
+ if use examples ; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}