summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorandy <andy@mailbox.tu-berlin.de>2012-06-25 22:50:13 +0200
committerandy <andy@mailbox.tu-berlin.de>2012-06-25 22:50:13 +0200
commit6b3c93661f73be9448984f09ce5631fa81d0503c (patch)
treece523eb49c983e9206db3fbfc7c769922ff0e382
parentebuild sanity fixes (diff)
downloadandy-6b3c93661f73be9448984f09ce5631fa81d0503c.tar.gz
andy-6b3c93661f73be9448984f09ce5631fa81d0503c.tar.bz2
andy-6b3c93661f73be9448984f09ce5631fa81d0503c.zip
Added mimeo to user overlay
-rw-r--r--x11-misc/mimeo/Manifest2
-rw-r--r--x11-misc/mimeo/mimeo-2012.6.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/x11-misc/mimeo/Manifest b/x11-misc/mimeo/Manifest
new file mode 100644
index 0000000..4debf39
--- /dev/null
+++ b/x11-misc/mimeo/Manifest
@@ -0,0 +1,2 @@
+DIST mimeo-2012.6.tar.xz 33272 RMD160 b55ccfa295bb70cc010911a045c5295c5c421ef1 SHA1 dd9f4081cab596797e11009d51e153a7502d9c5e SHA256 62d4625806dcc7e4831641420df5795915e92458b24d2216d0a4c9c022ea0bfa
+EBUILD mimeo-2012.6.ebuild 570 RMD160 a826eaa3d507cb075bd1188f551f0b53f4844659 SHA1 0a6f2c0f6db2a70b87a28af6c0f103676782602a SHA256 5c118f064a7ded646a7645dacbdb55464250a492dfdd658a323514d4a51e0408
diff --git a/x11-misc/mimeo/mimeo-2012.6.ebuild b/x11-misc/mimeo/mimeo-2012.6.ebuild
new file mode 100644
index 0000000..d7236f3
--- /dev/null
+++ b/x11-misc/mimeo/mimeo-2012.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+PYTHON_DEPEND="2"
+
+inherit distutils python
+
+DESCRIPTION="Open files using MIME-type associations."
+HOMEPAGE="http://xyne.archlinux.ca/projects/mimeo"
+SRC_URI="http://xyne.archlinux.ca/projects/mimeo/archives/${P}.tar.xz"
+
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="sys-apps/file"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_install() {
+ python_convert_shebangs -r 2 .
+ distutils_src_install
+
+ dobin mimeo
+}