summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/ktikz/ktikz-9999.ebuild')
-rw-r--r--media-gfx/ktikz/ktikz-9999.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/media-gfx/ktikz/ktikz-9999.ebuild b/media-gfx/ktikz/ktikz-9999.ebuild
index feae9f3..60ad228 100644
--- a/media-gfx/ktikz/ktikz-9999.ebuild
+++ b/media-gfx/ktikz/ktikz-9999.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils cmake-utils qmake-utils git-r3
+inherit eutils cmake-utils qmake-utils git-r3 xdg
DESCRIPTION="A QT5-based editor for the TikZ language"
HOMEPAGE="http://www.hackenberger.at/blog/ktikz-editor-for-the-tikz-language"
LICENSE="GPL-2"
SLOT="5"
KEYWORDS=""
-IUSE="kde +doc -debug"
+IUSE="kde -ktexteditor +doc -debug"
-EGIT_REPO_URI="https://github.com/fhackenberger/ktikz.git"
+EGIT_REPO_URI="https://github.com/jfmcarreira/ktikz.git"
DEPEND="
dev-qt/qtcore:5
@@ -45,6 +45,9 @@ src_prepare() {
src_configure() {
if use kde; then
+ local mycmakeargs=(
+ -DKTIKZ_USE_KTEXTEDITOR=$(usex ktexteditor)
+ )
cmake-utils_src_configure
else
KDECONFIG="CONFIG-=usekde"