aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/spidermonkey/spidermonkey-1.8.7-r4.ebuild')
-rw-r--r--dev-lang/spidermonkey/spidermonkey-1.8.7-r4.ebuild176
1 files changed, 0 insertions, 176 deletions
diff --git a/dev-lang/spidermonkey/spidermonkey-1.8.7-r4.ebuild b/dev-lang/spidermonkey/spidermonkey-1.8.7-r4.ebuild
deleted file mode 100644
index e3768b9..0000000
--- a/dev-lang/spidermonkey/spidermonkey-1.8.7-r4.ebuild
+++ /dev/null
@@ -1,176 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="5"
-WANT_AUTOCONF="2.1"
-PYTHON_COMPAT=( python2_{6,7} )
-PYTHON_REQ_USE="threads"
-inherit autotools-multilib autotools eutils toolchain-funcs multilib python-any-r1 versionator pax-utils
-
-MY_PN="js"
-TARBALL_PV="$(replace_all_version_separators '' $(get_version_component_range 1-3))"
-MY_P="${MY_PN}-${PV}"
-TARBALL_P="${MY_PN}${TARBALL_PV}-1.0.0"
-SPIDERPV="${PV}-patches-0.1"
-DESCRIPTION="Stand-alone JavaScript C library"
-HOMEPAGE="http://www.mozilla.org/js/spidermonkey/"
-SRC_URI="http://people.mozilla.com/~dmandelin/${TARBALL_P}.tar.gz
- http://dev.gentoo.org/~anarchy/mozilla/patchsets/spidermonkey-${SPIDERPV}.tar.xz"
-
-LICENSE="NPL-1.1"
-SLOT="0/mozjs187"
-KEYWORDS="~amd64"
-IUSE="debug jit minimal static-libs test"
-
-S="${WORKDIR}/${MY_P}"
-BUILDDIR="${S}/js/src"
-
-RDEPEND=">=dev-libs/nspr-4.7.0[${MULTILIB_USEDEP}]
- virtual/libffi[${MULTILIB_USEDEP}]"
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- app-arch/zip
- virtual/pkgconfig"
-
-MULTILIB_PARALLEL_PHASES="src_configure src_compile src_test"
-MULTILIB_WRAPPED_EXECUTABLES="@/usr/bin/js-config"
-MULTILIB_WRAPPED_HEADERS=(
- /usr/include/js/js-config.h
- /usr/include/js/NativeX64.h
-)
-
-abi_builddir() {
- echo "${BUILD_DIR}"/js/src
-}
-
-pkg_setup(){
- if [[ ${MERGE_TYPE} != "binary" ]]; then
- export LC_ALL="C"
- fi
-}
-
-ehook autotools-multilib-global-pre_src_prepare pre_prepare
-pre_prepare() {
- # Apply patches that are required for misc archs
- EPATCH_SUFFIX="patch" \
- EPATCH_FORCE="yes" \
- epatch "${WORKDIR}/spidermonkey"
-
- epatch "${FILESDIR}"/${PN}-1.8.5-fix-install-symlinks.patch
- epatch "${FILESDIR}"/${PN}-1.8.7-filter_desc.patch
- epatch "${FILESDIR}"/${PN}-1.8.7-freebsd-pthreads.patch
- epatch "${FILESDIR}"/${PN}-1.8.7-x32.patch
- # https://bugs.gentoo.org/show_bug.cgi?id=439260
- epatch "${FILESDIR}"/${P}-symbol-versions.patch
-
- epatch_user
-
- cd "${BUILDDIR}" || die
- eautoconf
- return 1
-}
-
-ehook autotools-multilib-global-pre_src_configure pre_configure
-pre_configure() {
- ECONF_SOURCE="${BUILDDIR}"
- myeconfargs=(
- ${myopts}
- --enable-jemalloc
- --enable-readline
- --enable-threadsafe
- --enable-system-ffi
- --enable-jemalloc
- $(use_enable debug)
- $(use_enable jit tracejit)
- $(use_enable jit methodjit)
- $(use_enable static-libs static)
- $(use_enable test tests)
- )
-}
-
-ehook autotools-multilib-per-abi-pre_src_configure pre_abi_configure
-pre_abi_configure() {
- mkdir -p "$(abi_builddir)"
- cd "$(abi_builddir)" || die
- if multilib_is_native_abi ; then
- myeconfargs+=(--with-system-nspr)
- else
- myeconfargs+=(
- --with-nspr-cflags="$(nspr-config-${ABI} --cflags)"
- --with-nspr-libs="$(nspr-config-${ABI} --libs)"
- --with-nspr-prefix="$(nspr-config-${ABI} --prefix)"
- --with-nspr-exec-prefix="$(nspr-config-${ABI} --exec-prefix)"
- )
- fi
- MULTILIB_TC_EXPORT_VARS="CC CXX AR RANLIB LD" multilib_tc_export \
- econf "${myeconfargs[@]}" "${othereconfargs[@]}"
- return 1
-}
-
-ehook autotools-multilib-per-abi-pre_src_compile pre_abi_compile
-pre_abi_compile() {
- cd "$(abi_builddir)" || die
- if tc-is-cross-compiler; then
- make CFLAGS="" CXXFLAGS="" \
- CC=$(tc-getBUILD_CC) CXX=$(tc-getBUILD_CXX) \
- AR=$(tc-getBUILD_AR) RANLIB=$(tc-getBUILD_RANLIB) \
- jscpucfg host_jsoplengen host_jskwgen || die
- make CFLAGS="" CXXFLAGS="" \
- CC=$(tc-getBUILD_CC) CXX=$(tc-getBUILD_CXX) \
- AR=$(tc-getBUILD_AR) RANLIB=$(tc-getBUILD_RANLIB) \
- -C config nsinstall || die
- mv {,native-}jscpucfg || die
- mv {,native-}host_jskwgen || die
- mv {,native-}host_jsoplengen || die
- mv config/{,native-}nsinstall || die
- sed -e 's@./jscpucfg@./native-jscpucfg@' \
- -e 's@./host_jskwgen@./native-host_jskwgen@' \
- -e 's@./host_jsoplengen@./native-host_jsoplengen@' \
- -i Makefile || die
- sed -e 's@/nsinstall@/native-nsinstall@' -i config/config.mk || die
- rm -f config/host_nsinstall.o \
- config/host_pathsub.o \
- host_jskwgen.o \
- host_jsoplengen.o || die
- fi
-}
-
-ehook autotools-multilib-per-abi-pre_src_test pre_abi_test
-pre_abi_test() {
- cd "$(abi_builddir)/jsapi-tests" || die
-}
-
-ehook autotools-multilib-per-abi-pre_src_install pre_abi_install
-pre_abi_install() {
- cd "$(abi_builddir)" || die
-}
-
-ehook autotools-multilib-native-post_src_install post_native_install
-post_native_install() {
- cd "$(abi_builddir)" || die
- if ! use minimal; then
- dobin shell/js
- if use jit; then
- pax-mark m "${ED}/usr/bin/js"
- fi
- fi
-}
-
-ehook autotools-multilib-global-post_src_install post_install
-post_install() {
- cd "${BUILDDIR}"
- dodoc ../../README
- dohtml README.html
- # install header files needed but not part of build system
- insinto /usr/include/js
- doins ../public/*.h
- insinto /usr/include/js/mozilla
- doins "${S}"/mfbt/*.h
-
- if ! use static-libs; then
- # We can't actually disable building of static libraries
- # They're used by the tests and in a few other places
- find "${D}" -iname '*.a' -delete || die
- fi
-}