summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJens Pranaitis <jens@chaox.net>2010-05-27 14:45:14 +0200
committerJens Pranaitis <jens@chaox.net>2010-05-27 14:45:14 +0200
commite808e8dbee8752c7c3796149758b2129fc48e3dd (patch)
tree2d44afcc53d1b468052e988b511857810aa7b858 /sys-apps
parentadded moblin-image-creator2 (diff)
downloadjensp-e808e8dbee8752c7c3796149758b2129fc48e3dd.tar.gz
jensp-e808e8dbee8752c7c3796149758b2129fc48e3dd.tar.bz2
jensp-e808e8dbee8752c7c3796149758b2129fc48e3dd.zip
added maemo-flasher
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/maemo-flasher35/Manifest2
-rw-r--r--sys-apps/maemo-flasher35/maemo-flasher35-2.5.2.2.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/maemo-flasher35/Manifest b/sys-apps/maemo-flasher35/Manifest
new file mode 100644
index 0000000..9f113b7
--- /dev/null
+++ b/sys-apps/maemo-flasher35/Manifest
@@ -0,0 +1,2 @@
+DIST maemo_flasher-3.5_2.5.2.2.tar.gz 48619 RMD160 846635ece4417140e858b73efb6164ea15f73039 SHA1 2a4f9fd1bad67419f515b3083d447c352bfa0aea SHA256 2072c7d146e72ba238723ebc639ad0fa6a61fc1f5305463a6bcc76ccb302723e
+EBUILD maemo-flasher35-2.5.2.2.ebuild 754 RMD160 deb9dcc00f5376f49880d0b3088d4e46c74e6828 SHA1 d26dadc1ff0c94422a7698516a2b01db006e5f21 SHA256 55e46f47f040b0e17b6d9bf2c952d85a58dbf1c684f7c52896b23c707958f138
diff --git a/sys-apps/maemo-flasher35/maemo-flasher35-2.5.2.2.ebuild b/sys-apps/maemo-flasher35/maemo-flasher35-2.5.2.2.ebuild
new file mode 100644
index 0000000..2d0f02a
--- /dev/null
+++ b/sys-apps/maemo-flasher35/maemo-flasher35-2.5.2.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+MY_PN="${PN/-/_}"
+MY_PN="${MY_PN/35/}"
+MY_PV="3.5_${PV}"
+MY_P="${MY_PN}-${MY_PV}"
+
+FN="${MY_P}.tar.gz"
+DESCRIPTION="Firmware flasher for Maemo"
+HOMEPAGE="http://www.maemo.org"
+SRC_URI="${FN}"
+
+LICENSE="Nokia-EULA"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+RESTRICT="fetch strip"
+
+DEPEND="virtual/libc"
+RDEPEND="${DEPEND}"
+
+pkg_nofetch() {
+ elog "Please obtain ${FN} from
+ http://tablets-dev.nokia.com/maemo-dev-env-downloads.php
+ and place it in ${DISTDIR}"
+}
+
+S="${WORKDIR}"/${MY_P}
+
+src_install() {
+ newbin flasher-3.5 flasher || die
+ newman man/man1/flasher-3.5.1 flasher.1 || die
+ dodoc doc/changelog doc/README.Debian || die
+}