summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Riley <justin.t.riley@gmail.com>2014-04-14 23:19:34 -0400
committerJustin Riley <justin.t.riley@gmail.com>2014-04-14 23:19:34 -0400
commit86023588386da6b7fbec0da4a2df7524ac69d5c0 (patch)
tree74f8bd1aff936572172d30462c30d87f06fe26d2 /media-gfx
parentadd ebuild for et-sdl-sound-29 (diff)
downloadjtriley-86023588386da6b7fbec0da4a2df7524ac69d5c0.tar.gz
jtriley-86023588386da6b7fbec0da4a2df7524ac69d5c0.tar.bz2
jtriley-86023588386da6b7fbec0da4a2df7524ac69d5c0.zip
cruft clean up
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/fontypython/Manifest1
-rw-r--r--media-gfx/fontypython/files/fontypython-0.4.4-fix-pil-imports.patch39
-rw-r--r--media-gfx/fontypython/files/fontypython-0.4.4-select-wx-2.8.patch11
-rw-r--r--media-gfx/fontypython/fontypython-0.4.4.ebuild37
4 files changed, 0 insertions, 88 deletions
diff --git a/media-gfx/fontypython/Manifest b/media-gfx/fontypython/Manifest
deleted file mode 100644
index 8de31b5..0000000
--- a/media-gfx/fontypython/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST fontypython-0.4.4.tar.gz 361335 SHA256 cb7ecba75f35b1db2ae0b171c06433cd119be98b589a5af2f7642a343ff97a4b SHA512 a89c654c9dcd8fc89d3ad91772f856d2d2570a96b3b60f52eed9db217f45e91a55f3044f0e4d1736c5402cde3a6598a353ae59285c892e80034f7baba15f9825 WHIRLPOOL c4a5364108bba2595cecf13f4532115bdaa24503ea9f1d949d618927b51e4d11df710e050fc93442cb42c012bb315e4e53ff8e2adf9f9c32b4b5cd6e1905e11b
diff --git a/media-gfx/fontypython/files/fontypython-0.4.4-fix-pil-imports.patch b/media-gfx/fontypython/files/fontypython-0.4.4-fix-pil-imports.patch
deleted file mode 100644
index 6868914..0000000
--- a/media-gfx/fontypython/files/fontypython-0.4.4-fix-pil-imports.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff --git a/fontypythonmodules/fontcontrol.py b/fontypythonmodules/fontcontrol.py
-index e156758..cff34f5 100644
---- a/fontypythonmodules/fontcontrol.py
-+++ b/fontypythonmodules/fontcontrol.py
-@@ -16,7 +16,7 @@
- ## along with Fonty Python. If not, see <http://www.gnu.org/licenses/>.
-
- import os, sys, locale, glob, errno
--import Image, ImageFont, ImageDraw
-+from PIL import Image, ImageFont, ImageDraw
- import fontybugs, fpsys
- from pathcontrol import *
-
-diff --git a/fontypythonmodules/fpsys.py b/fontypythonmodules/fpsys.py
-index f9572ae..fa1a98f 100644
---- a/fontypythonmodules/fpsys.py
-+++ b/fontypythonmodules/fpsys.py
-@@ -159,7 +159,7 @@ def checkFonts( dirtocheck, printer ):
- global segfonts
-
- code = """
--import ImageFont
-+from PIL import ImageFont
- try:
- font=ImageFont.truetype("%s", 24, 0)
- dud=font.getname()
-diff --git a/fontypythonmodules/sanitycheck.py b/fontypythonmodules/sanitycheck.py
-index cf4fcc1..7e46e9a 100644
---- a/fontypythonmodules/sanitycheck.py
-+++ b/fontypythonmodules/sanitycheck.py
-@@ -24,7 +24,7 @@ import imp
-
- ## PIL : Is it there?
- try:
-- import Image, ImageFont, ImageDraw
-+ from PIL import Image, ImageFont, ImageDraw
- except:
- print strings.PILError
- raise SystemExit
diff --git a/media-gfx/fontypython/files/fontypython-0.4.4-select-wx-2.8.patch b/media-gfx/fontypython/files/fontypython-0.4.4-select-wx-2.8.patch
deleted file mode 100644
index 47f80e7..0000000
--- a/media-gfx/fontypython/files/fontypython-0.4.4-select-wx-2.8.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff --git a/start_fontypython b/start_fontypython
-index 1de3888..a9bdc11 100755
---- a/start_fontypython
-+++ b/start_fontypython
-@@ -21,4 +21,6 @@ import os
- ## Just clear up some sad facts:
- if os.name != "posix": sys.exit(_("Sorry, only Gnu/Linux is supported at the moment."))
- ## start the show!
-+import wxversion
-+wxversion.select("2.8")
- import fontypythonmodules.start
diff --git a/media-gfx/fontypython/fontypython-0.4.4.ebuild b/media-gfx/fontypython/fontypython-0.4.4.ebuild
deleted file mode 100644
index 43c35e3..0000000
--- a/media-gfx/fontypython/fontypython-0.4.4.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/fontypython/fontypython-0.4.4.ebuild,v 1.1 2013/02/05 01:18:32 dirtyepic Exp $
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7} )
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-jython 2.7-pypy-*"
-
-inherit distutils-r1 multilib toolchain-funcs
-
-DESCRIPTION="Font preview application"
-HOMEPAGE="http://savannah.nongnu.org/projects/fontypython"
-SRC_URI="http://download.savannah.nongnu.org/releases/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-# Crashes w/ debug build of wxGTK (#201315)
-DEPEND="virtual/python-imaging
- dev-python/wxpython:2.8
- x11-libs/wxGTK:2.8[-debug]"
-RDEPEND="${DEPEND}"
-
-PYTHON_MODNAME="fontypythonmodules"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-pil-imports.patch"
- "${FILESDIR}/${P}-select-wx-2.8.patch"
-)
-
-python_install_all() {
- distutils-r1_python_install_all
- doman "${S}"/fontypython.1
-}