aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2019-09-08 12:24:48 +0100
committerPaul Healy <lmiphay@gmail.com>2019-09-08 12:24:48 +0100
commita615b0fd950a4c09556688a7c166d1692ef989f3 (patch)
treeccbf3de9318f8bcdcaa422c72fa1701dca76e294 /www-apps
parentremove old ebuilds; un-keyword .4 (security) (diff)
downloadlmiphay-a615b0fd950a4c09556688a7c166d1692ef989f3.tar.gz
lmiphay-a615b0fd950a4c09556688a7c166d1692ef989f3.tar.bz2
lmiphay-a615b0fd950a4c09556688a7c166d1692ef989f3.zip
revbump gitea
Signed-off-by: Paul Healy <lmiphay@gmail.com>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/gitea/Manifest2
-rw-r--r--www-apps/gitea/gitea-1.9.3.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/www-apps/gitea/Manifest b/www-apps/gitea/Manifest
index b833c28..155aa47 100644
--- a/www-apps/gitea/Manifest
+++ b/www-apps/gitea/Manifest
@@ -4,4 +4,6 @@ AUX gitea.initd-r1 688 BLAKE2B eb2341dee53f3fd92c49137855615d9ae7ca77efc396e2d2e
AUX gitea.logrotated 87 BLAKE2B 373830ddd6eed0ce2f0f7b1dab14e4a253e5a56a73f477cfadbc6deec373846d4df2d697735391581771699d5a6513acb0e14a446873de01eba10d19e3a6bd88 SHA512 798f3fc33026f19dd31ffa78b9b1ed313d7b82b19c047f509e896c1798b2925a1bb7c4998d98a6b47e728979bf7132fb1c2a80eb7fda096a763d6791631cb6d4
AUX gitea.service 472 BLAKE2B 4c728e2987d0c0a86e65d4b9c1a59f6193ff8a3f9b066991a06f495ad1c5586b3497c71fca1cce5b65f167af09343e7bf3215ee5e8fdefa539e384198d2d88d6 SHA512 6666fe3b4cdbb78a58db4a6bf47a15e6be9ab30b666c6eb77a9e8a002d8c0abd510fc75ef463a11ee6892ab12c98943774616072cb64fd9f2fa42ff8f676aa95
DIST gitea-1.9.2.tar.gz 24073823 BLAKE2B ca465a9825ee3fbf90255a529311d899c5d068062f5bd928ea9b24a5af6f1f45ffbd9539d9fd157776282a7b020ac182f3f3be57b5f3c33c8ec13ad3bebca22a SHA512 00c91032948feb76899835e874c5d11828b24d1e112b90d5bc645d6acc9965744123f879562629c8af02285d73e42dda54689697523bd16a5acce69bbed9b989
+DIST gitea-1.9.3.tar.gz 24064564 BLAKE2B f65c10d335735e107a8bc24e102c6e3e979516f3c557483af83a49358be7441b12e948b04a540c2981f71eb2424f8205488816251782ab0f132a549ee22c3349 SHA512 331a719cfec73f64650525c17d035c3df1ff23703196a8b0d4495693eecac7cced1f103012b694e8b37b9ee4ebf16f252f303a7525c06512c3124bed66043e27
EBUILD gitea-1.9.2.ebuild 1950 BLAKE2B 7932c25897f91a74ed9757abb9ca56b54b9c83fcec1a528954a7d3b93bfd57c59feddb31b558d3be4757ffd2c6bd1d5552be9713b2d02a286288a8dcbab26f2e SHA512 55b2b54234e23c778f4793526981c5744ec1dd0b29dc675c65855c5da6c99420c4859e7836439c0208d1893f3735dbeb0fda00fe87419c5c2ea28cb0cc7221eb
+EBUILD gitea-1.9.3.ebuild 1950 BLAKE2B 7932c25897f91a74ed9757abb9ca56b54b9c83fcec1a528954a7d3b93bfd57c59feddb31b558d3be4757ffd2c6bd1d5552be9713b2d02a286288a8dcbab26f2e SHA512 55b2b54234e23c778f4793526981c5744ec1dd0b29dc675c65855c5da6c99420c4859e7836439c0208d1893f3735dbeb0fda00fe87419c5c2ea28cb0cc7221eb
diff --git a/www-apps/gitea/gitea-1.9.3.ebuild b/www-apps/gitea/gitea-1.9.3.ebuild
new file mode 100644
index 0000000..1da8239
--- /dev/null
+++ b/www-apps/gitea/gitea-1.9.3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit user systemd golang-build golang-vcs-snapshot
+
+EGO_PN="code.gitea.io/gitea"
+# network sandbox issue
+KEYWORDS=""
+
+DESCRIPTION="A painless self-hosted Git service, written in Go"
+HOMEPAGE="https://github.com/go-gitea/gitea"
+SRC_URI="https://github.com/go-gitea/gitea/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-go/go-bindata"
+RDEPEND="dev-vcs/git"
+
+pkg_setup() {
+ enewgroup git
+ enewuser git -1 /bin/bash /var/lib/gitea git
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/\"main.Version.*$/\"main.Version=${PV}\"/"\
+ -e "s/-ldflags '-s/-ldflags '/" \
+ -e "s/GOFLAGS := -i -v/GOFLAGS := -v/" \
+ src/${EGO_PN}/Makefile || die
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" emake -C src/${EGO_PN} generate
+ TAGS="bindata pam sqlite" LDFLAGS="" CGO_LDFLAGS="-fno-PIC" GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" emake -C src/${EGO_PN} build
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin gitea
+ insinto /var/lib/gitea/conf
+ newins custom/conf/app.ini.sample app.ini.example
+ popd || die
+ newinitd "${FILESDIR}"/gitea.initd-r1 gitea
+ newconfd "${FILESDIR}"/gitea.confd gitea
+ keepdir /var/log/gitea /var/lib/gitea/data
+ fowners -R git:git /var/log/gitea /var/lib/gitea/
+ systemd_dounit "${FILESDIR}/gitea.service"
+}
+
+pkg_postinst() {
+ if [[ ! -e "${EROOT}/var/lib/gitea/conf/app.ini" ]]; then
+ elog "No app.ini found, copying initial config over"
+ cp "${FILESDIR}"/app.ini "${EROOT}"/var/lib/gitea/conf/ || die
+ chown git:git /var/lib/gitea/conf/app.ini
+ else
+ elog "app.ini found, please check example file for possible changes"
+ ewarn "Please note that environment variables have been changed:"
+ ewarn "GITEA_WORK_DIR is set to /var/lib/gitea (previous value: unset)"
+ ewarn "GITEA_CUSTOM is set to '\$GITEA_WORK_DIR/custom' (previous: /var/lib/gitea)"
+ fi
+}