summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/rtv/rtv-1.13.0.ebuild')
-rw-r--r--net-misc/rtv/rtv-1.13.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/rtv/rtv-1.13.0.ebuild b/net-misc/rtv/rtv-1.13.0.ebuild
new file mode 100644
index 0000000..bea16b5
--- /dev/null
+++ b/net-misc/rtv/rtv-1.13.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{3,4,5} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="RTV provides an interface to view and interact with reddit from your terminal."
+HOMEPAGE="https://github.com/michael-lazar/rtv"
+SRC_URI="https://github.com/michael-lazar/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# S="${WORKDIR}/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/praw[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/mailcap-fix[${PYTHON_USEDEP}]
+ dev-python/kitchen[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-lang/python[ncurses]"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-praw-fix.patch"
+}