summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtur Maciąg <maciag.artur@gmail.com>2010-07-07 14:04:29 +0200
committerArtur Maciąg <maciag.artur@gmail.com>2010-07-07 14:04:29 +0200
commit597ea225de3092b166066752075127222bcd133f (patch)
tree2d372a2e00ec2f1344179e0bf889b83f6cb28041
parent[dev-python/routes] ebuild specific version 1.8 added; required by reddit (diff)
downloadpiczu-597ea225de3092b166066752075127222bcd133f.tar.gz
piczu-597ea225de3092b166066752075127222bcd133f.tar.bz2
piczu-597ea225de3092b166066752075127222bcd133f.zip
[www-servers/cherokee] removed old version
-rw-r--r--www-servers/cherokee/cherokee-0.11.3.ebuild99
-rw-r--r--www-servers/cherokee/files/cherokee-initd-0.924
2 files changed, 0 insertions, 123 deletions
diff --git a/www-servers/cherokee/cherokee-0.11.3.ebuild b/www-servers/cherokee/cherokee-0.11.3.ebuild
deleted file mode 100644
index 230c1f2..0000000
--- a/www-servers/cherokee/cherokee-0.11.3.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: Exp $
-
-WANT_AUTOCONF="latest"
-
-inherit eutils pam versionator libtool autotools
-
-DESCRIPTION="An extremely fast and tiny web server."
-SRC_URI="http://www.cherokee-project.com/download/$(get_version_component_range 1-2)/${PV}/${P}.tar.gz"
-HOMEPAGE="http://www.cherokee-project.com/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="ipv6 ssl gnutls static pam coverpage threads kernel_linux admin trace"
-
-RDEPEND=">=sys-libs/zlib-1.1.4-r1
- ssl? ( dev-libs/openssl )
- pam? ( virtual/pam )
- admin? ( dev-lang/python )"
-DEPEND="${RDEPEND}"
-
-src_compile() {
- local myconf
-
- if use static ; then
- myconf="${myconf} --enable-static --enable-static-module=all"
- else
- myconf="${myconf} --disable-static"
- fi
-
- local os="Unknown"
- case "${CHOST}" in
- *-freebsd*)
- os="FreeBSD" ;;
- *-netbsd*)
- os="NetBSD" ;;
- *-openbsd*)
- os="OpenBSD" ;;
- *)
- os="Linux" ;;
- esac
-
- econf \
- ${myconf} \
- $(use_enable pam) \
- $(use_enable ipv6) \
- $(use_enable threads pthread) \
- $(use_enable ssl tls) \
- $(use_enable trace) \
- $(use_enable kernel_linux epoll) \
- --disable-dependency-tracking \
- --enable-os-string="Gentoo ${os}" \
- --with-wwwroot=/var/www/localhost/htdocs \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- || die "configure failed"
-
- emake || die "emake failed"
-}
-
-src_install () {
- emake -j1 DESTDIR="${D}" docdir="/usr/share/doc/${PF}/html" install || die "make install failed"
- dodoc AUTHORS ChangeLog TODO
-
- newpamd pam.d_cherokee ${PN} || die "newpamd failed"
- newinitd "${FILESDIR}/${PN}-initd-0.9" ${PN} || die "newinitd failed"
-
- dodir /usr/share/doc/${PF}/contrib
- insinto /usr/share/${PF}/contrib
- doins contrib/05to06.py
- doins contrib/06to07.py
- doins contrib/07to08.py
- doins contrib/08to09.py
- doins contrib/09to010.py
-
- keepdir /etc/cherokee/mods-enabled /etc/cherokee/sites-enabled /var/www/localhost/htdocs
-
- use coverpage || rm -rf "${D}"/var/www/localhost/htdocs/{index.html,images}
- use admin || rm -rf "${D}"/usr/sbin/admin "${D}"/usr/share/cherokee/admin
-
-}
-
-pkg_postinst() {
- enewgroup cherokee
- enewuser cherokee -1 -1 /var/www/localhost cherokee
-
- if use admin ; then
- echo ""
- elog "Just run 'cherokee-admin' and go to: http://localhost:9090"
- echo ""
- else
- echo ""
- elog "Try USE=admin if you want a easy way to configure cherokee."
- echo ""
- fi
-}
diff --git a/www-servers/cherokee/files/cherokee-initd-0.9 b/www-servers/cherokee/files/cherokee-initd-0.9
deleted file mode 100644
index 28fb290..0000000
--- a/www-servers/cherokee/files/cherokee-initd-0.9
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/cherokee/files/cherokee-initd-0.6,v 1.2 2008/03/25 10:39:35 bass Exp $
-
-PIDFILE=/var/run/cherokee.pid
-
-depend() {
- need net
-}
-
-start() {
- ebegin "Starting Cherokee Web Server"
- start-stop-daemon --start -b --pidfile ${PIDFILE} \
- --exec /usr/sbin/cherokee
- eend $?
-}
-
-stop() {
- ebegin "Stopping Cherokee Web Server"
- start-stop-daemon --stop --pidfile ${PIDFILE} \
- --exec /usr/sbin/cherokee
- eend $?
-}