summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/fatrat/fatrat-1.2.9999.ebuild')
-rw-r--r--net-misc/fatrat/fatrat-1.2.9999.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/net-misc/fatrat/fatrat-1.2.9999.ebuild b/net-misc/fatrat/fatrat-1.2.9999.ebuild
deleted file mode 100644
index 3c46f7b..0000000
--- a/net-misc/fatrat/fatrat-1.2.9999.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="2"
-
-EGIT_REPO_URI="git://git.dolezel.info/fatrat.git"
-EGIT_BRANCH="1.2"
-
-inherit cmake-utils eutils git-2 qt4-r2
-
-DESCRIPTION="Qt4-based download/upload manager"
-HOMEPAGE="http://fatrat.dolezel.info/"
-SRC_URI=""
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="bittorrent +curl -debug doc jabber nls webinterface"
-
-RDEPEND="x11-libs/qt-gui:4[dbus]
- x11-libs/qt-svg:4
- bittorrent? ( >=net-libs/rb_libtorrent-0.14.1
- >=dev-cpp/asio-1.1.0
- x11-libs/qt-webkit:4 )
- curl? ( >=net-misc/curl-7.18.2 )
- doc? ( x11-libs/qt-assistant:4 )
- jabber? ( net-libs/gloox )
- webinterface? ( x11-libs/qt-script:4 )"
-DEPEND=">=dev-util/cmake-2.6.0
- ${RDEPEND}"
-
-S="${WORKDIR}/${PN}"
-
-src_unpack() {
- # this is a completely optional and NOT automagic dep
- # (it is dynamically loaded)
- if ! has_version dev-libs/geoip; then
- einfo "If you want the GeoIP support, then emerge dev-libs/geoip."
- fi
- git-2_src_unpack
-}
-
-src_configure() {
- local myconf=""
- use debug && myconf="-DCMAKE_BUILD_TYPE=Debug"
- cmake . \
- -DCMAKE_INSTALL_PREFIX="/usr" \
- $(cmake-utils_use_with bittorrent BITTORRENT) \
- $(cmake-utils_use_with curl CURL) \
- $(cmake-utils_use_with doc DOCUMENTATION) \
- $(cmake-utils_use_with jabber JABBER) \
- $(cmake-utils_use_with nls NLS) \
- $(cmake-utils_use_with webinterface WEBINTERFACE) \
- ${myconf} || die "cmake failed"
-}
-
-src_install() {
- use bittorrent && echo "MimeType=application/x-bittorrent;" >> "${S}"/data/${PN}.desktop
- emake DESTDIR="${D}" install || die "make install failed"
-}