aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Shelton <stuart@shelton.me>2014-03-21 11:37:46 +0000
committerStuart Shelton <stuart@shelton.me>2014-03-21 11:37:46 +0000
commitba332aedb0f9bcf87e4610f6bacd33d1b20a90c3 (patch)
treefe2eeebf9e81b33b7674b3a3fdda50669a59ee9f /dev-ruby
parentUpdate net-analyzer/rrdtool Manifest (diff)
downloadsrcshelton-ba332aedb0f9bcf87e4610f6bacd33d1b20a90c3.tar.gz
srcshelton-ba332aedb0f9bcf87e4610f6bacd33d1b20a90c3.tar.bz2
srcshelton-ba332aedb0f9bcf87e4610f6bacd33d1b20a90c3.zip
Update dev-ruby/rake-10.1.1
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rake/rake-10.0.3.ebuild64
-rw-r--r--dev-ruby/rake/rake-10.1.1.ebuild (renamed from dev-ruby/rake/rake-10.1.0.ebuild)8
2 files changed, 4 insertions, 68 deletions
diff --git a/dev-ruby/rake/rake-10.0.3.ebuild b/dev-ruby/rake/rake-10.0.3.ebuild
deleted file mode 100644
index e9ea7ca7..00000000
--- a/dev-ruby/rake/rake-10.0.3.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake/rake-0.9.2.2.ebuild,v 1.16 2013/01/28 15:16:10 aballier Exp $
-
-EAPI=4
-USE_RUBY="ree18 ruby18 ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGES README.rdoc TODO"
-
-RUBY_FAKEGEM_TASK_TEST=""
-
-inherit bash-completion ruby-fakegem
-
-DESCRIPTION="Make-like scripting in Ruby"
-HOMEPAGE="http://rake.rubyforge.org/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="bash-completion doc"
-
-DEPEND="${DEPEND} app-arch/gzip"
-RDEPEND="${RDEPEND}"
-
-ruby_add_bdepend "doc? ( dev-ruby/rdoc )
- test? ( dev-ruby/minitest )"
-
-all_ruby_prepare() {
- # Comment out unimportant test which failes on ruby18 at least.
- sed -i -e '/def test_classic_namespace/,/^ end/ s:^:#:' test/test_rake_application_options.rb || die
-
- # Avoid tests which can't work in bootstrapping because the test runs
- # in a directory that can't access the file being loaded.
- rm test/test_rake_clean.rb || die
- sed -i -e '/test_run_code_rake/,/^ end/ s:^:#:' test/test_rake_test_task.rb || die
-
- # Decompress the file. The compressed version has errors, ignore them.
- zcat doc/rake.1.gz > doc/rake.1
-}
-
-all_ruby_compile() {
- if use doc; then
- ruby -Ilib bin/rake rdoc || die "doc generation failed"
- fi
-}
-
-each_ruby_test() {
- ${RUBY} bin/rake test || die "tests failed"
-}
-
-all_ruby_install() {
- ruby_fakegem_binwrapper rake
-
- if use doc; then
- pushd html
- dohtml -r *
- popd
- fi
-
- doman doc/rake.1
-
- dobashcompletion "${FILESDIR}"/rake.bash-completion rake
-}
diff --git a/dev-ruby/rake/rake-10.1.0.ebuild b/dev-ruby/rake/rake-10.1.1.ebuild
index ea1a4490..17f72007 100644
--- a/dev-ruby/rake/rake-10.1.0.ebuild
+++ b/dev-ruby/rake/rake-10.1.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake/rake-0.9.6.ebuild,v 1.4 2013/09/01 14:45:57 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake/rake-0.9.6-r1.ebuild,v 1.1 2013/12/26 09:26:38 graaff Exp $
-EAPI=4
-USE_RUBY="ree18 ruby18 ruby19 ruby20 jruby"
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="CHANGES README.rdoc TODO"
@@ -28,7 +28,7 @@ ruby_add_bdepend "doc? ( dev-ruby/rdoc )
all_ruby_prepare() {
# Comment out unimportant test which failes on ruby18 at least.
- sed -i -e '/def test_classic_namespace/,/^ end/ s:^:#:' test/test_rake_application_options.rb || die
+ #sed -i -e '/def test_classic_namespace/,/^ end/ s:^:#:' test/test_rake_application_options.rb || die
# Avoid tests which can't work in bootstrapping because the test runs
# in a directory that can't access the file being loaded.