summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/cairo-dock/cairo-dock-9999.ebuild')
-rw-r--r--x11-misc/cairo-dock/cairo-dock-9999.ebuild26
1 files changed, 4 insertions, 22 deletions
diff --git a/x11-misc/cairo-dock/cairo-dock-9999.ebuild b/x11-misc/cairo-dock/cairo-dock-9999.ebuild
index 12e54d6..81690fb 100644
--- a/x11-misc/cairo-dock/cairo-dock-9999.ebuild
+++ b/x11-misc/cairo-dock/cairo-dock-9999.ebuild
@@ -4,17 +4,18 @@
EAPI="2"
+# The ebuild depends on CMAKE and also the BZR revision control system
+# which is used for pulling the source code from the LaunchPad repository
inherit cmake-utils bzr
-# Launchpad repository where "cairo-dock" lives:
-EBZR_REPO_URI="lp:cairo-dock-core"
+# The aaunchpad repository where "cairo-dock" lives:
+EBZR_REPO_URI="lp:cairo-dock-core"
# You can specify a certain revision from the repository here.
# Or comment it out to choose the latest ("live") revision.
#EBZR_REVISION="959"
-
DESCRIPTION="Cairo-dock is a fast, responsive, Mac OS X-like dock."
HOMEPAGE="https://launchpad.net/cairo-dock-core/"
# Next line is not needed because the BZR repository is specified further above
@@ -69,33 +70,14 @@ pkg_setup()
ewarn ""
ewarn ""
- # We have to deal with the weird behavior of cairo-dock installing
- # stuff under "/usr/usr/lib" for 32-bit systems.
- # ... installing stuff under "/usr/usr/lib6464" for 64-bit systems.
-
- # So, we do the following so that files get installed into the normal directory...
-
- mkdir /usr/usr
- ln -s /usr/lib /usr/usr/lib
- ln -s /usr/lib64 /usr/usr/lib6464/
-
- # Note that the first 'ln' will fail if we're on a 64-bit system. That's okay.
- # Note that the second 'ln' will fail if we're on a 32-bit system. That's okay.
-
}
-
src_prepare() {
bzr_src_prepare
}
-# Not sure what the next line does. Can't find any documentation about it.
-# Maybe it does nothing? It came from someone else's old ebuild for
-# cairo-dock. Help?!
-#MAKE_IN_SOURCE_BUILD=true
-
src_configure() {