summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-12-18 15:53:22 +0000
committerMike Frysinger <vapier@gentoo.org>2002-12-18 15:53:22 +0000
commit286ceb16f4f99f61a893ea2407e54c5d7d1fbe57 (patch)
treed623c17e26ab4edf59fff50828c3b2efd1015e12 /app-text/mlview/mlview-0.0.3_rc1.ebuild
parentChanged econf||die to econf (diff)
downloadgentoo-2-286ceb16f4f99f61a893ea2407e54c5d7d1fbe57.tar.gz
gentoo-2-286ceb16f4f99f61a893ea2407e54c5d7d1fbe57.tar.bz2
gentoo-2-286ceb16f4f99f61a893ea2407e54c5d7d1fbe57.zip
Changed econf||die to econf
Diffstat (limited to 'app-text/mlview/mlview-0.0.3_rc1.ebuild')
-rw-r--r--app-text/mlview/mlview-0.0.3_rc1.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/app-text/mlview/mlview-0.0.3_rc1.ebuild b/app-text/mlview/mlview-0.0.3_rc1.ebuild
index e558f105ca2f..86a3799efac7 100644
--- a/app-text/mlview/mlview-0.0.3_rc1.ebuild
+++ b/app-text/mlview/mlview-0.0.3_rc1.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mlview/mlview-0.0.3_rc1.ebuild,v 1.1 2002/11/05 12:21:45 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mlview/mlview-0.0.3_rc1.ebuild,v 1.2 2002/12/18 15:53:22 vapier Exp $
+MY_P=${P/_/}
DESCRIPTION="XML Editor for Gnome"
HOMEPAGE="http://www.nongnu.org/mlview/"
-MY_P=${P/_/}
SRC_URI="http://savannah.gnu.org/download/${PN}/tarballs/${MY_P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
@@ -18,20 +19,15 @@ DEPEND="gnome-base/gnome-libs
S="${WORKDIR}/${MY_P}"
src_compile() {
- local myconf=""
+ econf `use_enable nls`
- use nls || myconf="--disable-nls"
-
- econf $myconf || die "./configure failed"
-
# The presence of this file breaks the compilation without nls
[ -f ${S}/intl/libintl.h ] && rm ${S}/intl/libintl.h
-
+
emake || die "Compilation failed"
}
src_install() {
- einstall || die "Installation failed"
-
+ einstall
dodoc ABOUT-NLS AUTHORS BRANCHES COPYING ChangeLog NEWS README TODO
}