summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-26 12:54:33 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-26 12:54:33 +0000
commit886fe0657f7f7f276ef5bec7ab14516bd48eb5a3 (patch)
tree260c089fbffc865629c95cd2cd243933d16cac97 /sys-apps/file
parent*** empty log message *** (diff)
downloadgentoo-2-886fe0657f7f7f276ef5bec7ab14516bd48eb5a3.tar.gz
gentoo-2-886fe0657f7f7f276ef5bec7ab14516bd48eb5a3.tar.bz2
gentoo-2-886fe0657f7f7f276ef5bec7ab14516bd48eb5a3.zip
*** empty log message ***
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/file-3.33.ebuild29
-rw-r--r--sys-apps/file/files/digest-file-3.331
2 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/file/file-3.33.ebuild b/sys-apps/file/file-3.33.ebuild
new file mode 100644
index 000000000000..8906286fd7eb
--- /dev/null
+++ b/sys-apps/file/file-3.33.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-3.33.ebuild,v 1.1 2000/11/26 12:52:15 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Program to identify a file's format by scanning binary data for patters"
+#unfortunately, this ftp site doesn't support passive ftp
+#maybe we can find an alternative for those behind firewalls, or mirror
+#on cvs.gentoo.org
+SRC_URI="ftp://ftp.astron.com/pub/file/${A}"
+
+src_compile() {
+ try ./configure --prefix=/usr --datadir=/etc --host=${CHOST}
+ try make
+}
+
+src_install() {
+ into /usr
+ dobin file
+ doman file.1 magic.4
+ insinto /etc
+ doins magic magic.mime
+ dodoc LEGAL.NOTICE MAINT README
+}
+
+
+
diff --git a/sys-apps/file/files/digest-file-3.33 b/sys-apps/file/files/digest-file-3.33
new file mode 100644
index 000000000000..9a0e1f33e262
--- /dev/null
+++ b/sys-apps/file/files/digest-file-3.33
@@ -0,0 +1 @@
+MD5 3b8e32ed3a79774bd92f0052fa07ca04 file-3.33.tar.gz