summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMATSUU Takuto <matsuu@gentoo.org>2009-12-19 11:14:37 +0900
committerMATSUU Takuto <matsuu@gentoo.org>2009-12-19 11:14:37 +0900
commit4f550dab24e891c03607191e9fde0237a4800b18 (patch)
tree1c648af08284c56e0d9562c6e4a480af28c6a32f
parentdev-ruby/ferret: Initial import. (diff)
downloadmatsuu-4f550dab24e891c03607191e9fde0237a4800b18.tar.gz
matsuu-4f550dab24e891c03607191e9fde0237a4800b18.tar.bz2
matsuu-4f550dab24e891c03607191e9fde0237a4800b18.zip
mail-client/sup: Initial import.
-rw-r--r--mail-client/sup/Manifest2
-rw-r--r--mail-client/sup/sup-0.9.1.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/mail-client/sup/Manifest b/mail-client/sup/Manifest
new file mode 100644
index 0000000..7d3d356
--- /dev/null
+++ b/mail-client/sup/Manifest
@@ -0,0 +1,2 @@
+DIST sup-0.9.1.gem 138752 RMD160 39a21ab0f6ce4ee41bd5a439b5ba2f390ec00afe SHA1 b028ee10d92701e1c938443c7a882025e5a3d5d4 SHA256 aa54587c7feaec7387e4542277480456fb888189ce67efbf969e2ded36fb2e42
+EBUILD sup-0.9.1.ebuild 667 RMD160 419a1a6d4175a3e04f2846b4063f0bf6c60b5d4c SHA1 ad0cd2d689c24cc90d7d59915440a2ed545271a6 SHA256 318b97fb4dfc7fc5b390303c064941cd353648d721c47ac0bcde39e41c16fed7
diff --git a/mail-client/sup/sup-0.9.1.ebuild b/mail-client/sup/sup-0.9.1.ebuild
new file mode 100644
index 0000000..43e3048
--- /dev/null
+++ b/mail-client/sup/sup-0.9.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+inherit gems
+
+DESCRIPTION="a console-based email client for people with a lot of email"
+HOMEPAGE="http://sup.rubyforge.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-ruby/ferret-0.11.6
+ dev-ruby/highline
+ dev-ruby/lockfile
+ >=dev-ruby/mime-types-1
+ >=dev-ruby/ncurses-ruby-0.9.1
+ dev-ruby/net-ssh
+ dev-ruby/ruby-gettext
+ >=dev-ruby/ruby-rmail-0.17
+ >=dev-ruby/trollop-1.12
+ dev-ruby/fastthread"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ gems_src_install
+ rm "${D}${GEMSDIR}/gems/${P}/lib/ncurses.rb" || die
+}
+