aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-05-07 22:12:47 +0200
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-06-27 14:20:34 +0200
commit2442677d17ad8ece249e6418c64477a3ff29290d (patch)
tree88748e9ba41f324f9b40c0a71dd7241bc5ea6f57
parentsci-physics/tauola: update EAPI 7 -> 8 (diff)
downloadsci-2442677d17ad8ece249e6418c64477a3ff29290d.tar.gz
sci-2442677d17ad8ece249e6418c64477a3ff29290d.tar.bz2
sci-2442677d17ad8ece249e6418c64477a3ff29290d.zip
sci-physics/photos: new package, add 3.64
Co-authored-by: Andrew Nowa Ammerlaan <andrewammerlaan@gentoo.org> Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
-rw-r--r--sci-physics/photos/Manifest1
-rw-r--r--sci-physics/photos/metadata.xml23
-rw-r--r--sci-physics/photos/photos-3.64.ebuild82
3 files changed, 106 insertions, 0 deletions
diff --git a/sci-physics/photos/Manifest b/sci-physics/photos/Manifest
new file mode 100644
index 000000000..5fcd8e48e
--- /dev/null
+++ b/sci-physics/photos/Manifest
@@ -0,0 +1 @@
+DIST PHOTOS.3.64.tar.gz 1415406 BLAKE2B 503247dbcaa15d801850e8cf4981aaffd7b04c13c6542543fab88d00e08ebd6831b828ddfbd3d26469f2cddcfc21acfbeaae171f3778deaabd5abddcc1d64d0e SHA512 750e213a257479b41ac9b4848787a61035ab5ed2157d3b4e3b4b0a081241f5c76e882f66b401dcfbea363e7154aa2a4ae1ba05ac1e40a35c2e5687d10910085e
diff --git a/sci-physics/photos/metadata.xml b/sci-physics/photos/metadata.xml
new file mode 100644
index 000000000..0a24d3422
--- /dev/null
+++ b/sci-physics/photos/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexander@neuwirth-informatik.de</email>
+ <name>Alexander Puck Neuwirth</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-physics@gentoo.org</email>
+ <name>Gentoo Physics Project</name>
+ </maintainer>
+
+ <longdescription lang="en">
+ The main application of PHOTOS is the generation of QED radiative corrections in decays of any resonances, simulated by a "host" Monte Carlo generator
+ </longdescription>
+
+ <use>
+ <flag name="pythia">Build with pythia</flag>
+ <flag name="hepmc2">Build with hepmc 2</flag>
+ <flag name="hepmc3">Build with hepmc 3</flag>
+ <flag name="tauola">Build with tauola</flag>
+ </use>
+</pkgmetadata>
diff --git a/sci-physics/photos/photos-3.64.ebuild b/sci-physics/photos/photos-3.64.ebuild
new file mode 100644
index 000000000..32c09af64
--- /dev/null
+++ b/sci-physics/photos/photos-3.64.ebuild
@@ -0,0 +1,82 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fortran-2 autotools
+
+MY_PN="PHOTOS"
+MY_P=${MY_PN}.${PV}
+
+DESCRIPTION="Monte Carlo for bremsstrahlung in the decay of particles and resonances"
+HOMEPAGE="
+ https://gitlab.cern.ch/photospp/photospp
+ http://photospp.web.cern.ch/photospp/
+"
+SRC_URI="https://photospp.web.cern.ch/resources/${MY_P}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples hepmc2 hepmc3 pythia tauola"
+
+RDEPEND="
+ hepmc2? ( sci-physics/hepmc:2=[-cm(-),gev(+)] )
+ hepmc3? ( sci-physics/hepmc:3=[-cm(-),gev(+)] )
+ pythia? ( sci-physics/pythia:8= )
+ tauola? ( sci-physics/tauola[hepmc2?,hepmc3?,pythia?] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ app-text/doxygen[dot]
+ app-text/ghostscript-gpl
+ app-text/texlive
+ )
+"
+REQUIRED_USE=" || ( hepmc2 hepmc3 )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --without-mc-tester \
+ $(use_with hepmc3 hepmc3 "${EPREFIX}/usr") \
+ $(use_with hepmc2 hepmc "${EPREFIX}/usr") \
+ $(use_with pythia pythia8 "${EPREFIX}/usr") \
+ $(use_with tauola tauola "${EPREFIX}/usr")
+ # weird autoconf + Makefile
+ cat <<-EOF >> make.inc || die
+ LDFLAGS += ${LDFLAGS}
+ CFLAGS += ${CFLAGS}
+ FFLAGS += ${FFLAGS}
+ EOF
+}
+
+src_compile() {
+ emake -j1
+
+ if use doc; then
+ cd "${S}/documentation/doxy_documentation" || die
+ default
+ cd "${S}/documentation/latex_documentation" || die
+ default
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if use doc; then
+ dodoc documentation/doxy_documentation/html/*
+ dodoc documentation/latex_documentation/*.pdf
+ fi
+
+ if use examples; then
+ dodoc -r examples
+ fi
+}