summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-05 18:52:15 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-05 19:55:01 +0200
commita1e4828e2ba563dbf0aa151d1a1451171e759b38 (patch)
tree1c8ff5f7c302c27c1c5477a4495fdcfc8d72103b /dev-ros/unique_id/unique_id-9999.ebuild
parentdev-ros/test_roscpp: fix tests (diff)
downloadgentoo-a1e4828e2ba563dbf0aa151d1a1451171e759b38.tar.gz
gentoo-a1e4828e2ba563dbf0aa151d1a1451171e759b38.tar.bz2
gentoo-a1e4828e2ba563dbf0aa151d1a1451171e759b38.zip
dev-ros/unique_id: fix tests
Closes: https://bugs.gentoo.org/734686 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/unique_id/unique_id-9999.ebuild')
-rw-r--r--dev-ros/unique_id/unique_id-9999.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-ros/unique_id/unique_id-9999.ebuild b/dev-ros/unique_id/unique_id-9999.ebuild
index 3614a9ea3228..32432dfa5632 100644
--- a/dev-ros/unique_id/unique_id-9999.ebuild
+++ b/dev-ros/unique_id/unique_id-9999.ebuild
@@ -25,3 +25,10 @@ DEPEND="${RDEPEND}
dev-cpp/gtest
$(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
)"
+PATCHES=( "${FILESDIR}/tests.patch" )
+
+src_test() {
+ # Those tests fail and are commented as undefined behavior in the code
+ export GTEST_FILTER='-BoostUUID.fromUrnString:BoostUUID.fromTooLongString:BoostUUID2.fromUrnString:BoostUUID2.fromTooLongString'
+ ros-catkin_src_test
+}