summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-23 05:57:51 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-23 05:57:51 +0200
commit3b34ad3f0d5cfa06041b275a4852a9d9e136d12c (patch)
tree66e2a6cab0787dfb0052a248eb5579e9e97a2244 /media-sound/whipper
parentmedia-sound/whipper: Enable py3.12 (diff)
downloadgentoo-3b34ad3f0d5cfa06041b275a4852a9d9e136d12c.tar.gz
gentoo-3b34ad3f0d5cfa06041b275a4852a9d9e136d12c.tar.bz2
gentoo-3b34ad3f0d5cfa06041b275a4852a9d9e136d12c.zip
media-sound/whipper: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-sound/whipper')
-rw-r--r--media-sound/whipper/whipper-0.10.0.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/media-sound/whipper/whipper-0.10.0.ebuild b/media-sound/whipper/whipper-0.10.0.ebuild
deleted file mode 100644
index c865bb56dbb7..000000000000
--- a/media-sound/whipper/whipper-0.10.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-DISTUTILS_USE_PEP517="setuptools"
-
-inherit distutils-r1
-
-DESCRIPTION="A Python CD-DA ripper preferring accuracy over speed (forked from morituri)"
-HOMEPAGE="https://github.com/whipper-team/whipper"
-SRC_URI="https://github.com/whipper-team/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="media-libs/libsndfile:="
-RDEPEND="
- ${DEPEND}
- app-cdr/cdrdao
- >=dev-libs/libcdio-paranoia-0.94_p2
- dev-python/musicbrainzngs[${PYTHON_USEDEP}]
- >=dev-python/pycdio-2.1.0[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/discid[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- media-libs/mutagen[${PYTHON_USEDEP}]
- media-sound/sox[flac]"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? ( dev-python/twisted[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests unittest
-
-PATCHES=( "${FILESDIR}/${PN}-0.7.0-cdparanoia-name-fix.patch" )
-
-python_prepare_all() {
- # accurip test totally depends on network access
- rm "${PN}"/test/test_common_accurip.py || die
-
- # Test fails with
- # Log [82 chars]28Z\n\nRipping phase information:\n Drive: HL[2290 chars]31\n
- # !=
- # Log [82 chars]28Z\nRipping phase information:\n Drive: HL-D[2274 chars]31\n
- # assertion. TODO: fix test.
- rm "${PN}"/test/test_result_logger.py || die
-
- export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
- distutils-r1_python_prepare_all
-}