summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/allpathslg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/allpathslg')
-rw-r--r--sci-biology/allpathslg/Manifest3
-rw-r--r--sci-biology/allpathslg/allpathslg-42337.ebuild35
-rw-r--r--sci-biology/allpathslg/allpathslg-47093.ebuild36
-rw-r--r--sci-biology/allpathslg/allpathslg-52415.ebuild54
-rw-r--r--sci-biology/allpathslg/files/allpathslg-47093-gcc4.9.patch16
-rw-r--r--sci-biology/allpathslg/metadata.xml5
6 files changed, 149 insertions, 0 deletions
diff --git a/sci-biology/allpathslg/Manifest b/sci-biology/allpathslg/Manifest
new file mode 100644
index 000000000000..8209935b6d9e
--- /dev/null
+++ b/sci-biology/allpathslg/Manifest
@@ -0,0 +1,3 @@
+DIST allpathslg-42337.tar.gz 2739498 SHA256 a2c8f64f6ba1705b2331ca07761d189183c6745f8717ffc67ee98e9e3ca3dba6 SHA512 7595fbe14a5029578b57d16f781cbb2a0f0ad6b1af2dd770e2274f8fe2e11d0013fdff12cc85c1be748e769ffb23b7d5fe30920feef38e0e8b947d05b8bda31c WHIRLPOOL 79bda55d49877641eb55630950472a06d8f25db467dbfecde8b4d04c3ce16c071d32dd312fa9a0f72723bf4caa8f9b1d0346acf438b9671b4bed2c0672c788b9
+DIST allpathslg-47093.tar.gz 3057279 SHA256 493e21ae727250ea632b73b61545c32de2d8fb31e6a92605393ebb4af251f828 SHA512 499d23de52cad666fac663eb4a7d770b2129c4f9622f6c808ce30283429b6f67fb343f8712b07c7cb062c429117a0855da960ffc1d2ffb4e7ec2f544ba5a6314 WHIRLPOOL a3bc58dc140be3cddbd44c7035e628c4425bf86bc38592004df21d4dc91958ced9f08d667b43c15c214e53e3098805f368a856e66e5c2049b0e03d043b098ebc
+DIST allpathslg-52415.tar.gz 3129266 SHA256 3c62024a0eacdc223bc727be4718da644fb302f785c7c7347a09ff422ce96362 SHA512 afe25b07d2e07dee3ced2283ffe858f24acfb35d53e9c11fcbcc47373594453d798c344d5604eb24d5c8d3685a185a3b8807bb3547d8066cbaab8d8cf927d1d6 WHIRLPOOL de15dfeddeca2f64fd8780839c45096c28cb47ec219d781f6754f9cf65ad6dfc39b8a48aaa2c36f777282fb08ac78ef8cd04c2e1d79f4f797710d3bb38792785
diff --git a/sci-biology/allpathslg/allpathslg-42337.ebuild b/sci-biology/allpathslg/allpathslg-42337.ebuild
new file mode 100644
index 000000000000..9fb44dfcc905
--- /dev/null
+++ b/sci-biology/allpathslg/allpathslg-42337.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="De novo assembly of whole-genome shotgun microreads"
+HOMEPAGE="http://www.broadinstitute.org/science/programs/genome-biology/crd"
+SRC_URI="ftp://ftp.broadinstitute.org/pub/crd/ALLPATHS/Release-LG/latest_source_code/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+KEYWORDS="amd64 -x86"
+
+DEPEND="
+ dev-libs/boost
+ !sci-biology/allpaths
+ sci-biology/vaal"
+RDEPEND=""
+
+src_prepare() {
+ sed -i 's/-ggdb3//' configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ einstall || die
+ # Provided by sci-biology/vaal
+ for i in QueryLookupTable ScaffoldAccuracy MakeLookupTable Fastb ShortQueryLookup; do
+ rm "${D}/usr/bin/$i" || die
+ done
+}
diff --git a/sci-biology/allpathslg/allpathslg-47093.ebuild b/sci-biology/allpathslg/allpathslg-47093.ebuild
new file mode 100644
index 000000000000..ab971ec46c89
--- /dev/null
+++ b/sci-biology/allpathslg/allpathslg-47093.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="De novo assembly of whole-genome shotgun microreads"
+HOMEPAGE="http://www.broadinstitute.org/science/programs/genome-biology/crd"
+SRC_URI="ftp://ftp.broadinstitute.org/pub/crd/ALLPATHS/Release-LG/latest_source_code/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 -x86"
+
+DEPEND="
+ dev-libs/boost
+ !sci-biology/allpaths
+ sci-biology/vaal"
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc4.9.patch
+ sed -i 's/-ggdb//' configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ # Provided by sci-biology/vaal
+ for i in QueryLookupTable ScaffoldAccuracy MakeLookupTable Fastb ShortQueryLookup; do
+ rm "${ED}/usr/bin/$i" || die
+ done
+}
diff --git a/sci-biology/allpathslg/allpathslg-52415.ebuild b/sci-biology/allpathslg/allpathslg-52415.ebuild
new file mode 100644
index 000000000000..29de20e37670
--- /dev/null
+++ b/sci-biology/allpathslg/allpathslg-52415.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils flag-o-matic
+
+DESCRIPTION="De novo assembly of whole-genome shotgun microreads"
+# see also http://www.broadinstitute.org/software/allpaths-lg/blog/?page_id=12
+HOMEPAGE="http://www.broadinstitute.org/science/programs/genome-biology/crd"
+SRC_URI="ftp://ftp.broadinstitute.org/pub/crd/ALLPATHS/Release-LG/latest_source_code/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="openmp"
+
+DEPEND="
+ dev-libs/boost
+ !sci-biology/allpaths
+ sci-biology/vaal"
+RDEPEND=""
+
+pkg_pretend() {
+ # as of release 44849, GCC 4.7.0 (or higher) is required
+ # seems pre gcc-4.7 users must stay with:
+ # ftp://ftp.broadinstitute.org/pub/crd/ALLPATHS/Release-LG/latest_source_code/2013/2013-01/allpathslg-44837.tar.gz
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ [[ $(tc-getCC) == *gcc* ]] && [[ $(gcc-version) < 4.7 ]] && \
+ die "You need to use gcc >4.7"
+ fi
+}
+
+src_prepare() {
+ local i
+ sed \
+ -e 's/-ggdb//' \
+ -e 's:CEHCK:CHECK:g' \
+ -i configure.ac || die
+ for i in QueryLookupTable ScaffoldAccuracy MakeLookupTable Fastb ShortQueryLookup; do
+ sed -e "/bin_PROGRAMS/s: ${i} : :g" -i src/Makefile.am || die
+ done
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable openmp)
+ )
+ autotools-utils_src_configure
+}
diff --git a/sci-biology/allpathslg/files/allpathslg-47093-gcc4.9.patch b/sci-biology/allpathslg/files/allpathslg-47093-gcc4.9.patch
new file mode 100644
index 000000000000..46e5493d28ce
--- /dev/null
+++ b/sci-biology/allpathslg/files/allpathslg-47093-gcc4.9.patch
@@ -0,0 +1,16 @@
+ src/paths/long/VariantCallTools.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/paths/long/VariantCallTools.cc b/src/paths/long/VariantCallTools.cc
+index dfe2787..725878b 100644
+--- a/src/paths/long/VariantCallTools.cc
++++ b/src/paths/long/VariantCallTools.cc
+@@ -1674,7 +1674,7 @@ void EdgesOnRef::FindAllPathsNoLoop(const GraphT& dg, int entrace_edge, int exit
+ int n1 = to_right2[entrace_edge];
+ int n2 = to_left2[exit_edge];
+
+- PartialPath start = {{n1},{}};
++ PartialPath start{{n1},vec<int>{}};
+ stack<PartialPath> visited;
+ visited.push(start);
+ while (! visited.empty()) {
diff --git a/sci-biology/allpathslg/metadata.xml b/sci-biology/allpathslg/metadata.xml
new file mode 100644
index 000000000000..f17a827e3101
--- /dev/null
+++ b/sci-biology/allpathslg/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>