aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonaldo V. Lobato <vieira.lobato@gmail.com>2024-04-06 16:11:25 -0300
committerRonaldo V. Lobato <vieira.lobato@gmail.com>2024-04-06 16:11:25 -0300
commitb1acf715fc1194406cf6df4ab1e9239b81738a0a (patch)
tree05a75495283207b4744f90e2d98f4fd76cefc7fb /gnome-extra
parentgnome-extra/junction: add 1.7 (diff)
downloadguru-b1acf715fc1194406cf6df4ab1e9239b81738a0a.tar.gz
guru-b1acf715fc1194406cf6df4ab1e9239b81738a0a.tar.bz2
guru-b1acf715fc1194406cf6df4ab1e9239b81738a0a.zip
gnome-extra/junction:
Update ebuilds to follow QA Notice warnings: Signed-off-by: Ronaldo V. Lobato <vieira.lobato@gmail.com>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/junction/junction-1.6-r1.ebuild14
-rw-r--r--gnome-extra/junction/junction-1.7.ebuild14
2 files changed, 26 insertions, 2 deletions
diff --git a/gnome-extra/junction/junction-1.6-r1.ebuild b/gnome-extra/junction/junction-1.6-r1.ebuild
index d7d8303e6..359c485fb 100644
--- a/gnome-extra/junction/junction-1.6-r1.ebuild
+++ b/gnome-extra/junction/junction-1.6-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit meson
+inherit xdg gnome2-utils meson
TROLL_COMMIT="8d7c2be66a4bf1cbb2081121997a33662fc19cd0"
DESCRIPTION="Application/browser chooser"
@@ -56,3 +56,15 @@ src_configure() {
src_test() {
:
}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}
diff --git a/gnome-extra/junction/junction-1.7.ebuild b/gnome-extra/junction/junction-1.7.ebuild
index 63b1d9050..bf28970ab 100644
--- a/gnome-extra/junction/junction-1.7.ebuild
+++ b/gnome-extra/junction/junction-1.7.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit meson
+inherit xdg gnome2-utils meson
TROLL_COMMIT="94ced56f1b08e6955f6c8325a04c74736d39b823"
DESCRIPTION="Application/browser chooser"
@@ -56,3 +56,15 @@ src_configure() {
src_test() {
:
}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}